Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2008
    Posts
    107

    Default OX-Admin daemon dies

    Hello,

    after updating my ox installation last night to the latest snapshot (using openSUSE11.1) the ox-admin daemon dies right after starting it.

    Here are the logs:

    open-xchange-admin.log.0
    Code:
    Mar 30, 2009 6:49:58 PM org.apache.jcs.auxiliary.lateral.socket.tcp.LateralTCPService <init>
    SEVERE: Could not create sender to [127.0.0.2:57462] -- Socket is null, cannot connect to 127.0.0.2:57462
    Mar 30, 2009 6:49:58 PM org.apache.jcs.auxiliary.lateral.socket.tcp.LateralTCPCacheManager <init>
    SEVERE: Failure, lateral instance will use zombie service
    java.io.IOException: Socket is null, cannot connect to 127.0.0.2:57462
    	at org.apache.jcs.auxiliary.lateral.socket.tcp.LateralTCPSender.init(LateralTCPSender.java:141)
    	at org.apache.jcs.auxiliary.lateral.socket.tcp.LateralTCPSender.<init>(LateralTCPSender.java:111)
    	at org.apache.jcs.auxiliary.lateral.socket.tcp.LateralTCPService.<init>(LateralTCPService.java:72)
    	at org.apache.jcs.auxiliary.lateral.socket.tcp.LateralTCPCacheManager.<init>(LateralTCPCacheManager.java:167)
    	at org.apache.jcs.auxiliary.lateral.socket.tcp.LateralTCPCacheManager.getInstance(LateralTCPCacheManager.java:108)
    	at org.apache.jcs.auxiliary.lateral.socket.tcp.discovery.UDPDiscoveryReceiver$MessageHandler.run(UDPDiscoveryReceiver.java:324)
    	at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Worker.run(PooledExecutor.java:748)
    	at java.lang.Thread.run(Thread.java:636)
    osgi-admin.log
    Code:
    !SESSION 2009-03-30 19:02:09.951 -----------------------------------------------
    eclipse.buildId=unknown
    java.version=1.6.0_0
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=linux, ARCH=x86, WS=motif, NL=en_US
    Command-line arguments:  -configuration file:/opt/open-xchange/etc/admindaemon/osgi/
    
    !ENTRY com.openexchange.server 4 0 2009-03-30 19:02:11.366
    !MESSAGE 
    !STACK 0
    org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Import-Package: com.openexchange.timer; version="0.0.0"
    	at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:305)
    	at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:350)
    	at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1118)
    	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:634)
    	at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:508)
    	at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:282)
    	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:468)
    	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:195)
    	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:297)
    
    !ENTRY open_xchange_admin 4 0 2009-03-30 19:02:11.381
    !MESSAGE 
    !STACK 0
    org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Import-Package: com.openexchange.api2; version="0.0.0"
    	at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:305)
    	at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:350)
    	at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1118)
    	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:634)
    	at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:508)
    	at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:282)
    	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:468)
    	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:195)
    	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:297)
    
    !ENTRY open_xchange_admin_plugin_hosting 4 0 2009-03-30 19:02:11.384
    !MESSAGE 
    !STACK 0
    org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: open_xchange_admin; bundle-version="0.0.0"
    	at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:305)
    	at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:350)
    	at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1118)
    	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:634)
    	at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:508)
    	at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:282)
    	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:468)
    	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:195)
    	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:297)
    
    !ENTRY org.eclipse.osgi 4 0 2009-03-30 19:02:11.421
    !MESSAGE Bundle initial@reference:file:com.openexchange.server.jar/ was not resolved.
    
    !ENTRY org.eclipse.osgi 4 0 2009-03-30 19:02:11.422
    !MESSAGE Bundle initial@reference:file:open_xchange_admin.jar/ was not resolved.
    
    !ENTRY org.eclipse.osgi 4 0 2009-03-30 19:02:11.422
    !MESSAGE Bundle initial@reference:file:open_xchange_admin_plugin_hosting.jar/ was not resolved.
    BTW: I'm using Sun-Java 1.6 with the latest openSUSE-Updates, whitch worked fine for me e. g. with a 2 weeks old snapshot-Version.

    Could it be a bug or do I have to change my settings?
    Viele Gre
    Rene

    OS: Ubuntu Server amd64 12.4 LTS
    JRE: openjdk-7-jre, MySQL: 5.5, Apache 2.2, Dovecot 2.0.19
    OX-Server backend: OXSE latest
    OX-frontend: OXSE latest appsuite + ox6

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    this may be a bug but honestly you should not and never use snapshot versions for "productive" environments. Those are for developers only and might not install or run properly.

    Greetings

  3. #3
    Join Date
    Aug 2008
    Posts
    107

    Default

    well, you are right, but it isn't a productive system.

    With the actualy snapshot it's fixed again, thanks
    Viele Gre
    Rene

    OS: Ubuntu Server amd64 12.4 LTS
    JRE: openjdk-7-jre, MySQL: 5.5, Apache 2.2, Dovecot 2.0.19
    OX-Server backend: OXSE latest
    OX-frontend: OXSE latest appsuite + ox6

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •