Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 5 of 5
  1. #1
    Jeremiah Guest

    Question Problem with remote IMAPS *workaround*

    I have a problem over here with using OX-Hyperion on Debian/Etch with a remote IMAPS and SMTP Server.

    I followed the install instructions and skipped Chapter 5 (PAM/MySQL, NSSwitch, Cyrus, Postfix) since I don't want to use a local IMAP and SMTP Server)

    But I could not get OX to work with my remote (Cyrus) IMAP Server, that will only allow IMAPS (port 993) connections.
    When I try to create a user I get the following error

    Code:
    # ./createuser -A oxadmin -P adminpw -u username -d "Foo Bar" -g "Foo" -s "Bar" -p "userpw" -e "Foo.Bar@email.com" -l "de_DE" -t "Europe/Berlin" -M on --imapserver "10.110.27.240:993" --smtpserver "10.110.27.240:25"
    Server response:
     com.openexchange.admin.plugins.PluginException: com.openexchange.admin.rmi.exceptions.OXUserIMAPException: javax.mail.MessagingException: Connection refused;
      nested exception is:
            java.net.ConnectException: Connection refused
    So I created the User like:
    Code:
    # ./createuser --dbonly -A oxadmin -P adminpw -u username -d "Foo Bar" -g "Foo" -s "Bar" -p "userpw" -e "Foo.Bar@email.com" -l "de_DE" -t "Europe/Berlin" -M on --imapserver "10.110.27.240:993" --smtpserver "10.110.27.240:25"
    10

    When I now try to login as "FooBar" into the Webfrontend and try to open the email folder I get the following error:
    Code:
    Fehlermeldung: Es trat ein Socket-Fehler auf: Unconnected sockets not implemented (MSG-0092,128903892-34)
    here is a snip from the JavaLog
    Code:
    SEVERE: MSG-0092 Category=8 Message=A socket error occurred: Unconnected sockets not implemented exceptionID=255180169-13
    MSG-0092 Category=8 Message=A socket error occurred: Unconnected sockets not implemented exceptionID=255180169-13
            at com.openexchange.api2.MailInterfaceImpl.handleMessagingException(MailInterfaceImpl.java:4907)
            at com.openexchange.api2.MailInterfaceImpl.getRootFolders(MailInterfaceImpl.java:4105)
            at com.openexchange.ajax.Folder.actionGetSubfolders(Folder.java:613)
            at com.openexchange.ajax.Folder.actionGetSubfolders(Folder.java:368)
            at com.openexchange.ajax.Folder.actionGet(Folder.java:222)
            at com.openexchange.ajax.Folder.doGet(Folder.java:169)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)
            at com.openexchange.ajax.SessionServlet.service(SessionServlet.java:132)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
            at com.openexchange.tools.ajp13.AJPv13Request.response(AJPv13Request.java:92)
            at com.openexchange.tools.ajp13.AJPv13RequestHandler.createResponse(AJPv13RequestHandler.java:335)
            at com.openexchange.tools.ajp13.AJPv13Connection.createResponse(AJPv13Connection.java:170)
            at com.openexchange.tools.ajp13.AJPv13Listener.run(AJPv13Listener.java:237)
            at java.lang.Thread.run(Thread.java:595)
    Caused by: javax.mail.MessagingException: Unconnected sockets not implemented;
      nested exception is:
            java.net.SocketException: Unconnected sockets not implemented
            at com.sun.mail.imap.IMAPStore.protocolConnect(IMAPStore.java:479)
            at javax.mail.Service.connect(Service.java:275)
            at com.openexchange.groupware.imap.DefaultIMAPConnection.connect(DefaultIMAPConnection.java:192)
            at com.openexchange.api2.MailInterfaceImpl.init(MailInterfaceImpl.java:666)
            at com.openexchange.api2.MailInterfaceImpl.getRootFolders(MailInterfaceImpl.java:4099)
            ... 12 more
    Caused by: java.net.SocketException: Unconnected sockets not implemented
            at javax.net.SocketFactory.createSocket(SocketFactory.java:97)
            at com.sun.mail.util.SocketFetcher.createSocket(SocketFetcher.java:222)
            at com.sun.mail.util.SocketFetcher.getSocket(SocketFetcher.java:163)
            at com.sun.mail.iap.Protocol.<init>(Protocol.java:84)
            at com.sun.mail.imap.protocol.IMAPProtocol.<init>(IMAPProtocol.java:87)
            at com.sun.mail.imap.IMAPStore.protocolConnect(IMAPStore.java:446)
            ... 16 more
    After some searching and reading in the Forum I changed the "user.imapLogin" and "user.imapServer" fields in the MySQL Database and changed the settings in the "imap.properties" File under /opt/open-exchange/etc/groupware" accordingly (see below)

    Code:
    imapLoginType=user
    imapMasterPassword=secret
    imapServer=10.110.27.240:993
    smtpServer=10.110.27.240:25
    smtpLocalhost=null
    imaps=true
    imapsPort=993
    smtps=false
    smtpsPort=465
    mail.mime.charset=UTF-8
    imapSort=application
    imapSearch=imap
    imapMessageFetchLimit=5000
    imapAttachmentDisplaySizeLimit=8192
    imapQuoteLineColors=#a14044,#917722,#599351,#516193,#666666
    imapCredSrc=session
    imapSupportsACL=true
    smtpAuthentication=true
    imapTimeout=5000
    imapConnectionTimeout=10000
    imapMaxNumOfConnections=0
    imapAuthEnc=UTF-8
    userFlagsEnabled=true
    partModifierImpl=com.openexchange.groupware.imap.DummyPartModifier
    maxIMAPConnectionIdleTime=60000
    allowNestedDefaultFolderOnAltNamespace=false
    ignoreSubscription=false
    setSMTPEnvelopeFrom=false
    spamEnabled=true
    I even sniffed the Network-Traffic with WireShark and found out that despite setting imaps=true and imapsPort=993 and imapServer=10.110.27.240:993 OX is still trying to connect to the remote IMAP Server via Port 143

    So any suggestion what I missed or how I get OX to use IMAPS?
    (Oh and maybe you can tell me how to install my X509 Certificates so that Java will accept the Certificate from the remote IMAP Server (since we have a self-sined CA))

    Thanks for any Tips
    Last edited by Jeremiah; 06-14-2007 at 10:05 AM. Reason: got a workaround

  2. #2
    Jeremiah Guest

    Lightbulb using stunnel

    After a bit try and error I got a workaround:

    I installed stunnel to forward the local unencrypted port 143 to the SSL encrypted Port 993 of the remote Server. And changed the OX configuration back to default, so it would try to use a local IMAP server.

    Code:
    stunnel -c -d143 -r<REMOTE_IP>:993
    works like charm

  3. #3
    kkretsch Guest

    Default remote imaps access?

    Are there any news about connection via SSL to a remote imap server? I don't want to start yet another process for tunneling. I tried to define a port number using the changeuser commandline but it still connects via plain imap port 143.

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    imap configuration is done at the etc/groupware/imap.properties file.
    sorry, you've already figured that out, i'll take a look how to do it when i find time for it.

    Solved:
    just add the imaps port to the 'imapServer' property as this overwrites any other configuration. I sniffed imap/imaps and connections to my (localhost) imap server are correctly managed as imaps.
    imapServer=127.0.0.1:993

    imaps must stay enabled of course:
    imaps=true

    Greetings
    Last edited by Martin Heiland; 08-05-2007 at 02:41 AM.

  5. #5
    kkretsch Guest

    Talking

    Quote Originally Posted by Martin Braun View Post
    imaps must stay enabled of course:
    imaps=true
    Thanks, that's the solution. Just tried it and finally it connects via SSL.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •