Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 4 of 4
  1. #1
    zoomiest Guest

    Default Apache won't Connect

    I just completed my first installation of OX6, (on Ubuntu 8.10) and then found that I can't connect to the apache webserver to configure it...

    Question 1
    Based on the Deb4 HowTo, was the /etc/apache2/sites-enabled/000-default configuration file supposed to be the ONLY settings, or were those to be ADDED to the existing install default?

    Question 2
    Was I the only one who found that that Deb 4 HowTo was missing the step to create the configdb database. I had to create it manually. Was I just initializing my scripts incorrectly?

    Question 3
    What should I look for to connect to the apache webserver?
    Last edited by zoomiest; 04-14-2009 at 10:49 PM. Reason: added additional detail

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    Answer 1:
    Since those guides are intended for a single-box installation, they assume that those configurations are the only ones. We understand that you want to use your webserver for more than one application, but those configurations are getting pretty custom and complex so we did not want to spread confusion about complex setups. If you're running multiple applications on one server, served by a single Apache instance, we assume that you already have some knowledge about web server configuration and can handle it the way it fits your setup. So yes - those configuration files are intended to be the only ones but it is possible to configurae OX and other applications at the same time. Basically the Apache sites-enabled entry for OX is very simple since we only activeate mod_deflate, mod_expires and a redirect to /ox6/.

    Answer 2:
    The howto contains a step for setting up the configdb:

    "Now we have to initialize the Open-Xchange configdb database. This can all be done by executing the initconfigdb script.

    $ /opt/open-xchange/sbin/initconfigdb --configdb-pass=db_password -a"

    Note that this script will only work if no mysql root user password is set at the point of OX installation, you should/must set a strong password for 'root' after using that script.

    Answer 3:
    What exactly do you mean with that? Don't you have access to the web interface? Does Apache does not connect to the OX backend via mod_proxy_ajp? If the open-xchange-gui package is installed the GUI is placed at http://yourserver.tld/ox6/. For debugging, please take a look at the log files at /var/log/apache2/*

    Hope that helps.

  3. #3
    zoomiest Guest

    Default Further...

    Answer 1:
    Thanks. I will fix that up and restart apache.

    Answer 2:
    Okay. Perhaps I should re-do this... just to be sure.

    Answer 3:
    I get a
    "Failed to Connect. Firefox can't establish a connection to the server at 192.168.7.104."

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    About the third point, ehm... could it be that Apache is just not running at 192.168.7.104 or some kind of network problems occurs? Just try to apache2ctl start and watch the output, maybe some configuration files are broken and keep the Apache server from starting properly.
    Last edited by Martin Heiland; 04-14-2009 at 11:45 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •