Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 4 of 4
  1. #1
    Join Date
    Apr 2009
    Posts
    8

    Default Problem with sieve and cyrus 2.2

    Hello Community,
    I have an Problem with the combination OX6 and Cyrus.

    I became the Message: Error in Low Level connection to the sieve server.

    When I try the connection with sieveshell, I can log me in.

    A trace of the connection give me this:
    ------------
    Capturing on lo
    0.000000 213.83.1.94 -> 213.83.1.94 AJP13 0:REQ:GET /ajax/mailfilter HTTP/1. 1
    0.004391 213.83.1.94 -> 213.83.1.94 TCP 8009 > 3658 [ACK] Seq=0 Ack=624 Win= 6189 Len=0 TSV=15211841 TSER=15211839
    0.008426 213.83.1.94 -> 213.83.1.94 TCP 2175 > sieve [SYN] Seq=0 Len=0 MSS=1 6396 TSV=15211842 TSER=0 WS=3
    0.008466 213.83.1.94 -> 213.83.1.94 TCP sieve > 2175 [RST, ACK] Seq=0 Ack=1 Win=0 Len=0
    0.016771 213.83.1.94 -> 213.83.1.94 AJP13 0:RSP:SEND HEADERS:200 OK
    0.016806 213.83.1.94 -> 213.83.1.94 TCP 3658 > 8009 [ACK] Seq=624 Ack=191 Wi n=4318 Len=0 TSV=15211844 TSER=15211844
    0.017051 213.83.1.94 -> 213.83.1.94 AJP13 0:RSP:SEND BODY CHUNK
    0.017061 213.83.1.94 -> 213.83.1.94 TCP 3658 > 8009 [ACK] Seq=624 Ack=341 Wi n=4318 Len=0 TSV=15211844 TSER=15211844
    0.020288 213.83.1.94 -> 213.83.1.94 AJP13 0:RSP:END RESPONSE
    0.020302 213.83.1.94 -> 213.83.1.94 TCP 3658 > 8009 [ACK] Seq=624 Ack=347 Wi n=4318 Len=0 TSV=15211845 TSER=15211845
    0.037319 213.83.1.94 -> 213.83.1.94 AJP13 2:REQ:GET /ajax/mailfilter HTTP/1. 1
    0.040156 213.83.1.94 -> 213.83.1.94 TCP 8009 > 2571 [ACK] Seq=0 Ack=622 Win= 4096 Len=0 TSV=15211850 TSER=15211849
    0.043908 213.83.1.94 -> 213.83.1.94 TCP 2176 > sieve [SYN] Seq=0 Len=0 MSS=1 6396 TSV=15211851 TSER=0 WS=3
    0.044770 213.83.1.94 -> 213.83.1.94 TCP sieve > 2176 [RST, ACK] Seq=0 Ack=1 Win=0 Len=0
    0.052609 213.83.1.94 -> 213.83.1.94 AJP13 2:RSP:SEND HEADERS:200 OK
    0.052653 213.83.1.94 -> 213.83.1.94 TCP 2571 > 8009 [ACK] Seq=622 Ack=191 Wi n=4099 Len=0 TSV=15211853 TSER=15211853
    0.052821 213.83.1.94 -> 213.83.1.94 AJP13 2:RSP:SEND BODY CHUNK
    0.052834 213.83.1.94 -> 213.83.1.94 TCP 2571 > 8009 [ACK] Seq=622 Ack=341 Wi n=4099 Len=0 TSV=15211853 TSER=15211853
    0.052900 213.83.1.94 -> 213.83.1.94 AJP13 2:RSP:END RESPONSE
    0.052907 213.83.1.94 -> 213.83.1.94 TCP 2571 > 8009 [ACK] Seq=622 Ack=347 Wi n=4099 Len=0 TSV=15211853 TSER=15211853
    ------------------
    This is in the open-xchange log
    -----------------
    Caused by: java.net.ConnectException: Connection refused
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at java.net.PlainSocketImpl.doConnect(PlainSocketImpl .java:333)
    at java.net.PlainSocketImpl.connectToAddress(PlainSoc ketImpl.java:195)
    at java.net.PlainSocketImpl.connect(PlainSocketImpl.j ava:182)
    at java.net.SocksSocketImpl.connect(SocksSocketImpl.j ava:366)
    at java.net.Socket.connect(Socket.java:520)
    at com.openexchange.jsieve.SieveHandler.initializeCon nection(SieveHandler.java:247)
    at com.openexchange.mailfilter.ajax.actions.Mailfilte rAction.actionConfig(MailfilterAction.java:162)

    -------------------
    A Telnet Connection is also possible.

    My mailfilter.properties is this:
    ------------------
    SIEVE_LOGIN_TYPE=user
    SIEVE_CREDSRC=session
    SIEVE_SERVER=localhost
    SIEVE_PORT=2000
    SCRIPT_NAME=Open-Xchange
    -------------------
    My imapd.conf. Only the Lines with sieve
    ---------------
    # Space-separated list of users that have sieve "admin" status, in
    sieve_admins: cyrus
    # and sieve_proxyservers.
    # directories: ~user/.sieve.
    ## sieveusehomedir: false
    sieveusehomedir: false
    # If sieveusehomedir is false, this directory is searched for Sieve scripts.
    sievedir: /var/spool/sieve
    #sievenotifier: zephyr
    # lmtp, sieve)
    # File containing the certificate used for sieve. If not specified, the global
    # certificate is used. A value of "disabled" will disable SSL/TLS for sieve.
    #sieve_tls_cert_file: /etc/ssl/certs/cyrus-sieve.pem
    # File containing the private key belonging to the sieve-specific server
    # "disabled" will disable SSL/TLS for sieve.
    #sieve_tls_key_file: /etc/ssl/private/cyrus-sieve.key
    # Require a client certificate for ALL services (imap, pop3, lmtp, sieve).
    # Require a client certificate for sieve ONLY.
    #sieve_tls_require_cert: false

    -----------------
    I have installed Cyrus 2.2 and Build: 6.8.0-6802, 2009-02-12 16:31:09

    Before I have cyrus installed, ther was an Dovecot with pysieved installed and this was perfect running. But there was a problem with shared folders. So I have cyrus installed.

    What can here the Problem be?

    Thank you for your Help

    EDIT: I have the wrong configs and Logfiles postet
    Last edited by mholstein; 04-28-2009 at 09:35 AM.

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    i think it would help if you capture the network traffic on port 2000, maybe the credentials are not correctly transfered or it is a general SIEVE issue. The Stacktrace says "Connection refused", so it could be that the sieve server does not accept connections from the OX server (if they are on two different machines or sieveshell connects via 127.0.0.1 and ox via localhost).

    Greetings

  3. #3
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Quote Originally Posted by mholstein View Post
    Hello Community,
    I have an Problem with the combination OX6 and Cyrus.

    I became the Message: Error in Low Level connection to the sieve server.
    -------------------
    A Telnet Connection is also possible.

    My mailfilter.properties is this:
    ------------------
    SIEVE_LOGIN_TYPE=user
    SIEVE_CREDSRC=session
    SIEVE_SERVER=localhost
    SIEVE_PORT=2000
    SCRIPT_NAME=Open-Xchange
    -------------------
    You are using SIEVE_LOGIN_TYPE=user which means the server is connecting to the same server as configured as --imapserver for each user. If you want to connect to localhost, you need to set SIEVE_LOGIN_TYPE=global.
    OXpedia.org - the answer to almost all questions.

  4. #4
    Join Date
    Apr 2009
    Posts
    8

    Thumbs up

    Thanx for your help.
    The Problem was, that the sieve daemon was only listening on the localhost interface, but OX ask on the eth0 interface.
    No sieve is listening on eth0 too and everything is fine.

    Thank you!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •