Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 5 of 5
  1. #1
    chris Guest

    Default Field Mapping Problem when importing Contacts

    Hi guys,
    i'm having a annoying problem when importing contact data with Funambol. I've successfully configured Funambol to synchronize with my OpenXchange server, but when while synchronizing OpenXchange flips the fields for additional email and business email.
    Thunderbird and Outlook map the fields correctly.

    Is there a simple way to configure the mapping in the OpenXchange server since it is very confusing for the user when the fields in his MailClient/Mobile and OpenXchange are flipped.

    Regards,
    Chris

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi Chris,

    are you sure that Open-Xchange "flips" the fields? We deliver and store data like it is provided via the Funambol Connector. Please check the data exchange of the Funambol server and the Open-Xchange Server to get more information about which component ist faulty.

    Thanks

  3. #3
    chris Guest

    Default

    ok, i checked that:
    here is the vcard exchanged by Funambol and an emailclient:
    Code:
    BEGIN:VCARD
    VERSION:2.1
    N:Bla;Blub;;;
    FN:Bla, Blub
    NICKNAME:
    ADR;HOME:;;;;;;
    ADR:;;;;;;
    BDAY:
    TEL;VOICE;HOME:
    TEL;VOICE;HOME:
    TEL;CAR;VOICE:
    TEL;FAX;HOME:
    TEL;CELL:
    TEL;FAX:
    TEL;VOICE:
    TEL;PREF;VOICE:
    TEL;X-FUNAMBOL-RADIO:
    EMAIL;INTERNET:additional@example.org
    EMAIL;INTERNET;HOME:private@example.org
    EMAIL;INTERNET;HOME;X-FUNAMBOL-INSTANTMESSENGER:
    URL:
    X-ANNIVERSARY:
    X-FUNAMBOL-CHILDREN:
    X-SPOUSE:
    ADR;WORK:;;;;;;
    ROLE:
    TITLE:
    ORG:;
    TEL;VOICE;WORK:
    TEL;VOICE;WORK:
    TEL:
    TEL;FAX;WORK:
    TEL;X-FUNAMBOL-CALLBACK:
    TEL;WORK;PREF:
    TEL;CELL;WORK:
    TEL;PAGER:
    TEL;X-FUNAMBOL-TELEX:
    EMAIL;INTERNET;WORK:business@example.org
    X-MANAGER:
    NOTE:
    X-FUNAMBOL-SUBJECT:
    END:VCARD
    It seems as if the additional email adress is not been properly mapped. It is given the EMAIL;INTERNET: description which my mail clients seem to map as the default email address. Is there a way to change this behaviour so that for example the business mail adrdess is mapped to EMAIL;INTERNET?

    Regards,
    Chris

  4. #4
    chris Guest

    Default

    no hints how to fix that?

  5. #5
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Obviously this problem is not related to Open-Xchange software, the way to go would be informing the maintainer of the synchronization software.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •