Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 6 of 6
  1. #1
    Fiodin Guest

    Default Problem with the open-xchange-admin package and MySQL 5.1

    Hello,

    I just started to install Open Xchange Server on an Ubuntu 8.04 system with the package manager. By installing the following package:
    open-xchange-admin
    the package manager won't install it because it depends on the mysql-server-5.0. So if I don't install the mysql server 5.0 instead of the 5.1 this admin package will not be installed.

    I just went on and after /opt/open-xchange/sbin/initconfigdb --configdb-pass=db_password -a
    this message appears:
    /opt/open-xchange/sbin/initconfigdb currently knows the following parameters:

    Parameter | Default value
    ------------------------------------------------------------
    --admin-user |
    -- |
    --NG | NG
    --configdb-user | openexchange
    --configdb-pass | db_password
    -- |
    --FIGDB_HOST_LONG | FIGDB_HOST
    --configdb-port | 3306
    -- |
    --NAME_LONG | NAME

    NOTE: use "-a" to create SQL admin user using GRANT command
    use -i to automatically delete the configdb if exists


    Example:

    /opt/open-xchange/sbin/initconfigdb --configdb-pass=secret

    missing required option --admin-user



    I just made it that the root user has no password in the MySQL Database. So I do not think that this is the problem.

    I just think the problem is with the package.

    Can I do the installation of this package without going back to MySQL 5.0? Or is there any other workaround!

    Thank you for helping!

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    the OX packages for Ubuntu 8.04 depend of MySQL 5.0 since it is the only supported MySQL release for Hardy Heron, MySQL 5.1 has been added with the Ubuntu 9.04 release and is not part of 8.04. We won't set dependencies on packages that are not available in a specific distribution. Please follow the installation guides at the Wiki: http://www.open-xchange.com/wiki/ind...or_Ubuntu_8.04

    Greetings
    Last edited by Martin Heiland; 05-21-2009 at 11:17 AM.

  3. #3
    Fiodin Guest

    Default

    OK thanks for helping.

    After one hour I just dropped the mysql server 5.1 and installed the 5.0. Hopefully now I can finish with the installation guide.

    Thank you!!!

  4. #4
    Fiodin Guest

    Default

    But now the packagemanager wants to update the mysql-server to version 5.1 after "apt-get update" and "apt-get upgrade". And the message is, that there is an newer version for "mysql-server". And this package depends in the newer version on "mysql-server-5.1"
    I didn't change the sources.list instead of adding the source for open-xchange.

    So I think the MySQL Server in Version 5.1 was added to the mainsouces for Ubuntu 8.04. LTS Server Edition.
    There can't be any other possibility. Or what do you think?

  5. #5
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    no i think even for Ubuntu it would be a no-go to add new and very unstable software to a stable LTS repository. I don't have a 8.04 installation available right now, but if you take a look at the online repository for 8.04, you'll notice that they're still at 5.0 which is a good version and imho there is no need to upgrade. Could it be that some additional software repositories have been added to your system that contain MySQL 5.1?

    Greetings

  6. #6
    Fiodin Guest

    Default

    No, the only source I added was that for Open Xchange and for PHP5.
    But I uncomment both in the sources.list and made an update and still is there the MySQL Server 5.1.

    It's magic!

    After that I made a little research and on the side you send I saw, with a little smile on my face, that there is only 5.0.

    I think it's a kind of magic.

    I just didn't try it, but I think now it should work because now I have the 5.0 running. If not, I will make a litlle post here, if I don't find any other solution.

    Thank you so far!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •