Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 4 of 4
  1. #1
    messi655 Guest

    Exclamation /opt/open-xchange/sbin/initconfigdb

    Hi all,

    I have problem about installing Open-Xchange. I am following guide http://www.open-xchange.com/wiki/ind...de_for_CentOS5 for installing Open-change, i have problem with database Mysql. when I create the database /opt/open-xchange/sbin/initconfigdb --configdb-pass=12345 -a
    error occurred, although I grant permission for the user openxchange as follows >grant all privileges on *.* to 'openxchange'@'%' identified by '12345'.

    # /opt/open-xchange/sbin/initconfigdb --configdb-pass=12345
    initializing configdb from scratch...ERROR 1045 (28000): Access denied for user 'openexchange'@'localhost' (using password: YES)
    ERROR

    But when I do it with root account is OK (edit file / opt / open-xchange / sbin / initconfigdb
    CONFIGDB_USER = root)
    # / opt / open-xchange / sbin / initconfigdb - configdb-pass-a = 123.

    Because security reasons I should not use the root account. I want to create a database with openxchange account. Can you help me?

    Thanks you very much!

  2. #2
    Join Date
    Sep 2009
    Location
    Almere Nederland
    Posts
    10

    Default the initconfdb tool

    Messi,

    The initconfigdb tool works when root has no passwd. So if you (just for the time you are installing) remove the root passwd for Mysql, you should be fine.
    After finishing up the installation, you can put the password back on the root user for Mysql, because by then you will have your own openxchange user for your open-xchange databases (which will have been created by the initconfdb tool/script....
    It's not the greatest way to go, but it works....

    grtz,

    B.

  3. #3
    Join Date
    Jul 2015
    Posts
    1

    Default

    How would you reset the password if you accidentally set it during install?

  4. #4
    Join Date
    Aug 2008
    Posts
    107

    Default

    You can start initconfigdb with the parameter "-mysql-root-passwd="
    Viele Gre
    Rene

    OS: Ubuntu Server amd64 12.4 LTS
    JRE: openjdk-7-jre, MySQL: 5.5, Apache 2.2, Dovecot 2.0.19
    OX-Server backend: OXSE latest
    OX-frontend: OXSE latest appsuite + ox6

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •