Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Installation...

  1. #1
    pennywize Guest

    Angry Installation...

    Hallo,

    weil ich leider in diesem Thread keine Antwort auf meine Frage erhalten habe, versuche ich es nochmal auf deutsch mit allen Schritten die ich bisher getätigt habe.

    1. Zuerst alle *.jar gezogen und nach /opt/open-xchange/lib kopiert.

    2. Danach diese diese Etch Pakete installiert

    apt-get install -y sun-java5-jdk sun-java5-bin sun-java5-demo mysql-client-5.0 mysql-common \
    mysql-server mysql-server-5.0 apache2-mpm-prefork apache2-utils apache2.2-common \
    libapache2-mod-jk cyrus-admin-2.2 cyrus-clients-2.2 cyrus-common-2.2 cyrus-doc-2.2 \
    cyrus-imapd-2.2 cyrus-nntpd-2.2 cyrus-pop3d-2.2 cyrus-sasl2-doc gettext \
    gettext-base liblocale-gettext-perl cvs ant ant-optional postfix libnss-mysql-bg \
    sasl2-bin libpam-mysql
    3. Apache konfiguriert
    4. Die Schritte IV.1 und IV.2 ausgeführt. Es gab keine Fehlermeldungen und es wurde fehlerfrei kompiliert.

    5. Nun kommen wir zu IV.3

    Adjust your MySQL authentification information (OXDB_USER_*) in /opt/open-xchange/sbin/oxinstaller
    Sehe ich mir diese Datei genau an finde ich unter OXDB_USER_* diese Zeilen:

    OXDB_USER=openexchange
    OXDB_USER_LONG=oxdb-user
    OXDB_PASS=
    OXDB_PASS_LONG=oxdb-pass
    OXDB_HOST=localhost
    OXDB_HOST_LONG=oxdb-host
    OXDB_PORT=3306
    OXDB_PORT_LONG=oxdb-port
    OXADMIN_PASS=
    OXADMIN_PASS_LONG=admin-pass
    MAIL_DOMAIN=
    MAIL_DOMAIN_LONG=maildomain
    MAIL_HOSTNAME=
    MAIL_HOSTNAME_LONG=mailhostname
    INST_LANGUAGE=en_US
    INST_LANGUAGE_LONG=language
    INST_LANGUAGE_VALUES="de_DE en_US fr_FR"
    Ich habe diese Parts nicht bearbeitet, weil es zu diesem Zeitpunkt kein mysql Passwort gibt und dieses erst bei Ausführung dieser Zeile erstellt wird:

    /opt/open-xchange/sbin/oxinstaller --oxdb-pass=some_pass --admin-pass=some_pass --maildomain example.com
    Es werden bei 1/2 Fehlermeldungen ausgeschrieben, dass das Passwort nicht stimmt, ok. Trotzdem kann ich mich in die MySQL Datenbank mit dem vergebenen Passwort einloggen

    mysql -h localhost -u openexchange -p configdb
    Enter password:
    Reading table information for completion of table and column names
    You can turn off this feature to get a quicker startup with -A

    Welcome to the MySQL monitor. Commands end with ; or \g.
    Your MySQL connection id is 122
    Server version: 5.0.32-Debian_7etch1-log Debian etch distribution

    Type 'help;' or '\h' for help. Type '\c' to clear the buffer.
    Muss trotzdem vor der Ausführung dies Datei /opt/open-xchange/sbin/oxinstaller bearbeitet werden?
    Diesen Part hab ich, so wie einige andere auch, nicht so richtig verstanden!

    OK, fahren wir fort mit IV.4 wie im Wiki beschrieben, bis zu diesem Punkt klappt alles reibungslos mit der Installation

    /opt/open-xchange/sbin/open-xchange-groupware
    Führe ich dieses Kommando aus, endet es in einer Endlosschleife bis ich mit ^C abbreche. Die Einträge in den Logs sehen so aus

    18.06.2007 20:26:51 com.openexchange.admin.daemons.Activator start
    INFO: Starting Admindaemon...
    18.06.2007 20:26:51 com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: OX init starting...
    18.06.2007 20:26:52 org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPService <init>
    SCHWERWIEGEND: Could not create sender to [127.0.0.1:57462] -- Socket is null, cannot connect to 127.0.0.1:57462
    18.06.2007 20:26:52 org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPCacheManager <init>
    SCHWERWIEGEND: Failure, lateral instance will use zombie service
    java.io.IOException: Socket is null, cannot connect to 127.0.0.1:57462
    ...
    ...
    SCHWERWIEGEND: /bin/chown exited abnormally
    18.06.2007 20:30:45 com.openexchange.admin.rmi.impl.OXUser create
    SCHWERWIEGEND: /bin/chown: »postmaster:«: kann die Login-Gruppe einer numerischen UID nicht ermitteln
    18.06.2007 20:30:45 com.openexchange.admin.rmi.impl.OXUser create
    SCHWERWIEGEND: Unable to chown homedirectory: /home/postmaster
    18.06.2007 20:30:49 com.openexchange.admin.rmi.impl.OXUserIMAPImpl initImap
    SCHWERWIEGEND: javax.mail.AuthenticationFailedException: Login failed: authentication failure
    18.06.2007 20:30:49 com.openexchange.admin.rmi.impl.OXUser create
    SCHWERWIEGEND: Error while calling create for plugin: open_xchange_admin_plugin_imap

    Weiter eingerichtet/installiert hab ich bislang noch nicht. Mir ist nicht so ganz klar was/wie/wo falsch gemacht haben zu sollen - mit Ausnahme der Geschichte mit dem oxinstaller. Kann es sein, dass die Pakete betreffs Cyrus, Postfix etc erst später installiert werden müssen?
    Es wäre nett, wenn man mich auf den richtigen Weg bringen würde.

    MfG
    Jasmin

  2. #2
    sledge0303 Guest

    Default

    Ich kann dir im moment nicht weiterhelfen, weil seit einigen Wochen in Sachen OX6 bei mir nichts installiert habe. Werde demnächst damit wieder anfangen!
    Glaub mich aber zu erinnern, zuerst alle Pakete installiert und konfiguriert zu haben und danach erst mit dem oxinstaller das PW für MySQL DB, des Users admin/oxadmin generiert und die Groupware gestartet zu haben.
    Auf die Frage ob oxinstaller angepasst werden muss oder nicht muss ich jetzt passen. Das könnte dir jemand beantworten der das Ding lauffähig installiert hat oder halt einer der Entwickler.
    Sollte dir niemand helfen wollen, warte bis ich soweit bin und hoffe dir danach alle Fragen beantworten zu können - dafür musst dich aber in Geduld üben.

  3. #3
    sledge0303 Guest

    Default

    Hallo Jasmin,

    ich hab mal eben eine Installation auf einer XeN VM erstellt, alle Einstellungen dokumentiert und dir ein kleines Howto erstellt. Den Link hast per PM erhalten
    Für mich ist OX6 noch keine Alternative zu Hymalia, weil halt Lighttpd damit nicht so richtig will. Hab auch keine Zeit rumzufrickeln oder ein würgaround auszuarbeiten - auf gut deutsch: hab OX bereits wieder runtergeschmissen und die LVM gelöscht!

  4. #4
    pennywize Guest

    Default

    Hi,

    danke für die URL zu deiner Page, werde es morgen ausprobieren und gebe dir anschließend bescheid.
    Mit dem Lighty ist ärgerlich

    Jasmin

  5. #5
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Seit lighttpd 1.5 sollte der doch nun auch ajp supporten, oder? Ich meine so etwas gelesen zu haben.

  6. #6
    sledge0303 Guest

    Default

    Quote Originally Posted by Martin Braun View Post
    Seit lighttpd 1.5 sollte der doch nun auch ajp supporten, oder? Ich meine so etwas gelesen zu haben.
    Eigentlich schon, zumindest mit Tomcat. Ihr habt etwas eigenes im Gegensatz zu Tomcat entwickelt und damit gibt es seine Probleme mit der Weiterleitung nach der Anmeldung durch den User.

    Der Ablauf sieht so aus:

    1. OX Interface erscheint
    2. User meldet sich an mit Kennung/Passwort
    3a. Beim Apache erscheint das GUI und User kann arbeiten
    3b. beim Lighty wird Passwort angenommen, lädt Dateien und bleibt dann ohne Fehlermeldung stehen

    In etwa 4 Wochen hab ich mehr Zeit mich damit auseinanderzusetzen und ggf. ein Würgaround basteln.
    OX5 funktioniert mit dem Lighty mehr als nur gut, siehe diesem Howto.
    Allerdings hat die letzte Version des Lighty einen kleinen Bug und es werden nicht so ganz nachvollziehbare Meldungen in das Log geschrieben - ohne Auswirkungen auf die OX5 Funktionen
    Last edited by sledge0303; 06-22-2007 at 07:59 AM.

  7. #7
    Multivitamin Guest

    Default

    Quote Originally Posted by pennywize View Post
    Hi,

    danke für die URL zu deiner Page, werde es morgen ausprobieren und gebe dir anschließend bescheid.
    Mit dem Lighty ist ärgerlich

    Jasmin
    Hi!

    und? Hast du erfolg gehabt? Ich hänge nämlich gerade am gleichen Problem und komme leider nicht weiter.

    Bin also für jeden Tip dankbar

    --
    Gruß Dirk

  8. #8
    Join Date
    Feb 2007
    Location
    Olpe
    Posts
    199

    Default

    1) Was sagen die Logs?

    2) Interessehalber: Was bringt euch der Lighthttpd, ich sehe im Anwendungsfall "Open-Xchange" keine Vorteile?

    Daniel

  9. #9
    sledge0303 Guest

    Default

    Quote Originally Posted by Daniel Halbe View Post
    2) Interessehalber: Was bringt euch der Lighthttpd, ich sehe im Anwendungsfall "Open-Xchange" keine Vorteile?
    Hallo Daniel,

    OX5 bzw. OX6 sollen in eine bestehende Umgebung eingebaut werden, weil für andere Projekte in Verbindung mit dem Lighty eine bessere Performance erreicht wird.
    Was den Anwendungsfall OX angeht, hast mit deiner Aussage nicht unrecht, es geht darum diese Applikation einzugliedern.
    Hab bezüglich OX6 Wiki noch einen Punkt, der mich auch beschäftigt:

    Before you can start the Open-Xchange application you must set up the Open-Xchange database with the tool "oxinstaller". Adjust your MySQL authentification information (OXDB_USER_*) in /opt/open-xchange/sbin/oxinstaller
    Ich führe den oxinstaller erst nach Beendigung der Konfiguration aller Dienste durch ohne den oxinstaller modifiziert zu haben.
    Bei der Erstellung des DB Passworts werden mir bei Schritt 1/2 ebenfalls 2 Fehlermeldungen betreffs MySQL ausgegeben, dass das Passwort falsch war.
    Führe ich das Kommando mit dem Zusatz '-f' anschließend erneut aus, kein Problem, auch ein einloggen in die DB mit diesem Passwort ist möglich. Habe auch schon einige Berichte hier im Forum gelesen, diese sagen mir bei der Klärung dieser Frage würde Informationsbedarf bestehen: muss /opt/open-xchange/sbin/oxinstaller bearbeitet werden bevor das Kommando ausgeführt wird, ja oder nein?

    @Multivitamin,

    Was das Problem von Pennywize und ggf. deines betrifft, sie hat mir gestern die Logs geschickt. Wenn du schreibst du hast das gleiche Problem, sind die Logeinträge identisch mit denen von Jasmin, s.o.?
    Benutzt du rein zufällig Etch als OS? Ich weiss nicht welche technische Foren über Linux-/Root- oder dedicated Server zu liest, im rootforum.de hab ich mal eine Problemstellung seit der Umstellung von Sarge auf Etch beschrieben.
    Ihr beide habt eindeutig Berechtigungsprobleme, will mal im laufe der Woche OX6 auf einer Xen VM mit Ubuntu dapper installieren.
    Das Wiki erklärt im Bezug auf OX die notwendigen Schritte, klärt den User aber nicht auf welche Datei/Verzeichnisrechte ggf. gesetzt werden müssen.
    Wiki bedeutet nicht Howto!

  10. #10
    Multivitamin Guest

    Default

    Quote Originally Posted by sledge0303 View Post
    Was das Problem von Pennywize und ggf. deines betrifft, sie hat mir gestern die Logs geschickt. Wenn du schreibst du hast das gleiche Problem, sind die Logeinträge identisch mit denen von Jasmin, s.o.?
    Benutzt du rein zufällig Etch als OS? Ich weiss nicht welche technische Foren über Linux-/Root- oder dedicated Server zu liest, im rootforum.de hab ich mal eine Problemstellung seit der Umstellung von Sarge auf Etch beschrieben.
    Ihr beide habt eindeutig Berechtigungsprobleme, will mal im laufe der Woche OX6 auf einer Xen VM mit Ubuntu dapper installieren.
    Das Wiki erklärt im Bezug auf OX die notwendigen Schritte, klärt den User aber nicht auf welche Datei/Verzeichnisrechte ggf. gesetzt werden müssen.
    Wiki bedeutet nicht Howto!
    Hi!

    ja richtig, ich benutze Etch. Mein Problem hat sich aber auch etwas gewandelt und ist nun wie in diesem Thread beschrieben:http://www.open-xchange.com/forum/sh...n+to+config+DB.

    Ich glaube eigentlich nicht, dass es hier noch ein Rechteproblem ist, aber eine tolle Idee woran es liegt, habe ich dennoch nicht

    Das ein Wiki kein Howto ist, ist schon klar - hat aber auch niemand behauptet. Auch ist es klar, dass man zunächst mal selber seine "Birne" anstrengen sollte, aber in meinem Fall (und auch wohl bei Pennywize) hat das nix gebraucht

    --
    Gruß Dirk

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •