Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 9 of 9
  1. #1
    zwelch Guest

    Default Fehlermeldung: 503 - Service Temporarily Unavailable

    Hallo Forum!

    Ich habe heute fast erfolgreich und gemäß der Anleitung "Open-Xchange Community Edition" auf meinem Server (OpenSUSE 11.1) installiert. Leider erscheint, wenn ich mich in der Groupware einloggen will, die im Betreff genannte Fehlermeldung.

    Ich vermute, dass der Groupware-Dienst sich nicht zum starten überreden lassen will und deshalb diese Meldung erscheint. Wenn ich folgende ausführe:

    Code:
    ns1 ~ # rcopen-xchange-groupware start
    Starting open-xchange-groupware daemon                             done
    Gibt es folgende Meldung im Log:

    Code:
    ns1 ~ # cat /var/log/open-xchange/open-xchange-console.log
    Error occurred during initialization of VM
    Could not reserve enough space for object heap
    Could not create the Java virtual machine.
    Im Server selbst stecken zwar nur 512 MB RAM (und lassen sich leider auch nicht aufrüsten (embedded)) aber, es ist eigentlich genügend frei.

    Code:
    ns1 ~ # free
                 total       used       free     shared    buffers     cached
    Mem:        448584     243024     205560          0       9184     127248
    -/+ buffers/cache:     106592     341992
    Swap:            0          0          0
    Jetzt die Frage: Ist mir noch zu helfen () und wenn ja, wie?
    Danke.

    // Edit
    // Ich glaube es müssen 2 Java-Prozesse laufen. Tun sie aber nicht.
    Code:
    ns1 ~ # ps axf | grep java
     2642 ?        Sl     0:15 /usr/bin/java -Xms100m -Xmx100m -XX:+UseConcMarkSweepGC -XX:NewSize=50m -XX:MaxNewSize=50m -XX:SurvivorRatio=6 -Dopenexchange.propdir=/opt/open-xchange/etc/admindaemon -Dopenexchange.propdir2=/opt/open-xchange/etc/common -Dconfigdir=/opt/open-xchange/etc/admindaemon -Djava.util.logging.config.file=/opt/open-xchange/etc/admindaemon/file-logging.properties -Duser.timezone=GMT -Dlibdir=/opt/open-xchange/bundles/com.openexchange.common/lib -jar /opt/open-xchange/bundles/org.eclipse.osgi_3.3.0.v20070530.jar -configuration file:/opt/open-xchange/etc/admindaemon/osgi/
     3818 pts/0    S+     0:00          \_ grep --color=auto java
    Last edited by zwelch; 07-28-2009 at 06:03 PM.

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    like you've already mentioned the problem here is memory. Open-Xchange does not require much memory but the JVM is caching as much as you've configured. I guess we need some manual configuration here to make it work. Please take a look at this file

    Code:
    /opt/open-xchange/etc/groupware/ox-scriptconf.sh
    This file configures the java virtual machine. There are settings for maximum and even minimum memory usage, if the minimum or maximum is higher than the available memory, the JVM does not start. Please post the content of this file (the JAVA_XTRAOPTS line) so we can do some tuning for systems with low memory.

    Greetings

  3. #3
    zwelch Guest

    Default

    hi,
    here ist the file.

    Code:
    ns1 ~ # cat /opt/open-xchange/etc/groupware/ox-scriptconf.sh
    
    PROPERTIESDIR=/opt/open-xchange/etc/groupware
    COMMONPROPERTIESDIR=/opt/open-xchange/etc/common
    LOGGINGPROPERTIES=/opt/open-xchange/etc/groupware/file-logging.properties
    OSGIPATH=/opt/open-xchange/etc/groupware/osgi
    
    # This properties sets the java options given to the groupware on start
    JAVA_XTRAOPTS="-Xms512m -Xmx512m -XX:+UseConcMarkSweepGC -XX:NewSize=256m -XX:MaxNewSize=256m -XX:SurvivorRatio=6"
    
    # Maximum number of open Files for the groupware
    NRFILES="8192"
    
    # Specify the umask of file permissions to be created by ox, e.g. in the
    # filestore.
    # BEWARE: setting a nonsense value like 666 will make open-xchange stop working!
    #         useful values are 006 or 066
    UMASK=066
    cu

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    okay the problem is that the JVM is configured to a minimum of 512MB reserved memory which is clearly too much for your server. I'd propose this config:

    -Xmx384m -XX:+UseConcMarkSweepGC

    You can remove or uncomment the previous settings. This new setting configures a maximum memory consumption of 384 MB, but you can configure it to be higher or lower.

    Good luck!

  5. #5
    zwelch Guest

    Default

    it works!
    thanks a lot!

  6. #6
    Join Date
    May 2008
    Location
    Frankfurt am Main
    Posts
    58

    Default

    Sorry, dass ich mich auch hier drann hänge.

    Ich bekomme die gleiche Fehlermeldung...

    Mein Rechner hat aber 1024MB und es laufen 2 java Prozesse (/usr/bin/java und /usr/lib/jvm/java-1.5.9-sun-1.5.0/jre/bin/java)

    Den OX-Server habe ich gestern frisch aufgesetzt - und es war noch nie eine andere Version draufgewesen.

    Auch ein wechsel der JAVA Version ändert nichts am Fehler.

    Beim Login-Versuch wird die Logdatei open-xchange-osgi.log geändert:

    Code:
    !ENTRY org.eclipse.osgi 4 0 2009-08-27 13:40:42.498
    !MESSAGE
    !STACK 0
    java.io.IOException: Permission denied
            at java.io.UnixFileSystem.createFileExclusively(Native Method)
            at java.io.File.checkAndCreate(File.java:1343)
            at java.io.File.createTempFile(File.java:1431)
            at org.eclipse.osgi.storagemanager.StorageManager.createTempFile(Storage
    Manager.java:721)
            at org.eclipse.osgi.storagemanager.StorageManager.getOutputStream(Storag
    eManager.java:783)
            at org.eclipse.osgi.internal.baseadaptor.BaseStorage.saveBundleDatas(Bas
    eStorage.java:489)
            at org.eclipse.osgi.internal.baseadaptor.BaseStorage.saveAllData(BaseSto
    rage.java:382)
            at org.eclipse.osgi.internal.baseadaptor.BaseStorage.access$1(BaseStorag
    e.java:372)
            at org.eclipse.osgi.internal.baseadaptor.BaseStorage$StateSaver.run(Base
    Storage.java:1115)
            at java.lang.Thread.run(Thread.java:595)
    
    !ENTRY org.eclipse.osgi 4 0 2009-08-27 13:40:42.498
    !MESSAGE
    !STACK 0
    java.io.IOException: Permission denied
            at java.io.UnixFileSystem.createFileExclusively(Native Method)
            at java.io.File.checkAndCreate(File.java:1343)
            at java.io.File.createTempFile(File.java:1431)
            at org.eclipse.osgi.internal.baseadaptor.BaseStorage.saveStateData(BaseS
    torage.java:539)
            at org.eclipse.osgi.internal.baseadaptor.BaseStorage.saveAllData(BaseSto
    rage.java:383)
            at org.eclipse.osgi.internal.baseadaptor.BaseStorage.access$1(BaseStorag
    e.java:372)
            at org.eclipse.osgi.internal.baseadaptor.BaseStorage$StateSaver.run(Base
    Storage.java:1115)
            at java.lang.Thread.run(Thread.java:595)
    Merci

    Dirk

  7. #7
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    please check the file permissions on this directory and subdirectories

    /opt/open-xchange/etc/groupware/osgi/

    this should look like this:

    Code:
    drwxr-xr-x 4 open-xchange open-xchange  4096 2009-08-26 16:42 .
    drwxr-xr-x 6 root         root          4096 2009-08-26 15:56 ..
    drwxr-xr-x 2 open-xchange open-xchange 12288 2009-08-26 15:53 bundle.d
    -rw-r--r-- 1 open-xchange open-xchange 10189 2009-08-26 16:42 config.ini
    -rw-r--r-- 1 root         root          3061 2009-08-26 14:57 config.ini.template
    drwx--x--x 4 open-xchange open-xchange  4096 2009-08-26 16:42 org.eclipse.osgi
    Could it be that the groupware has been started with /opt/open-xchange/sbin/open-xchange-groupware instead of the /etc/init.d script?

    Greetings

  8. #8
    Join Date
    May 2008
    Location
    Frankfurt am Main
    Posts
    58

    Default

    Quote Originally Posted by Martin Braun View Post
    Hi,

    please check the file permissions on this directory and subdirectories

    /opt/open-xchange/etc/groupware/osgi/

    this should look like this:

    Code:
    drwxr-xr-x 4 open-xchange open-xchange  4096 2009-08-26 16:42 .
    drwxr-xr-x 6 root         root          4096 2009-08-26 15:56 ..
    drwxr-xr-x 2 open-xchange open-xchange 12288 2009-08-26 15:53 bundle.d
    -rw-r--r-- 1 open-xchange open-xchange 10189 2009-08-26 16:42 config.ini
    -rw-r--r-- 1 root         root          3061 2009-08-26 14:57 config.ini.template
    drwx--x--x 4 open-xchange open-xchange  4096 2009-08-26 16:42 org.eclipse.osgi
    the 2 directories (and all the files within) were owned by root...

    I changed them to be owned by open-xchange - and now the error is no longer occouring...

    GUI was loades successfully...

    Quote Originally Posted by Martin Braun View Post
    Could it be that the groupware has been started with /opt/open-xchange/sbin/open-xchange-groupware instead of the /etc/init.d script?
    Yes...

    Dirk
    Last edited by diwa; 08-27-2009 at 02:20 PM.

  9. #9
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Okay, glad to hear that it works now. Please keep in mind - if a process or script is launched as root, it writes files for that group/user to the file system. The init.d scripts run as user open-xchange, but the sbin script will run as the user who started it.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •