Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 10 of 10
  1. #1
    hubsif Guest

    Default not possible to create two users with same name?

    Hi,

    We're syncing OX with MS AD. Unfortunately there exist two users with the same name (but different username).

    Oxldapsync can create the first user, but when it tries to create the second the following error occurs:
    "The displayname is already used"

    As there are many people in the world with the same name, I thought only the username has to be unique (which is met in this case).

    At the moment we can not create the second user. Anyone knows how to fix this?

    Thank you!
    hubsif.

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    you could configure

    /opt/open-xchange/etc/admindaemon/User.properties:
    DISPLAYNAME_UNIQUE=true

    Greetings

  3. #3
    hubsif Guest

    Default

    Hm, sorry for having bothered you.
    Seems like a typical case of RTFM.

    Thank you very much.

    hubsi.

  4. #4
    hubsif Guest

    Default

    Still having problems:
    Now I get the following error message:
    Code:
    Category=3 Message=An infostore folder named [XXX] already exists below folder userstore (10) in context 1. Please choose another display name. exceptionID=-1016211918-3
    What to do?
    Thank you!

  5. #5
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Well yes, making display names unique is not to annoy administrators but to maintain data consistency. On most file systems you cannot create two files or folder named equally. Since the infostore can be accessed through WebDAV it has the limitations that no display name can be available as a folder more than one time. You can have users with equal surname and givenname, but their displayname must be different.

  6. #6
    Join Date
    Nov 2010
    Location
    Lleida, Spain
    Posts
    22

    Default

    Hello,

    after a great effort I got OX working with the users in my LDAP and using IMAP and SMTP servers of my organization.

    But now after a little debugging logs I need to expose what seems the last problem I face. When I run oxldapsync.sh there are some users that are NOT imported. The error message from the server is what follows:

    Server response:
    The displayname is already used

    That's because I've got some users with 2 accounts, but I do not understand why Open-Xchange seems to take the displayname as an identifier (or something that should be unique), because in real life there are obviously different people with the same name. I'm using the field "uid" from LDAP as the unique identifier, and not displayname what seems no sense.

    After reading this thread I set (as our friend M. Braun) explains:
    /opt/open-xchange/etc/admindaemon/User.properties:
    DISPLAYNAME_UNIQUE=false


    And now I'm at the same point than hubsif:

    user in context 1 could not be created:
    Server response:
    FLD-0075 Category=3 Message=An infostore folder named XXXXXXXX already exists below folder userstore (10) in context 1. Please choose another display name. exceptionID=-1348815074-10


    So,...
    Is there any solution or trick for this issue? Would be a workaround to map (OX displayname) to (uid LDAP) (in mapping.openldap.conf):
    displayname = uid ?

    What is using OX displayname for?


    Thanks,
    Gerard.

  7. #7
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi Gerard,

    OX is using the displayname for the Infostore folder of each user. OX also uses internal identifiers so the display name does not need to be unique from the OX perspective. BUT: Almost all file manager and file systems cannot deal with two folders having the same name. Since the Infostore can be mounted via WebDAV, we have to take care on those file managers. We discovered severe issues and crashes if the WebDAV Interface delivers two identical folder names within the same parent folder.

    Greetings

  8. #8
    Join Date
    Nov 2010
    Location
    Lleida, Spain
    Posts
    22

    Default duplicated displayname

    Hello Martin,

    and do you suggest me something for my particular case? Would be possible or recommended to use another field for displayname? or even a concatenation of LDAP fields (e.g. displayname + mail or displayname + uid). An in this case how can I do the configuration in mapping.openldap.conf ?

    And if I would map displayname to mail? Would the thing make sense? I'm also interested in the possibilities of shared Infostores between users.

    I think If I could use a concatenation of fields my problem would be solved. Any idea?

    Thanks in advance
    Gerard.



    Quote Originally Posted by Martin Braun View Post
    Hi Gerard,

    OX is using the displayname for the Infostore folder of each user. OX also uses internal identifiers so the display name does not need to be unique from the OX perspective. BUT: Almost all file manager and file systems cannot deal with two folders having the same name. Since the Infostore can be mounted via WebDAV, we have to take care on those file managers. We discovered severe issues and crashes if the WebDAV Interface delivers two identical folder names within the same parent folder.

    Greetings

  9. #9
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    yes - if you generate a unique display name, this issue would be solved. However, i'm not a ldapsync expert and dunno how that might be configured :/

  10. #10
    Join Date
    Nov 2010
    Location
    Lleida, Spain
    Posts
    22

    Default

    Helo,

    I made some tests trying to use unique fields (e.g. mail OR uid) for displaynames, but was not a good choice since displayname it's the name which is used for show user in OX interface. I want to say that this name is shown to other users when they are looking for you (for example)..., and its very ugly and no useful to find for mail instead of name.

    I think this is a really problem and in my case it's only affecting a few users, but maybe I could report it as a bug or a feature request. Maybe I could also ask to OX LDAP Sync forum, to see if there are another solution.

    Thanks,
    Gerard.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •