Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 17
  1. #1
    Al Catraz Guest

    Default Installation problem on CentOS 5.3 x64

    Hi

    I"ve just installed Version: 6.10.0 Rev6 (2009-07-19 18:09:13) on CentOS 5.3 x64 and would say I've done it "by the book" (or actually "by the wiki").
    Anyway, I only get to the point "Creating contexts and users". when I issue the (slightly altered) command
    Code:
    /opt/open-xchange/sbin/createcontext -A oxadminmaster -P 'my_master_password' -c 1 -N 'mycontextname' -u oxadmin -d "Context Admin" -g Admin -s User -p 'my_adminpassword' -L defaultcontext -e myemail@mydomain.com -q 2048 --access-combination-name=all
    I get the error
    Code:
    context 1 could not be created:
    Server response:
     Error unmarshaling return; nested exception is:
            java.lang.ClassNotFoundException: com.mysql.jdbc.exceptions.MySQLNonTransientConnectionException (no security manager: RMI class loader disabled)
    What the heck am i doing wrong?

    Any help would be greatly appreciated

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    please post the corresponding log file entry from /var/log/open-xchange/open-xchange-admin.log.0 or any other file that contains relevant information.

    Thanks

  3. #3
    Livio Guest

    Default

    Hi,

    getting the same error on my Ubuntu 9.04 x64 root server when I try to create the oxadmin context.
    I followed the "Open-Xchange Server 6 on Ubuntu 8.04" and the pdf manual.
    Furthermore, I used SUNs JRE 1.6.0-14-8 and 1.5.0-18-1. Then I disabled my shorewall firewall, since there seems to be an UDP network problem. Afterwards, I added the broadcast route 224.0.0.0.
    But again, the problem remains.

    The following error messages are repeated all the time in open-xchange-admin.log.0:
    Aug 27, 2009 5:24:05 PM org.apache.jcs.auxiliary.lateral.socket.tcp.discov ery.UDPDiscoverySender send
    SEVERE: Error sending message
    java.io.IOException: Operation not permitted
    at java.net.PlainDatagramSocketImpl.send(Native Method)
    at java.net.DatagramSocket.send(DatagramSocket.java:6 12)
    at org.apache.jcs.auxiliary.lateral.socket.tcp.discov ery.UDPDiscoverySender.send(UDPDiscoverySender.jav a:152)
    at org.apache.jcs.auxiliary.lateral.socket.tcp.discov ery.UDPDiscoverySender.passiveBroadcast(UDPDiscove rySender.java:222)
    at org.apache.jcs.auxiliary.lateral.socket.tcp.discov ery.UDPDiscoverySender.passiveBroadcast(UDPDiscove rySender.java:196)
    at org.apache.jcs.auxiliary.lateral.socket.tcp.discov ery.UDPDiscoverySenderThread.run(UDPDiscoverySende rThread.java:152)
    at EDU.oswego.cs.dl.util.concurrent.ClockDaemon$RunLo op.run(ClockDaemon.java:364)
    at java.lang.Thread.run(Thread.java:595)
    Aug 27, 2009 5:24:05 PM org.apache.jcs.auxiliary.lateral.socket.tcp.discov ery.UDPDiscoverySenderThread run
    SEVERE: Problem calling the UDP Discovery Sender [224.0.0.1:6780]
    java.io.IOException: Operation not permitted
    at java.net.PlainDatagramSocketImpl.send(Native Method)
    at java.net.DatagramSocket.send(DatagramSocket.java:6 12)
    at org.apache.jcs.auxiliary.lateral.socket.tcp.discov ery.UDPDiscoverySender.send(UDPDiscoverySender.jav a:152)
    at org.apache.jcs.auxiliary.lateral.socket.tcp.discov ery.UDPDiscoverySender.passiveBroadcast(UDPDiscove rySender.java:222)
    at org.apache.jcs.auxiliary.lateral.socket.tcp.discov ery.UDPDiscoverySender.passiveBroadcast(UDPDiscove rySender.java:196)
    at org.apache.jcs.auxiliary.lateral.socket.tcp.discov ery.UDPDiscoverySenderThread.run(UDPDiscoverySende rThread.java:152)
    at EDU.oswego.cs.dl.util.concurrent.ClockDaemon$RunLo op.run(ClockDaemon.java:364)
    at java.lang.Thread.run(Thread.java:595)


    Right know I am running out of any ideas. It would be great to get some help on this topic.

    Thanks!

  4. #4
    Al Catraz Guest

    Default

    Quote Originally Posted by Martin Braun View Post
    Hi,

    please post the corresponding log file entry from /var/log/open-xchange/open-xchange-admin.log.0 or any other file that contains relevant information.

    Thanks
    Hi Martin
    Thanks for your reply. Here's the last entries from /var/log/open-xchange/open-xchange-admin.log.0:
    Code:
    Aug 26, 2009 8:25:31 PM com.openexchange.admin.rmi.impl.OXContextCommonImpl createcommon
    SEVERE: com.mysql.jdbc.exceptions.MySQLNonTransientConnectionException: Could not create connection to database server. Attempted reconnect 3 times. Giving up.
    com.openexchange.admin.rmi.exceptions.StorageException: com.mysql.jdbc.exceptions.MySQLNonTransientConnectionException: Could not create connection to database server. Attempted reconnect 3 times. Giving up.
            at com.openexchange.admin.storage.mysqlStorage.OXUtilMySQLStorageCommon.createDatabase(OXUtilMySQLStorageCommon.java:100)
            at com.openexchange.admin.storage.mysqlStorage.OXUtilMySQLStorage.createDatabase(OXUtilMySQLStorage.java:399)
            at com.openexchange.admin.storage.mysqlStorage.OXContextMySQLStorage.create(OXContextMySQLStorage.java:1090)
            at com.openexchange.admin.rmi.impl.OXContext.createmaincall(OXContext.java:816)
            at com.openexchange.admin.rmi.impl.OXContextCommonImpl.createcommon(OXContextCommonImpl.java:159)
            at com.openexchange.admin.rmi.impl.OXContext.create(OXContext.java:220)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:585)
            at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:294)
            at sun.rmi.transport.Transport$1.run(Transport.java:153)
            at java.security.AccessController.doPrivileged(Native Method)
            at sun.rmi.transport.Transport.serviceCall(Transport.java:149)
            at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:466)
            at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:707)
            at java.lang.Thread.run(Thread.java:595)
    Caused by: com.mysql.jdbc.exceptions.MySQLNonTransientConnectionException: Could not create connection to database server. Attempted reconnect 3 times. Giving up.
            at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:980)
            at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:956)
            at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:926)
            at com.mysql.jdbc.ConnectionImpl.createNewIO(ConnectionImpl.java:2253)
            at com.mysql.jdbc.ConnectionImpl.<init>(ConnectionImpl.java:718)
            at com.mysql.jdbc.ConnectionImpl.getInstance(ConnectionImpl.java:298)
            at com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDriver.java:282)
            at java.sql.DriverManager.getConnection(DriverManager.java:525)
            at java.sql.DriverManager.getConnection(DriverManager.java:171)
            at com.openexchange.admin.tools.AdminCache.getSimpleSqlConnection(AdminCache.java:440)
            at com.openexchange.admin.storage.mysqlStorage.OXUtilMySQLStorageCommon.createDatabase(OXUtilMySQLStorageCommon.java:97)
            ... 16 more
    Caused by: java.sql.SQLException: Access denied for user 'openexchange'@'localhost' (using password: YES)
            at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:1055)
            at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:956)
            at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3491)
            at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3423)
            at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:910)
            at com.mysql.jdbc.MysqlIO.secureAuth411(MysqlIO.java:3938)
            at com.mysql.jdbc.MysqlIO.doHandshake(MysqlIO.java:1273)
            at com.mysql.jdbc.ConnectionImpl.createNewIO(ConnectionImpl.java:2181)
            ... 23 more
    Hope that helps.

  5. #5
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    yes it helps - the server reports that the connection to the database failed because the database user "openexchange" can not login to the mysql server running at localhost. Have you configured a proper password for this user and is it present at both configdb.properties files?

    Greetings

  6. #6
    Al Catraz Guest

    Default

    Quote Originally Posted by Martin Braun View Post
    Hi,

    yes it helps - the server reports that the connection to the database failed because the database user "openexchange" can not login to the mysql server running at localhost. Have you configured a proper password for this user and is it present at both configdb.properties files?

    Greetings
    Well... i assumed it is done automatically by one of the scripts, since the wiki doesn't mention otherwise, respectively doesn't reflect that particular step: OX-Wiki


    THX in advance
    Last edited by Al Catraz; 08-28-2009 at 05:53 PM.

  7. #7
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    the "initconfigdb" script does create users and the configdb database, but only if the mysql user "root" has no password.

  8. #8
    Al Catraz Guest

    Default

    Quote Originally Posted by Martin Braun View Post
    Hi,

    the "initconfigdb" script does create users and the configdb database, but only if the mysql user "root" has no password.
    Hi Martin

    Working late on a friday? You _MUST_ be an engineer!!!
    I stumbled across that "password for root"-issue on my first installation attempt, read the forum entries, wiped the system completely and reinstalled from scratch.

    On my second attempt (this one) "initconfigdb" produced no errors, so i assume everything is fine (where can i check?).
    If i try to run it again, it looks like this:
    Code:
    [root@bsr1 /]# /opt/open-xchange/sbin/initconfigdb --configdb-pass='somereallystrangepassword' -a
    the database configdb exists, use the -i switch if you want to automatically delete it

  9. #9
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    you could enter the mysql console (just type mysql) and perform a
    Code:
    SHOW DATABASES
    configdb should show up after executing the initconfigdb stuff.

    Greetings

  10. #10
    Al Catraz Guest

    Default

    Seems I've got a serious problem here:
    Code:
    [root@bsr1 /]# mysql
    Welcome to the MySQL monitor.  Commands end with ; or \g.
    Your MySQL connection id is 28
    Server version: 5.0.45 Source distribution
    
    Type 'help;' or '\h' for help. Type '\c' to clear the buffer.
    
    mysql> SHOW DATABASES
        ->
    ...and that's all she wrote!I

    So now I decided, to run all the steps all over again and this time I get a different error:
    Code:
    [root@bsr1 /]# service mysqld start
    Starting MySQL:                                            [  OK  ]
    
    [root@bsr1 /]# /opt/open-xchange/sbin/initconfigdb --configdb-pass=thisisatest -ia
    initializing configdb from scratch... done
    
    [root@bsr1 /]# /opt/open-xchange/sbin/oxinstaller --servername=oxserver --configdb-pass=thisisatest --master-pass=thisisatest --ajp-bind-port=localhost
    setting up groupware configuration /opt/open-xchange/etc/groupware
    ..................................................
    groupware daemon must now be restarted if already running
    setting up admin daemon configuration /opt/open-xchange/etc/admindaemon
    ......................
    *** RMI authentication is enabled
    using oxadminmaster as master account
    admin daemon must now be restarted if already running
    
    [root@bsr1 /]# service open-xchange-admin start
    Starting open-xchange-admin daemon [done]                  [  OK  ]
    
    [root@bsr1 /]# service saslauthd start
    Starting saslauthd:                                        [  OK  ]
    
    [root@bsr1 /]# /opt/open-xchange/sbin/registerserver -n oxserver -A oxadminmaster -P thisisatest
    server could not be registered:
    Server response:
     Authentication failed
    /var/log/open-xchange/open-xchange-admin.log.0 now shows this:
    Code:
    Aug 29, 2009 6:18:48 PM com.openexchange.admin.rmi.impl.BasicAuthenticator doAuthentication
    SEVERE: Master authentication for user: oxadminmaster
    com.openexchange.admin.rmi.exceptions.InvalidCredentialsException: Authentication failed
            at com.openexchange.admin.rmi.impl.BasicAuthenticator.doAuthentication(BasicAuthenticator.java:153)
            at com.openexchange.admin.rmi.impl.OXUtil.registerServer(OXUtil.java:379)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:585)
            at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:294)
            at sun.rmi.transport.Transport$1.run(Transport.java:153)
            at java.security.AccessController.doPrivileged(Native Method)
            at sun.rmi.transport.Transport.serviceCall(Transport.java:149)
            at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:466)
            at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:707)
            at java.lang.Thread.run(Thread.java:595)
    Last edited by Al Catraz; 08-29-2009 at 08:24 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •