Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 7 of 7
  1. #1
    paul.raison Guest

    Default Database Update after Upgrade to 6.10.0

    I have just used the Ubuntu packages to upgrade to 6.10.0. When I first logged into Open-Xchange I saw briefly an error about not being able to Upgrade the database but it logged in ok. However, I don't have access to the email module. Looking at the logs, it's to do with error logging into imap server.

    How do I manually do the database upgrade which obviously failed before?

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    if the database update failed, no user in that schema can log in since it is locked. The message is typically "Updating database, please try to log in later". Please post the error messages you see at the log, otherwise we can't see whats going on.

    Thanks

  3. #3
    paul.raison Guest

    Default Upgrade to 6.10.0

    OK, so I found the following in the logs relating to the database upgrade failure:-

    Aug 30, 2009 3:36:03 PM com.openexchange.ajax.Login doGet
    SEVERE: CTX-0007 Category=4 Message=Updating database ... Try again later. exceptionID=308293189-5
    CTX-0007 Category=4 Message=Updating database ... Try again later. exceptionID=308293189-5
    at com.openexchange.authentication.database.impl.Data baseAuthentication.handleLoginInfo(DatabaseAuthent ication.java:113)
    at com.openexchange.authentication.service.Authentica tion.login(Authentication.java:92)
    at com.openexchange.login.internal.LoginPerformer.doL ogin(LoginPerformer.java:137)

    And when ever a user logs in, the following error appears in the log:-

    Aug 30, 2009 3:36:18 PM com.openexchange.groupware.settings.impl.RdbSettin gStorage readSharedValue
    SEVERE: Problem while reading setting value.
    MSG-1001 Category=3 Message=Wrong or missing login data to access server 127.0.0.1 with login raisonps (user=3, context=1). Error message from server: Error initializing TLS exceptionID=308293189-10

    Does that help?

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    well it shows that the database update tasks complete, could you please post the whole stacktrace below

    MSG-1001 Category=3 Message=Wrong or missing login data to access server 127.0.0.1 with login raisonps (user=3, context=1). Error message from server: Error initializing TLS exceptionID=308293189-10

    Thanks

  5. #5
    paul.raison Guest

    Default Upgrade to 6.10.0

    Here's the log below the error:-

    Aug 30, 2009 3:36:18 PM com.openexchange.groupware.settings.impl.RdbSettin gStorage readSharedValue
    SEVERE: Problem while reading setting value.
    MSG-1001 Category=3 Message=Wrong or missing login data to access server 127.0.0.1 with login raisonps (user=3, context=1). Error message from server: Error initializing TLS exceptionID=308293189-10
    at com.openexchange.groupware.settings.tree.modules.m ail.folder.Sent$1.getValue(Sent.java:112)
    at com.openexchange.groupware.settings.impl.RdbSettin gStorage.readSharedValue(RdbSettingStorage.java:33 3)
    at com.openexchange.groupware.settings.impl.RdbSettin gStorage.readValues(RdbSettingStorage.java:275)
    at com.openexchange.groupware.settings.impl.RdbSettin gStorage.readSubValues(RdbSettingStorage.java:384)
    at com.openexchange.groupware.settings.impl.RdbSettin gStorage.readValues(RdbSettingStorage.java:271)
    at com.openexchange.groupware.settings.impl.RdbSettin gStorage.readSubValues(RdbSettingStorage.java:384)
    at com.openexchange.groupware.settings.impl.RdbSettin gStorage.readValues(RdbSettingStorage.java:271)
    at com.openexchange.groupware.settings.impl.RdbSettin gStorage.readSubValues(RdbSettingStorage.java:384)
    at com.openexchange.groupware.settings.impl.RdbSettin gStorage.readValues(RdbSettingStorage.java:271)
    at com.openexchange.ajax.ConfigMenu.doGet(ConfigMenu. java:122)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:596)
    at com.openexchange.ajax.AJAXServlet.service(AJAXServ let.java:381)
    at com.openexchange.ajax.SessionServlet.service(Sessi onServlet.java:149)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:689)
    at com.openexchange.ajp13.najp.AJPv13RequestHandlerIm pl.doServletService(AJPv13RequestHandlerImpl.java: 429)
    at com.openexchange.ajp13.AJPv13Request.response(AJPv 13Request.java:128)
    at com.openexchange.ajp13.najp.AJPv13RequestHandlerIm pl.createResponse(AJPv13RequestHandlerImpl.java:28 2)
    at com.openexchange.ajp13.najp.AJPv13ConnectionImpl.c reateResponse(AJPv13ConnectionImpl.java:189)
    at com.openexchange.ajp13.najp.AJPv13Task.run(AJPv13T ask.java:258)
    at java.util.concurrent.Executors$RunnableAdapter.cal l(Executors.java:417)
    at java.util.concurrent.FutureTask$Sync.innerRun(Futu reTask.java:269)
    at java.util.concurrent.FutureTask.run(FutureTask.jav a:123)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run Task(ThreadPoolExecutor.java:650)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:675)
    at java.lang.Thread.run(Thread.java:595)

  6. #6
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    could it be that this IMAP server offers STARTTLS (for TLS mode) but does not initiate the connection correctly? We've added support for TLS by default with 6.10 if the IMAP server announces that it is capable to talk TLS. A network capture on port 143 would shed some more light. Any error message at the IMAP servers log?

    Greetings

  7. #7
    paul.raison Guest

    Default

    You are correct, the imap server was offering TLS but had no valid certificates to use. I have now disabled TLS on the imap server, and everything is now working again.

    Many thanks for all your help.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •