Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 7 of 7
  1. #1
    Join Date
    Feb 2008
    Location
    Germany
    Posts
    46

    Default after restore, ox6 hangs on filestore

    hello every1,

    i am trying to switch to a different server. there for i backed up (or backuped?)

    /opt/open-xchange
    /var/opt/filestore
    mysqldatabases configdb and oxdatabase_9

    i installed ox6 on the new machine and did the restore.

    after login in ox all data (kontact, calendar, jobs) show up. but when i try to take a look in the filestore, ox hanges.

    filerights are ok.

    /var/log/open-xchange.log.0 says:
    HTML Code:
    07.10.2009 16:05:20 com.openexchange.groupware.settings.impl.RdbSettingStorage readSharedValue
    SCHWERWIEGEND: Problem while reading setting value.
    MSG-1016 Category=5 Message=Connection was refused or timed out while attempting to connect to remote server localhost for user test@example.de. exceptionID=-2146516740-252
            at com.openexchange.groupware.settings.tree.modules.mail.folder.Spam$1.getValue(Spam.java:112)
            at com.openexchange.groupware.settings.impl.RdbSettingStorage.readSharedValue(RdbSettingStorage.java:333)
            at com.openexchange.groupware.settings.impl.RdbSettingStorage.readValues(RdbSettingStorage.java:275)
            at com.openexchange.groupware.settings.impl.RdbSettingStorage.readSubValues(RdbSettingStorage.java:384)
            at com.openexchange.groupware.settings.impl.RdbSettingStorage.readValues(RdbSettingStorage.java:271)
            at com.openexchange.groupware.settings.impl.RdbSettingStorage.readSubValues(RdbSettingStorage.java:384)
            at com.openexchange.groupware.settings.impl.RdbSettingStorage.readValues(RdbSettingStorage.java:271)
            at com.openexchange.groupware.settings.impl.RdbSettingStorage.readSubValues(RdbSettingStorage.java:384)
            at com.openexchange.groupware.settings.impl.RdbSettingStorage.readValues(RdbSettingStorage.java:271)
            at com.openexchange.ajax.ConfigMenu.doGet(ConfigMenu.java:122)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:596)
            at com.openexchange.ajax.AJAXServlet.service(AJAXServlet.java:365)
            at com.openexchange.ajax.SessionServlet.service(SessionServlet.java:159)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
            at com.openexchange.ajp13.najp.AJPv13RequestHandlerImpl.doServletService(AJPv13RequestHandlerImpl.java:433)
            at com.openexchange.ajp13.AJPv13Request.response(AJPv13Request.java:128)
            at com.openexchange.ajp13.najp.AJPv13RequestHandlerImpl.createResponse(AJPv13RequestHandlerImpl.java:286)
            at com.openexchange.ajp13.najp.AJPv13ConnectionImpl.createResponse(AJPv13ConnectionImpl.java:189)
            at com.openexchange.ajp13.najp.AJPv13Task.run(AJPv13Task.java:281)
            at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:417)
            at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
            at java.util.concurrent.FutureTask.run(FutureTask.java:123)
            at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
            at java.lang.Thread.run(Thread.java:595)
    the mailserver isn't setup yet. the mailfeature is locked at the moment.

    i am using ox6.12 on debian lenny with sun-java 1.50

    did anyone have similar problems during restoring an ox-server?

    greeting to all

    kniggisiggi

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    this specific error message seems to be related to the E-Mail module, not to the infostore. Are you using the exact same filestorage path than on the old server? What does /opt/open-xchange/sbin/listfilestorage output?

    Greetings

  3. #3
    Join Date
    Feb 2008
    Location
    Germany
    Posts
    46

    Default

    hi martin,

    Code:
    t# /opt/open-xchange/sbin/listfilestore -A oxadminmaster -P *geheim*
    id path                       size reserved used maxctx curctx
     3 file:///var/opt/filestore 20000     1600   20   5000      8
    when i look at the directorytree in ox6 i can see all my folders. do i click in one folder i can even open one file. after that ox hangs.

    weird is, when ever i click into the modul filestore the "neu"-button does not change to the right "new-filestore"symbol. but when i am in the calendar-modul i can create a new filestorefile over the "new-filestore"-button below the "new-calendar"-button and load the file up. the file also shows up in the filestore directory. but when i click on it shows up and hangs....

    the only difference on the systems (old server and new server) i notices ist that the uid and gid do not match. but the rights (user open-xchange and group open-xchange) on the files in /var/opt/filestore and /opt/open-xchange are set right.

    /var/log/open-xchange/open-xchange-admin-log.0 says:
    07.10.2009 14:17:26 com.openexchange.tools.oxfolder.OXFolderProperties $1 onPropertyChange
    INFO: Property 'ENABLE_INTERNAL_USER_EDIT' change propagated. ENABLE_INTERNAL_USER_EDIT=false


    what did i do wrong during backup and restore?
    Last edited by kniggisiggi; 10-08-2009 at 08:19 AM.

  4. #4
    Join Date
    Feb 2008
    Location
    Germany
    Posts
    46

    Default

    if i delete the whole filestore /var/opt/filestore the behavior is the same.

    so it seems that ox6 can't read the filestorepath.

    if i do a backup what do i need to backup?

    databases configdb and oxdatabase_9 and what else?

  5. #5
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    You need the database and the filestore. Have you checked that the user "open-xchange" has proper permissions? The groupware service runs as this user.

  6. #6
    Join Date
    Feb 2008
    Location
    Germany
    Posts
    46

    Default

    hi martin,

    i did a full reinstallation of the server the 4. time, now!!

    i checked everything a thousand times. the java-service for ox and the owner of /var/opt/filestore have the same uid!

    upload and download with my webdav-client works fine! but still when i try to take a look in the infostore modul it hangs.

    where do i find the tool checkconsistency?
    Last edited by kniggisiggi; 10-12-2009 at 02:33 PM.

  7. #7
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    This tool is available at /opt/open-xchange/sbin/ if all plugins have been installed (plugin-hosting afaik).

    Greetings

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •