Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 8 of 8
  1. #1
    blackbird Guest

    Default OX POP3 connector

    Hallo,

    wir benutzen die OpenExchange Appliance Edition und haben da ein Problem.

    Wir haben mehrere Pop3 Account unter --> Einstellungen --> Email --> Accounts angelegt.

    Diese haben auch schon funktioniert, seit heute tritt aber folgendes Problem auf. Bei einem dieser Accounts werden keine Emails mehr abgerufen und im openexchange.log steht folgender Eintrag.

    Oct 26, 2009 3:35:45 PM com.openexchange.pop3.connect.POP3SyncMessagesCall able call
    WARNING: Connect to POP3 account failed: MSG-1009 Category=1 Message=Wrong message header: Expected parameter name, got ";" exceptionID=-198405575-479
    MSG-1009 Category=1 Message=Wrong message header: Expected parameter name, got ";" exceptionID=-198405575-479
    at com.openexchange.mail.mime.MIMEMailException.handl eMessagingException(MIMEMailException.java:456)
    at com.openexchange.mail.mime.MIMEMailException.handl eMessagingException(MIMEMailException.java:364)
    at com.openexchange.mail.mime.MIMEMailException.handl eMessagingException(MIMEMailException.java:353)
    at com.openexchange.mail.mime.converters.MIMEMessageC onverter.convertMessage(MIMEMessageConverter.java: 1252)
    at com.openexchange.pop3.storage.mailaccount.MailAcco untPOP3Storage.addMessagesToStorage(MailAccountPOP 3Storage.java:415)
    at com.openexchange.pop3.storage.mailaccount.MailAcco untPOP3Storage.syncMessages(MailAccountPOP3Storage .java:342)
    at com.openexchange.pop3.connect.POP3SyncMessagesCall able.call(POP3SyncMessagesCallable.java:156)
    at java.util.concurrent.FutureTask$Sync.innerRun(Futu reTask.java:269)
    at java.util.concurrent.FutureTask.run(FutureTask.jav a:123)
    at com.openexchange.pop3.POP3Access.connectInternal(P OP3Access.java:380)
    at com.openexchange.mail.api.MailAccess.connect0(Mail Access.java:400)
    at com.openexchange.mail.api.MailAccess.connect(MailA ccess.java:353)
    at com.openexchange.mail.MailServletInterfaceImpl.ini tMailAccess(MailServletInterfaceImpl.java:1057)
    at com.openexchange.mail.MailServletInterfaceImpl.ini tConnection(MailServletInterfaceImpl.java:1034)
    at com.openexchange.mail.MailServletInterfaceImpl.get ChildFolders(MailServletInterfaceImpl.java:424)
    at com.openexchange.ajax.Folder.actionGetSubfolders(F older.java:956)
    at com.openexchange.ajax.Folder.actionGetSubfolders(F older.java:376)
    at com.openexchange.ajax.Folder.actionGet(Folder.java :243)
    at com.openexchange.ajax.Folder.doGet(Folder.java:196 )
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:596)
    at com.openexchange.ajax.AJAXServlet.service(AJAXServ let.java:365)
    at com.openexchange.ajax.SessionServlet.service(Sessi onServlet.java:159)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:689)
    at com.openexchange.ajp13.najp.AJPv13RequestHandlerIm pl.doServletService(AJPv13RequestHandlerImpl.java: 433)
    at com.openexchange.ajp13.AJPv13Request.response(AJPv 13Request.java:128)
    at com.openexchange.ajp13.najp.AJPv13RequestHandlerIm pl.createResponse(AJPv13RequestHandlerImpl.java:28 6)
    at com.openexchange.ajp13.najp.AJPv13ConnectionImpl.c reateResponse(AJPv13ConnectionImpl.java:189)
    at com.openexchange.ajp13.najp.AJPv13Task.run(AJPv13T ask.java:281)
    at java.util.concurrent.Executors$RunnableAdapter.cal l(Executors.java:417)
    at java.util.concurrent.FutureTask$Sync.innerRun(Futu reTask.java:269)
    at java.util.concurrent.FutureTask.run(FutureTask.jav a:123)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run Task(ThreadPoolExecutor.java:650)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:675)
    at java.lang.Thread.run(Thread.java:595)
    Caused by: javax.mail.internet.ParseException: Expected parameter name, got ";"
    at javax.mail.internet.ParameterList.<init>(Parameter List.java:234)
    at javax.mail.internet.ContentType.<init>(ContentType .java:110)
    at javax.mail.internet.MimeMultipart.parsebm(MimeMult ipart.java:786)
    at javax.mail.internet.MimeMultipart.parse(MimeMultip art.java:493)
    at javax.mail.internet.MimeMultipart.getCount(MimeMul tipart.java:240)
    at com.openexchange.mail.mime.utils.MIMEMessageUtilit y.hasAttachments(MIMEMessageUtility.java:411)
    at com.openexchange.mail.mime.converters.MIMEMessageC onverter.convertMessage(MIMEMessageConverter.java: 1159)

    Bei einem anderen Account auf dem gleichen Server funktioniert alles.. Kann das mit einer "schlechten" Email zusammenhängen?

    Updates sind alle aktuell. Ein neubooten des Systems brachte keine Besserung.

    Vielen Dank

    Matthias
    Last edited by blackbird; 10-26-2009 at 06:12 PM.

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hallo Matthias,

    ja das kann durchaus mit einer "schlechten" E-Mail zusammenhängen, habt ihr eine Möglichkeit diese auszumachen? Generell sollte natürlich weiterhin ein Zugriff auf den Account möglich sein, ich werde mal einen Bug dazu aufmachen. Falls du noch mehr Informationen liefern kannst wäre das Klasse.

    https://bugs.open-xchange.com/show_bug.cgi?id=14716

    Gruß und vielen Dank
    Last edited by Martin Heiland; 10-26-2009 at 06:38 PM.

  3. #3
    blackbird Guest

    Default

    Jut, danke .. ich habe den Fehler gefunden .. lag tatsächlich an einer "schlechten" Email... und zwar..

    Content-Type: multipart/alternative;;
    boundary="----------part_1_4ae152c32febe"
    Ich denke die zwei ";" sind Schuld..

    ist ein Newsletter eines größeren Unternehmens gewesen..

    Viele Grüße

    Matthias Vierling

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Vielen Dank!

    Wenn möglich kannst du die E-Mail an den Bug anhängen, oder einfach hier posten/mir als PM schicken dann mache ich das für dich.

    Gruß

  5. #5
    blackbird Guest

    Default

    HI,

    geht leider nicht, da es eine Email von einem unserer Kunden ist. Ich werde ihn aber mal fragen.

    Grüße

    Matthias

  6. #6
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    du könntest sensible Daten in der EML löschen oder ändern. Es kommt wohl eher auf die Struktur an.

    Gruß

  7. #7
    blackbird Guest

    Default

    Hier der Header

    Return-Path: <newsletter@XXX.de>
    X-Spam-Checker-Version: SpamAssassin 3.2.4 (2008-01-01) on XXX.XX
    X-Spam-Level:
    X-Spam-Status: Spam=No, score=-2.6 required=5.0 tests=BAYES_00,HTML_MESSAGE
    autolearn=ham
    Delivered-To: ###@####.##
    X-Greylist: delayed 00:09:17 by SQLgrey-1.6.7
    Received: from XXX.XXX (XXX.XXX [##.##.##.##])
    by XXX.XXX (Postfix) with ESMTP id 934B536F004F
    for <###@####.##>; Fri, 23 Oct 2009 09:02:29 +0200 (CEST)
    Received: (qmail 24415 invoked by uid 99); 23 Oct 2009 08:52:51 +0200
    Date: 23 Oct 2009 08:52:51 +0200
    To: ###@####.##
    Subject: Newsletter 2009-10
    Message-ID: <98729f7d63c1287273f4ae2be6a6082c@XXX>
    Errors-To: ###@####.##
    X-Typo3MID: MID35_t444-a49bbad44fdf1db83c1ab558ee8db851
    From: ### <###@####.##>
    Reply-To: ### <###@####.##>
    Organisation: ###
    X-Mailer: TYPO3 Direct Mail module
    X-Priority: 3
    Mime-Version: 1.0
    Content-Type: multipart/alternative;;
    boundary="----------part_1_4ae152c32febe"
    Tux-ID: 1256281349-29715
    X-Tobit-To: ###@####.##
    X-Delivery-Agent: maildrop 2.0.3 Copyright 1998-2005 Double Precision, Inc. on XXX
    X-Virus-Status: No
    X-Virus-Checker-Version: clamassassin 1.2.3-r1 with clamdscan / ClamAV 0.95.1/9930/Fri Oct 23 04:00:24 2009

  8. #8
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hallo,

    das Problem sollte mittlerweile gelöst sein.

    Gruß

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •