Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 7 of 7
  1. #1
    Sven.B Guest

    Default OX6 Upgrade und rpmnew files

    Hallo Forum

    Ich habe gerade mein OX6 von 6.6 (Stabil) auf 6.12.0.0-9_9.1 es funktioniert soweit alles bis auf den IMAP Connect.
    Ich habe nun mal in /opt/open-xchange/etc/groupware geschaut

    HTMLEntities.properties
    cache.ccf
    event.properties
    ldapauth.properties
    notification.properties
    server.properties.rpmnew
    spamassassin.properties
    TidyConfiguration.properties
    cache.ccf.rpmnew
    file-logging.properties
    mail.properties
    osgi
    servletmappings
    system.properties
    TidyMessages.properties
    calendar.properties
    imap.properties
    mail.properties.rpmnew
    ox-scriptconf.sh
    sessioncache.ccf
    system.properties.rpmnew
    ajp.properties
    configdb.properties
    importerExporter.xml
    mailcache.ccf
    ox-scriptconf.sh.rpmnew
    sessioncache.ccf.rpmnew
    transport.properties
    ajp.properties.rpmnew
    configdb.properties.rpmnew
    infostore.properties
    mailfilter.properties
    participant.properties
    sessiond.properties
    updatetasks.cfg
    attachment.properties
    configjump.properties
    javamail.properties
    mailfilter.properties.rpmnew
    push.properties
    settings
    whitelist.properties
    axis2.properties
    contact.properties
    ldap.properties
    mime.types
    server.properties
    smtp.properties

    hier sind nun lauter neue *.rpmnew files werden diese nun benutzt?
    woran kann es liegen das ich kein imap connect mehr habe?

    Danke schon mal im Voraus

    MFG
    Sven
    Attached Files Attached Files

  2. #2
    Sven.B Guest

    Default

    keiner eine Idee?

    In den Logs habe ich noch was gefunden, aber kann nix damit anfangen:

    Nov 11, 2009 2:31:52 PM com.openexchange.ajax.Folder$1 call
    SEVERE: MSG-1027 Category=8 Message=An error in protocol to mail server 195.95.220.110 with login foobar (user=92, context=1). Error message: * BYE JavaMail Exception: javax.net.ssl.SSLException: java.lang.IllegalArgumentException exceptionID=-173518754-38
    MSG-1027 Category=8 Message=An error in protocol to mail server 195.95.220.110 with login foobar (user=92, context=1). Error message: * BYE JavaMail Exception: javax.net.ssl.SSLException: java.lang.IllegalArgumentException exceptionID=-173518754-38

  3. #3
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hallo,

    die .rpmnew Dateien werden anlegt wenn du beim Update sagst "Ich will meine Konfiguration behalten". Die neuen Konfigurationsparameter und Standardwerte von 6.12 sind in den .rpmnew Dateien, die alten Dateien enthalten die Konfiguration für 6.6. Da zwischen diesen Releases mehr als ein Jahr liegt, solltest du dringend die Konfiguration von 6.12 übernehmen, diff kann helfen.
    Der IMAP Connect *könnte* mit der Konfiguration zusammenhängen, aber da will ich mich nicht festlegen. Mit 6.12 nutzen wir TLS sofern der IMAP Server es anbietet. Kann es sein dass der IMAP Server zwar TLS anbietet aber es nicht wirklich unterstützt?

    Gruß

  4. #4
    Sven.B Guest

    Default

    Hi Martin

    Vielen Dank für die Infos, die bringen mich schon etwas weiter.

    Auf dem Mailserver sehe ich im Log:
    Nov 11 14:21:51 mail imap[959]: STARTTLS negotiation failed: ox.server.intern

    ich habe mal den imap server abgefragt was er kann und ich bin mir auch sicher das er TLS kann.
    <snip>
    * CAPABILITY IMAP4 IMAP4rev1 ACL QUOTA LITERAL+ MAILBOX-REFERRALS NAMESPACE UIDPLUS ID NO_ATOMIC_RENAME UNSELECT CHILDREN MULTIAPPEND BINARY SORT THREAD=ORDEREDSUBJECT THREAD=REFERENCES ANNOTATEMORE IDLE STARTTLS AUTH=LOGIN AUTH=PLAIN SASL-IR X-NETSCAPE
    <snap>
    zumindest bietet er es an, ich habe es mit Outlook getestet und TLS aktiviert und die Zertifikats abfrage kommt auch.

    kann man das STARTTLS am OX ausschalten?

  5. #5
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    schau mal bitte /opt/open-xchange/etc/groupware/javamail.properties
    #mail.smtp.starttls.enable
    #mail.imap.starttls.enable

    Und die zugehörige Dokumentation.

    Gruß

  6. #6
    Sven.B Guest

    Default

    Hi Martin
    habe nun mal die neuen *.rpmnew files angepasst, zur /opt/open-xchange/etc/groupware/javamail.properties datei, die parameter sind da bei mir:
    #mail.smtp.starttls.enable
    #mail.imap.starttls.enable
    also nicht aktive.

    Nun bekomme ich beide services (groupware und admin) gestartet aber beim Anmelden bekomme ich nun : Fehlermeldung: 503 - Service Temporarily Unavailable

    wie gesagt die beiden Dienste laufen und Java auch siehe:
    ps axf|grep java
    6823 pts/0 S+ 0:00 | \_ grep java
    5863 pts/0 Sl 0:03 /usr/lib/jvm/java-1_5_0-ibm-1.5.0/jre/bin/java -Xms100m -Xmx100m -XX:+UseConcMarkSweepGC -XX:NewSize=50m -XX:MaxNewSize=50m -XX:SurvivorRatio=6 -Dopenexchange.propdir=/opt/open-xchange/etc/admindaemon -Dopenexchange.propdir2=/opt/open-xchange/etc/common -Dconfigdir=/opt/open-xchange/etc/admindaemon -Djava.util.logging.config.file=/opt/open-xchange/etc/admindaemon/file-logging.properties -Duser.timezone=GMT -Dlibdir=/opt/open-xchange/bundles/com.openexchange.common/lib -jar /opt/open-xchange/bundles/org.eclipse.osgi_3.3.0.v20070530.jar -configuration file:/opt/open-xchange/etc/admindaemon/osgi/
    5951 pts/0 Sl 0:04 \_ /usr/lib/jvm/java-1_5_0-ibm-1.5.0/jre/bin/java -Xmx512M -XX:+UseConcMarkSweepGC -Djava.awt.headless=true -Dopenexchange.propdir=/opt/open-xchange/etc/groupware -Dopenexchange.propdir2=/opt/open-xchange/etc/common -Djava.util.logging.config.file=/opt/open-xchange/etc/groupware/file-logging.properties -jar /opt/open-xchange/bundles/org.eclipse.osgi_3.3.0.v20070530.jar -configuration file:/opt/open-xchange/etc/groupware/osgi

    was mich ein wenig irritriert ist das java nicht auf 8009 lauscht

    netstat -nlp |grep java
    tcp 0 0 0.0.0.0:8260 0.0.0.0:* LISTEN 5863/java
    tcp 0 0 127.0.0.1:1099 0.0.0.0:* LISTEN 5863/java
    tcp 0 0 127.0.0.1:9998 0.0.0.0:* LISTEN 5863/java
    tcp 0 0 127.0.0.1:9999 0.0.0.0:* LISTEN 5951/java
    tcp 0 0 0.0.0.0:57461 0.0.0.0:* LISTEN 5863/java
    tcp 0 0 0.0.0.0:23901 0.0.0.0:* LISTEN 5951/java
    udp 0 0 0.0.0.0:6780 0.0.0.0:* 5863/java

    ist das richtig?

    In den Logs kann ich nichts auffälliges endecken.

    hast du noch eine Idee?
    Attached Files Attached Files

  7. #7
    Sven.B Guest

    Default

    Hi martin,

    habe es nun hinbekommen das ich mich wieder einloggen kann, Fehler war von mir das ich die datei cache.ccf.rpmnew nicht umbenannt hatte.
    Aber was ich immer noch nicht hinbekommen habe, ist das ich den IMAP Ordner sehe.

    greets Sven

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •