Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 5 of 5
  1. #1
    Bellerophon Guest

    Default Property "MAX_UPLOAD_SIZE" is not defined

    Hallo

    Ich hoffe ihr könnt mir dabei helfen, wie ich heute mitbekommen habe läuft seit dem update auf 6.12.0 Rev7 von 6.10 der mail versandt nicht mehr mir folgendem fehler in den logs:

    Code:
    SEVERE: CFG-0005 Category=10 Message=Property "MAX_UPLOAD_SIZE" is not defined. exceptionID=-565077812-154913
    CFG-0005 Category=10 Message=Property "MAX_UPLOAD_SIZE" is not defined. exceptionID=-565077812-154913
            at com.openexchange.configuration.ServerConfig.getInt(ServerConfig.java:283)
            at com.openexchange.mail.json.parser.AbstractAttachmentHandler.<init>(AbstractAttachmentHandler.java:105)
            at com.openexchange.mail.json.parser.AbortAttachmentHandler.<init>(AbortAttachmentHandler.java:31)
            at com.openexchange.mail.json.parser.MessageParser.parse(MessageParser.java:203)
            at com.openexchange.mail.json.parser.MessageParser.parse4Transport(MessageParser.java:173)
            at com.openexchange.ajax.Mail.action(Mail.java:3472)
            at com.openexchange.ajax.AJAXServlet.fireUploadEvent(AJAXServlet.java:682)
            at com.openexchange.ajax.Mail.doPost(Mail.java:3346)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:616)
            at com.openexchange.ajax.AJAXServlet.service(AJAXServlet.java:365)
            at com.openexchange.ajax.SessionServlet.service(SessionServlet.java:159)
            at com.openexchange.ajax.PermissionServlet.service(PermissionServlet.java:66)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
            at com.openexchange.ajp13.najp.AJPv13RequestHandlerImpl.doServletService(AJPv13RequestHandlerImpl.java:433)
            at com.openexchange.ajp13.AJPv13Request.response(AJPv13Request.java:128)
            at com.openexchange.ajp13.najp.AJPv13RequestHandlerImpl.createResponse(AJPv13RequestHandlerImpl.java:286)
            at com.openexchange.ajp13.najp.AJPv13ConnectionImpl.createResponse(AJPv13ConnectionImpl.java:189)
            at com.openexchange.ajp13.najp.AJPv13Task.run(AJPv13Task.java:281)
            at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:417)
            at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
            at java.util.concurrent.FutureTask.run(FutureTask.java:123)
            at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
            at java.lang.Thread.run(Thread.java:595)
    die 2 möglichen werte unter attachment.properties und server.properties sind beide auf 0 gesetzt.

    update: Der Fehler tritt nur sporadisch auf, ich kann zumindest kein muster darin erkennen ob eine mail durchgeht und eine andere nicht.

    ich hoffe das mit jemand von euch hier weiterhelfen kann.

    lg
    Last edited by Bellerophon; 11-11-2009 at 04:20 PM.

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    bist du sicher dass das Versenden von E-Mails mit diesem Fehler zusammenhängt? Eigentlich ist es eher eine Warnung die beim starten des Servers auftreten kann. Tritt der Fehler tatsächlich in dem Moment auf wo der Benutzer auf "senden" klickt? Oder kommt vielleicht noch eine andere Meldung.

    Gruß

  3. #3
    Bellerophon Guest

    Default

    hallo

    die meldung tritt nicht auf beim starten des servers sondern genau in dem moment wen ein user versucht eine mail zu versenden, sonst kommt keine meldung in den logs. das komische ist hier das ca. 10-15% der mails trotzdem ausgeliefert werden und 85-90% nicht. es wird hier vom ox aus keine verbindung mit dem smtp relay hergestellt aus welchem grund auch immer.

    gibt es vielleicht einen verbose switch oder ähnliches um ein erweitertes logging zu erhalten im ox ? bzw mit welchen informationen könnte ich sonst helfen ?

    lg

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    also in Fällen in denen Fehler bei Benutzeraktionen auftreten, sollte das logging schon entsprechend verbose sein. Du kannst aber zusätzlich mal die file-logging.properties anpassen und beim obersten Eintrag "DEBUG" reinschreiben. Vorsicht: Durch Debuglog wird die OX zum Festplattenbenchmark...

  5. #5
    Bellerophon Guest

    Default

    danke für diesen tip, es hat sich auf erübrigt, der fehler wurde von einem exim daemon hervorgerufen der zwar vom ox die mail's angenohmen hat aber nicht mehr weiterverarbeitete und auch keine logmeldung dazu geliefert hat, dadurch hatte ich zuerst an den ox selber gedacht.

    danke nochmal trotzdem für die schnelle hilfe.

    lg

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •