Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 10 of 10
  1. #1

    Default Mail Filters with Sieve Server

    Hello,

    I configure open-xchange with ldapsync in a OpenSuse 11.2

    My mail server is a Cyrus-IMAP and Postfix, with a OpenLDAP in a OpenSuse 11.2.

    I have myuser with default imap mail OK.

    PROBLEM: When I try make a Mail Filter in OpenXchange I see this error:

    11-27-2009 08:05 PM-->Error: Error while communicating with the sieve server mysrvmail at port 2000 for user myuser in context 1 (MAIL_FILTER-0015, 793855225-19)

    I try configure the SIEVE parameters in the mailfilter.properties but I have always the same error.

    I need some especial configuration in a sieve server?
    This is other configurartion file for the sieve server in open-xchange.

    Tanks in advance!

    Joan
    Last edited by joan-open; 11-27-2009 at 09:13 PM.

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    does your mail backend support sieve at all? You might have to activate this feature at cyrus.

    Greetings

  3. #3

    Default

    Hi Martin,

    My sieve is running. I try activate a sieve filter in my imap server with sieveshell from other server and it works fine, but I must entry a password 2 times: It is for the autenticationn mechanism.

    In a /etc/imapd.conf of my imap server file I add a line:
    sasl_mech_list: PLAIN
    and now I must entry the password only one time from this other server and I can activate sieve filter, but from the OX I receive the same error.

    I look for the versions of cyrus modules in my my server:

    srvmail:/etc/pam.d # rpm -qa | grep cyrus
    cyrus-sasl-saslauthd-2.1.23-3.1.i586
    cyrus-sasl-digestmd5-2.1.23-3.1.i586
    cyrus-sasl-2.1.23-3.1.i586
    cyrus-sasl-crammd5-2.1.23-3.1.i586
    cyrus-imapd-2.3.14-8.3.i586
    cyrus-sasl-gssapi-2.1.23-3.1.i586
    cyrus-sasl-plain-2.1.23-3.1.i586

    The OX put the filter in the sieve directory of my imap server but it can't activate the filter.

    Perhaps it is the autentication mechanism? What mechanism use OX? It is possible change this mechanism in OX or in my imap server? How?

    Tanks,

    Joan
    Last edited by joan-open; 12-01-2009 at 01:14 PM. Reason: complete

  4. #4

    Default

    Hi !

    I update Open-Xchange to a 6.14 version and the sieve filters works fine now!

    best regards,

    Joan

  5. #5
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Nice to hear that. We have improved sieve over tls with 6.14, especially for cyrus.

  6. #6

    Default

    Quote Originally Posted by Martin Braun View Post
    Nice to hear that. We have improved sieve over tls with 6.14, especially for cyrus.
    Jetzt verstehe, ich warum bringt ox6-webclient diese berüchtigte Sieve-Fehlermeldung nach dem Update zu 6.14. Mit sieveshell bzw. Smartsieve kann ich mich wunderbar anmelden.
    Gibt es ein Workaround um Sieve über TLS erstmal zu deaktivieren, solange eine Lösung gefunden wird?

    Danke
    Gruß Johann

  7. #7
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    No, it is currently not possible to turn off TLS on the open-xchange side. The only way is to disable it on the SIEVE implementations side.
    OXpedia.org - the answer to almost all questions.

  8. #8

    Default

    Jetzt verstehe, ich warum bringt ox6-webclient diese berüchtigte Sieve-Fehlermeldung nach dem Update zu 6.14.
    Welche Fehlermeldung genau meinst du hier, und die Systemdaten wären interessant.

    Mit sieveshell bzw. Smartsieve kann ich mich wunderbar anmelden.
    Sieveshell kann kein TLS da tritt der Fehler definitiv nicht auf. Smartsieve hingegen kann TLS laut Doku. Hast du das auch dort mit TLS getestet? Das Problem ist TLS und Cyrus spezifisch, weil Cyrus sich bis zu einer bestimmten Version nicht RFC konform verhält.

    Genauere Details zu dem Problem siehe hier

    Gibt es ein Workaround um Sieve über TLS erstmal zu deaktivieren, solange eine Lösung gefunden wird?
    Deaktivieren kann man TLS z.Zt. leider nicht, das wird aber mit einer zukünftigen Version kommen. Als Workaround kann ich z.Zt. bei Cyrus nur empfehlen, die beiden Pakete von 6.12 und 6.14 mal zu testen (also nur die Mailfilter Pakete der Rest kann gleich bleiben) in der Regel funktioniert eines von beiden.

  9. #9

    Default

    Quote Originally Posted by Dennis Sieben View Post
    Welche Fehlermeldung genau meinst du hier, und die Systemdaten wären interessant.

    Sieveshell kann kein TLS da tritt der Fehler definitiv nicht auf. Smartsieve hingegen kann TLS laut Doku. Hast du das auch dort mit TLS getestet? Das Problem ist TLS und Cyrus spezifisch, weil Cyrus sich bis zu einer bestimmten Version nicht RFC konform verhält.

    Genauere Details zu dem Problem siehe hier



    Deaktivieren kann man TLS z.Zt. leider nicht, das wird aber mit einer zukünftigen Version kommen. Als Workaround kann ich z.Zt. bei Cyrus nur empfehlen, die beiden Pakete von 6.12 und 6.14 mal zu testen (also nur die Mailfilter Pakete der Rest kann gleich bleiben) in der Regel funktioniert eines von beiden.
    1. Error:
    SEVERE: MAIL_FILTER-0014 Category=8 Message=Error in low level connection to sieve server exceptionID=610564281-853

    2. Angaben
    rpm -qa |grep cyrus
    cyrus-imapd-2.3.7

    cat /etc/redhat-release
    CentOS release 5.4 (Final)

    java -version
    java version "1.5.0_15"

    3. Smartsieve mit TLS getestet:

    'server' => '127.0.0.1',
    'sieveport' => '2000',
    'imapport' => '143/imap/tls',

    4. gnutls-cli --crlf --starttls -p 2000 192.168.2.132
    Resolving '192.168.2.132'...
    Connecting to '192.168.2.132:2000'...

    - Simple Client Mode:

    "IMPLEMENTATION" "Cyrus timsieved v2.3.7-Invoca-RPM-2.3.7-7.el5_4.3"
    "SASL" "PLAIN LOGIN"
    "SIEVE" "comparator-i;ascii-numeric fileinto reject vacation imapflags notify envelope relational regex subaddress copy"
    "STARTTLS"
    OK
    *** Starting TLS handshake
    *** Fatal error: A record packet with illegal version was received.
    *** Handshake has failed
    Speicherzugriffsfehler



    5. Vielen Dank, ich werde versuchen mit dem Paket 6.12
    Last edited by johann8; 12-02-2009 at 05:27 PM.

  10. #10

    Thumbs up

    Ich habe zuerst unter VMWare getestet open-xchange-mailfilter 6.14 deinstalliert und 6.12 installiert. Funktioniert super, keine Errors mehr.

    Nach den Tests werde ich das Update auf dem Produktivserver auf 6.14 durchführen.

    Vielen Dank für den Tipp
    Last edited by johann8; 12-02-2009 at 05:21 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •