Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 7 of 7
  1. #1
    threeves Guest

    Default OX Server Community v6.14, sun java 1.6

    I'm installing OX Server stable (v6.14) on a Centos v5.4 x86_64 box. OX docs say java 1.6 can be used as of OX Server v6.10, so I download and install Sun java JDK as the ONLY version on my system.

    Here's "java -version" output:
    java version "1.6.0_17"
    Java(TM) SE Runtime Environment (build 1.6.0_17-b04)
    Java HotSpot(TM) 64-Bit Server VM (build 14.3-b01, mixed mode)

    Add JAVA_HOME and JRE_HOME to my profile for grins:
    > env
    SSH_AGENT_PID=3505
    HOSTNAME=prod2server.xchange-xpress.com
    DESKTOP_STARTUP_ID=
    TERM=xterm
    SHELL=/bin/bash
    HISTSIZE=1000
    GTK_RC_FILES=/etc/gtk/gtkrc:/root/.gtkrc-1.2-gnome2
    WINDOWID=26214481
    JRE_HOME=/usr/java/jdk1.6.0_17/jre/
    USER=root
    LS_COLORS=no=00:fi=00:di=00;34:ln=00;36i=40;33:so=00;35:bd=40;33;01:cd=40;33;01r=01;05;37;41:mi=01;05;37;41:ex=00;32:*.cmd=00;32: *.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*. sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.arj =00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00; 31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.bz=00;31:*.t z=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif =00;35:*.bmp=00;35:*.xbm=00;35:*.xpm=00;35:*.png=0 0;35:*.tif=00;35:
    GNOME_KEYRING_SOCKET=/tmp/keyring-1ndLHt/socket
    SSH_AUTH_SOCK=/tmp/ssh-CiAiot3469/agent.3469
    SESSION_MANAGER=local/prod2server.xchange-xpress.com:/tmp/.ICE-unix/3469
    MAIL=/var/spool/mail/root
    PATH=/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin:JAVA_HOME=/usr/java/jdk1.6.0_17/
    DESKTOP_SESSION=default
    GDM_XSERVER_LOCATION=local
    INPUTRC=/etc/inputrc
    PWD=/root
    JAVA_HOME=/usr/java/jdk1.6.0_17/
    XMODIFIERS=@im=none
    LANG=en_US.UTF-8
    GDMSESSION=default
    SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
    JDK_HOME=/usr/java/jdk1.6.0_17/
    SHLVL=2
    HOME=/root
    GNOME_DESKTOP_SESSION_ID=Default
    LOGNAME=root
    CVS_RSH=ssh
    DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-RcN6TGmjmF,guid=ff27f7e1ef482fd822eb84004b1ef933
    LESSOPEN=|/usr/bin/lesspipe.sh %s
    DISPLAY=:0.0
    G_BROKEN_FILENAMES=1
    COLORTERM=gnome-terminal
    XAUTHORITY=/tmp/.gdmEKV43U
    _=/bin/env

    run the "yum install ..." list from the RHEL docs and get this output:
    open-xchange-server-6.14.0.0-6_7.1.noarch from ox has depsolving problems
    --> Missing Dependency: java-1.5.0-sun is needed by package open-xchange-server-6.14.0.0-6_7.1.noarch (ox)
    Error: Missing Dependency: java-1.5.0-sun is needed by package open-xchange-server-6.14.0.0-6_7.1.noarch (ox)

    Hmmmm...am I missing a flag or variable somewhere? Any input would be appreciated.

    Sincerely,
    Thomas

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi Thomas,

    the packages for this distribution have dependencies on Sun Java 1.5 while you have installed Sun Java 1.6. OX works with both versions but the packages depend on one specific.

    Greetings

  3. #3
    threeves Guest

    Red face Clear Now...

    Doooooh! I misunderstood what I had read. Thanks for the clarification.

  4. #4
    fernandoc Guest

    Default Ok, then How can that be solved?

    Hola,
    I have been trying with this issue, I'm usind Ubuntu 9.10 Server (64-bit), intalled:
    Java6 problem started
    Java5 problem continued
    removed Java6, left Java5 alone: problem continued
    Installed Java from .bin files: java 6 and/or Java5: same history.
    Removed (purged) everything OX6 +Javas (all of them), reinstalled from zero: same history...
    So, here I am:Claiming for help!!!!!
    Thanks,
    Fernando

  5. #5
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    please post the output of java -version

    Thanks

  6. #6
    roberto Guest

    Default

    hi threeves,

    install this fake-rpm.

    touch OX-Java-Fake.spec
    (fill it with content below)
    rpmbuild -bb OX-Java-Fake.spec
    rpm -ivh /usr/src/redhat/RPMS/noarch/OX-Java-Fake-1.0-1.noarch.rpm

    i have only this fake-rpm and
    jpackage-utils-1.7.3-1jpp.2.el5.noarch
    java-1.6.0-openjdk-1.6.0.0-1.7.b09.el5.x86_64
    from centos-repository installed.

    saluti
    roberto

    #
    # rpmbuild -bb OX-Java-Fake.spec
    #
    Name: OX-Java-Fake
    Summary: Fake fuer Open-Xchange
    Version: 1.0
    Release: 1
    License: internal use only
    Group: Development/Tools
    Provides: java-1.5.0-sun
    AutoReqProv: no
    BuildRequires: bash
    BuildArch: noarch
    BuildRoot: %{_tmppath}/%{name}-%{version}

    %description
    Dieses Paket soll dem Open-Xchange vortaeuschen, es sei installiert...

    %changelog
    * Wed Jan 07 2010 Roberto
    o Initial release

    %prep

    %build

    %install

    %clean
    [ "%{buildroot}" != '/' ] && rm -rf %{buildroot}

    %pre

    %post

    %preun

    %postun

    %files
    %defattr(-,root,root)
    Last edited by roberto; 01-21-2010 at 12:22 AM.

  7. #7
    egarzaj Guest

    Default now i get this

    error: open of OX-Java-Fake failed: No such file or directory
    error: open of Summary: failed: No such file or directory
    error: open of Fake failed: No such file or directory
    error: open of fuer failed: No such file or directory
    error: open of Open-Xchange failed: No such file or directory
    error: open of Version: failed: No such file or directory
    error: open of 1.0 failed: No such file or directory
    error: open of Release: failed: No such file or directory
    error: open of 1 failed: No such file or directory
    error: open of License: failed: No such file or directory
    error: open of internal failed: No such file or directory
    error: open of use failed: No such file or directory
    error: open of only failed: No such file or directory
    error: open of Group: failed: No such file or directory
    error: open of Development/Tools failed: No such file or directory
    error: open of Provides: failed: No such file or directory
    error: open of java-1.5.0-sun failed: No such file or directory
    error: open of AutoReqProv: failed: No such file or directory
    error: open of no failed: No such file or directory
    error: open of BuildRequires: failed: No such file or directory
    error: open of bash failed: No such file or directory
    error: open of BuildArch: failed: No such file or directory
    error: open of noarch failed: No such file or directory
    error: open of BuildRoot: failed: No such file or directory
    error: open of /var/tmp/%{name}-%{version} failed: No such file or directory
    error: open of %description failed: No such file or directory
    error: open of Dieses failed: No such file or directory
    error: open of Paket failed: No such file or directory
    error: open of soll failed: No such file or directory
    error: open of dem failed: No such file or directory
    error: open of Open-Xchange failed: No such file or directory
    error: open of vortaeuschen, failed: No such file or directory
    error: open of es failed: No such file or directory
    error: open of sei failed: No such file or directory
    error: open of installiert... failed: No such file or directory
    error: open of %changelog failed: No such file or directory
    error: open of Name: failed: No such file or directory
    error: open of OX-Java-Fake failed: No such file or directory
    error: open of Summary: failed: No such file or directory
    error: open of Fake failed: No such file or directory
    error: open of fuer failed: No such file or directory
    error: open of Open-Xchange failed: No such file or directory
    error: open of Version: failed: No such file or directory

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •