Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1
    Gertjan Guest

    Default OXtender TB + Community Edition

    Hi Folks,

    Today I tried to connect Thunderbird (3) and OX-CE (6.14, on OpenSUSE 11.2), but without success. I can install the OXt4TB 1.5.5b4 on both a WinXP and an OpenSUSE 11.2 client, I can set the preferences. (Lightning is installed okay, no errors about missing things.) But it does not seems to even try to connect to the server, no entries in the logs (both on client as on server).
    Is the connector capable of connecting to OX 6.14 community edition?
    What am I doing wrong? As server, why can I only give a http://123.456.789.123 or http://www.server.tld server name, and not http://www.server.tld/oxdir ? Do I have to fill out a port number? (I presume it's just port 80)
    Can anybody confirm this issue?

  2. #2
    Join Date
    Nov 2009
    Posts
    104

    Default

    Hi,

    did you try to enable the logging in the OXtender preferences? Maybe then you find a problem in the logs.

    Best regards,
    Sebastian

  3. #3
    Gertjan Guest

    Default

    The only thing in the log on the clients is:
    Code:
    init logs
    But I just discover I cannot enable logging. When I try to enable it, the check mark is gone when I want to change the settings again.
    Last edited by Gertjan; 12-21-2009 at 12:48 PM.

  4. #4
    Gertjan Guest

    Default

    And another update:
    If I use a non-existing user, I receive an error: "Authentication failed".
    So, it does seem to work partially.

  5. #5
    Gertjan Guest

    Default

    And there is evidence of even more activity. The Apache access log do show, contrary to what I claimed before, some lines related to the OXtender:
    Code:
    123.456.789.123 - - [21/Dec/2009:18:19:47 +0100] "GET /ajax/login HTTP/1.1" 200 137 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091204 Lightning/1.0b2pre Thunderbird/3.0"
    123.456.789.123 - - [21/Dec/2009:18:19:49 +0100] "POST /ajax/login HTTP/1.1" 200 90 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091204 Lightning/1.0b2pre Thunderbird/3.0"
    123.456.789.123 - - [21/Dec/2009:18:19:52 +0100] "GET /ajax/config/identifier?session=e1249f0d04d247578302c0ee9d17ecd6 HTTP/1.1" 200 10 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091204 Lightning/1.0b2pre Thunderbird/3.0"
    123.456.789.123 - - [21/Dec/2009:18:19:52 +0100] "GET /ajax/config/context_id?session=e1249f0d04d247578302c0ee9d17ecd6 HTTP/1.1" 200 10 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091204 Lightning/1.0b2pre Thunderbird/3.0"
    123.456.789.123 - - [21/Dec/2009:18:19:52 +0100] "GET /ajax/contacts?action=updates&session=e1249f0d04d247578302c0ee9d17ecd6&folder=6&columns=1%2C500%2C524%2C555&timestamp=0&ignore=deleted HTTP/1.1" 200 190 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091204 Lightning/1.0b2pre Thunderbird/3.0"
    123.456.789.123 - - [21/Dec/2009:18:19:53 +0100] "PUT /ajax/group?action=search&session=e1249f0d04d247578302c0ee9d17ecd6 HTTP/1.1" 200 232 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091204 Lightning/1.0b2pre Thunderbird/3.0"
    123.456.789.123 - - [21/Dec/2009:18:19:53 +0100] "PUT /ajax/resource?action=search&session=e1249f0d04d247578302c0ee9d17ecd6 HTTP/1.1" 200 25 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091204 Lightning/1.0b2pre Thunderbird/3.0"
    123.456.789.123 - - [21/Dec/2009:18:19:53 +0100] "GET /ajax/folders?action=updates&ignore=deleted&timestamp=0&columns=1%2C2%2C5%2C300%2C301%2C302%2C308&session=e1249f0d04d247578302c0ee9d17ecd6 HTTP/1.1" 200 845 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091204 Lightning/1.0b2pre Thunderbird/3.0"
    123.456.789.123 - - [21/Dec/2009:18:19:54 +0100] "GET /ajax/login?action=logout HTTP/1.1" 400 237 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091204 Lightning/1.0b2pre Thunderbird/3.0"
    But in both my OX calendar and my Lighting calendar nothing happens. I also cannot select an address book.
    Last edited by Gertjan; 12-21-2009 at 07:27 PM.

  6. #6
    Join Date
    Nov 2009
    Posts
    104

    Default

    Hi,

    so if there are no logs in the log file you can see all log messages the the Thunderbird Error Console. In the menu "Extras" --> "Error Console". Maybe there we find a hint what caused the problems.

    Best regards,
    Sebastian

  7. #7
    Gertjan Guest

    Default

    Hi Sebastian,

    Thanks for mentioning the TB error console.

    After some lines about tables which already exists, the OXt4TB tries to set up a new db connection ("get new db connection, current counter is 1"), I receive an "exeption detected", an empty error, and both are repeated once.

    Afterwards many lines appear, most of them look like openening the db on the server, get info, try to sync, but nothing happens at the client.

    To me, it seems strange that I only can save settings about the server and user, all other tabs are reset when I want to change values in the OXt4TB preferences.

  8. #8
    Join Date
    Nov 2009
    Posts
    104

    Default

    Hi,

    you can enable the debug logs manually in the Thunderbird preferences. I don't know the extact english terms. In the Thunderbird preferences window is in the first tab a button "edit configuration" or something. There you can enable to debug log. Just change the value of this attribute "calendar.debug.log" to "true".

    Can you post the error message of the error console. Maybe I know the problem and can give you a solution.

    Best regards,
    Sebastian

  9. #9
    Gertjan Guest

    Default

    I've set the calendar.debug.log to true in about:config. As a result, logging is enabled every time I open the OXt4TB preferences. This was not the case before, then I could set the logging with the same result as I will show below, but I had to enable it every time I opened the preferences. (I presume the value was not saved to about:config. Could it be a rights issue?)

    In total, I have five error in the error console. Two sets of two errors. The first one in a set says "Error, exeption detected", the second one is empty.

    The fifth error says: "Error: redeclaration of const dataBaseHelperObj
    Source File: chrome://oxcalendar-provider/content/DataBaseHelper.js
    Line: 33"

    This last line I cannot reproduce, the others show up every time I close the OXt4TB preferences.

    Next to the errors there are many messages in the console, reporting about the syncing process, but I cannot find any strange things in there. Is it possible to dump the output in the error console to a text file?

  10. #10
    Gertjan Guest

    Default

    A small update/side note.

    I tried my other desktop as well, which is running TB2. There I can sync the users, not the calendar. But in TB2 I can also select 'Personal Address Book" and "Collected Addresses" in the Contacts tab in the OXt4TB preferences. This is not possible in the TB3 config.

    (I also found a small translation bug. In the OXt4TB Calendar tab, under "Sync coming appointments" I can select "Next 6 Monate" instead of "Next 6 month". This bug is in 1.5.0 as well as in 1.5.5b4)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •