Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 3 of 3
  1. #1
    hostfactory.ch Guest

    Default cannot deploy axis2, ends with error

    dear forum,
    i receive an error by unpacking '/opt/open-xchange/bundles/com.openexchange.axis2/com.openexchange.axis2.jar':

    # java -jar /opt/open-xchange/bundles/com.openexchange.axis2/com.openexchange.axis2.jar
    Failed to load Main-Class manifest attribute from /opt/open-xchange/bundles/com.openexchange.axis2/com.openexchange.axis2.jar


    at the moment my service directory is empty and i cannot access functions per soap-method. (/opt/open-xchange/bundles/com.openexchange.axis2/services)

    what exactly do i need to do, to correctly set up axis2?

    best regards
    marco

  2. #2
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Just follow the instructions given in the SOAP overview documents:

    http://www.open-xchange.com/wiki/ind...age#Interfaces
    OXpedia.org - the answer to almost all questions.

  3. #3
    hostfactory.ch Guest

    Default

    hi,

    chapter 'installation and configuration':
    --------------------------
    In order to use the SOAP Interface of the Open-Xchange Admin Daemon, you need the Open-Xchange Server and the Axis2 bundle. The SOAP Interface is a service that must be deployed into the Axis2 Bundle.

    For more information about the Axis2 bundle, please refer to the Quick-OX-Axis2-Integration-Overview document, that ships with the Axis2 bundle.

    The default configuration of the Admin SOAP service expects the Admin Daemon to be accessible on localhost. To change this behaviour, the file /opt/open-xchange/etc/admindaemon/plugin/open-xchange-admin-soap.properties must changed accordingly. Just set RMI_HOSTNAME to something different.
    --------------------------

    we installed axis2-open-xchange package per commandline, but i cannot find a 'quick-ox-axis2-integration-overview document' within.

    furthermore i haven't open-xchange-admin-soap.properties file in plugin-folder.

    can you please assist me to correctly set up axis2?

    best regards
    marco

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •