Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Baris Guest

    Default Cannot get connection to config DB

    Hi,

    I'm novice on openXchange.

    I have to install OpenXchange on Debian Etch later but first of all i'm triying to use this manual with Lenny :

    http://www.open-xchange.com/wiki/ind...for_Debian_5.0

    I'm testing on Lenny with Sun'VirtualBox.

    I have some problem with OpenXchange configuration.

    Next we have to register the local server at the Open-Xchange configdb database:

    Code:
    $ /opt/open-xchange/sbin/registerserver -n oxserver -A oxadminmaster -P admin_master_password
    Before i have this:

    Code:
    $ /opt/open-xchange/sbin/oxinstaller --add-license=YOUR-OX-LICENSE-CODE \
    --servername=oxserver --configdb-pass=db_password \
    --master-pass=admin_master_password --ajp-bind-port=localhost
    and i use the --no-license like this --add-license=--no-license.

    For my problem, i have this answer:

    Code:
    server could not be registered: 
    Server response:
     com.openexchange.admin.rmi.exceptions.PoolException: DBP-0001 Category=5 Message=Cannot get connection to config DB. exceptionID=1389646557-6
    I dont understand. Even with g**gle.

    Same problems with following steps

    Or if i cannot register server then filestore and database, it is because of i have not license and i'm testing with a version for which i need OX-License.

    But how do works --no-license?

    Best Regards,

    Baris

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi Baris,

    this is not a license issue. I suspect that the configdb has not been created correctly - or the admindaemon cannot connect to the database with the configured database user. Please check the log files.

    Greetings

  3. #3
    Baris Guest

    Default Cannot get connection to config DB

    Hi Martin,


    Code:
    6 janv. 2010 23:28:28 com.openexchange.admin.storage.sqlStorage.OXAdminPoolDBPool getConnectionForConfigDB
    GRAVE: Error pickup configdb database write connection from pool!
    DBP-0001 Category=5 Message=Cannot get connection to config DB. exceptionID=1389646557-6
            at com.openexchange.database.internal.DBPoolingExceptionFactory.createException(DBPoolingExceptionFactory.java:76)
            at com.openexchange.database.internal.DBPoolingExceptionFactory.createException(DBPoolingExceptionFactory.java:62)
            at com.openexchange.exceptions.Exceptions.create(Exceptions.java:139)
            at com.openexchange.exceptions.Exceptions.create(Exceptions.java:159)
            at com.openexchange.database.DBPoolingExceptionCodes.create(DBPoolingExceptionCodes.java:198)
            at com.openexchange.database.internal.ConfigDatabaseServiceImpl.get(ConfigDatabaseServiceImpl.java:103)
            at com.openexchange.database.internal.ConfigDatabaseServiceImpl.getWritable(ConfigDatabaseServiceImpl.java:145)
            at com.openexchange.database.internal.DatabaseServiceImpl.getWritable(DatabaseServiceImpl.java:119)
            at com.openexchange.databaseold.Database.get(Database.java:103)
            at com.openexchange.admin.storage.sqlStorage.OXAdminPoolDBPool.getConnectionForConfigDB(OXAdminPoolDBPool.java:72)
            at com.openexchange.admin.tools.AdminCache.getConnectionForConfigDB(AdminCache.java:360)
            at 
    
            ...
    Yep, i think that this is the problem.

    Best solution: uninstall and install again?
    Maybe i need some softwares before install Open-Xchange no?

    Greetings

  4. #4
    Join Date
    Aug 2008
    Posts
    107

    Default

    isn't it the right way to use the oxinstaller like this:

    Code:
    /opt/open-xchange/sbin/oxinstaller --no-license --servername=oxserver \
    --configdb-pass=db_password --master-pass=admin_master_password \
    --ajp-bind-port=localhost
    so type "--no-license" instead of "--add-license=--no-license".

    For me it works that way
    Viele Gre
    Rene

    OS: Ubuntu Server amd64 12.4 LTS
    JRE: openjdk-7-jre, MySQL: 5.5, Apache 2.2, Dovecot 2.0.19
    OX-Server backend: OXSE latest
    OX-frontend: OXSE latest appsuite + ox6

  5. #5
    Baris Guest

    Default

    Yep,

    I delete all ( my lenny ) and re-install all.

    I think that some packages missed on my previous lenny and i did a mistake because i entered password for mysql-admin.

    But now i have another error:

    Code:
    debianlenny:/home/baris# /opt/open-xchange/sbin/registerserver -n oxserver -A oxadminmaster -P admin_master_password
    server could not be registered: 
    Server response:
     registerServer; nested exception is:
    	java.lang.ClassNotFoundException: com.openexchange.admin.rmi.dataobjects.Server
    What is that means?

  6. #6
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    please post the whole stacktrace from the admin logfile.

    Thanks

  7. #7
    Baris Guest

    Default

    this file ?

    /var/log/open-xchange# vim open-xchange-admin.log.0

  8. #8
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    yup, we only need the error which is thrown when executing the command.

  9. #9
    Baris Guest

    Default

    I have these problems more than one time:



    Code:
    12-jan-10 5:26:12  org.apache.jcs.auxiliary.lateral.socket.tcp.discovery.UDPDiscoveryReceiver waitForMessage
    SEVERE: Error receving multicast packet
    java.io.IOException: Appel systme interrompu 
       at gnu.java.net.PlainDatagramSocketImpl.receive(libgcj.so.90)
       at java.net.DatagramSocket.receive(libgcj.so.90)
       at org.apache.jcs.auxiliary.lateral.socket.tcp.discovery.UDPDiscoveryReceiver.waitForMessage(UDPDiscoveryReceiver.java:162)
       at org.apache.jcs.auxiliary.lateral.socket.tcp.discovery.UDPDiscoveryReceiver.run(UDPDiscoveryReceiver.java:185)
       at java.lang.Thread.run(libgcj.so.90)
    12-jan-10 5:26:12  org.apache.jcs.auxiliary.lateral.socket.tcp.discovery.UDPDiscoveryReceiver run
    WARNING: message is null

    Code:
    12-jan-10 5:25:49  com.openexchange.config.internal.ConfigurationImpl processPropertiesFile
    WARNING: Overwriting property .level from file '/opt/open-xchange/etc/admindaemon/file-logging.properties' with property from file '/opt/open-xchange/etc/admindaemon/logging.properties', overwriting value 'INFO' with value 'SEVERE'.
    12-jan-10 5:25:49  com.openexchange.config.internal.ConfigurationImpl processPropertiesFile
    WARNING: Overwriting property handlers from file '/opt/open-xchange/etc/admindaemon/file-logging.properties' with property from file '/opt/open-xchange/etc/admindaemon/logging.properties', overwriting value 'java.util.logging.FileHandler' with value 'java.util.logging.ConsoleHandler'.
    12-jan-10 5:25:49  com.openexchange.config.internal.ConfigurationImpl processPropertiesFile
    WARNING: Overwriting property org.apache.level from file '/opt/open-xchange/etc/admindaemon/file-logging.properties' with property from file '/opt/open-xchange/etc/admindaemon/logging.properties', overwriting value 'WARNING' with value 'SEVERE'.

  10. #10
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Okay,

    seems you're running gnu gcj which is incompatible to OX. Please check java -version.

    To change the primary java version, use update-alternatives --config java

    and select sun or ibm java

    Greetings

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •