Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 5 of 5

Thread: IMAP Auth

  1. #1
    Join Date
    Jun 2009
    Posts
    28

    Default IMAP Auth

    Ich habe ein funktionierendes OX 6.14.0 auf IMAP Auth umgestellt indem ich das passende Modul installiert habe.
    Anmeldung funktioniert soweit einwandfrei, solange die Benutzernamen keine Punkte enthalten ( also "Meier" geht, "T.Meier" geht nicht.

    Bei Benutzernamen mit "." erhalte ich immer ein "Benutzer konnte nicht angemeldet werden ...."
    Die Linux logs zeigen das OX beim Versuch den Benutzer über IMAP (bei mir Cyrus) zu identifizieren die Meldung bekommt

    Feb 14 21:58:56 ox saslauthd[5016]: pam_unix(imap:auth): check pass; user unknown
    Feb 14 21:58:56 ox saslauthd[5016]: pam_unix(imap:auth): authentication failure; logname= uid=0 euid=0 tty= ruser= rhost=
    Feb 14 21:58:58 ox saslauthd[5016]: DEBUG: auth_pam: pam_authenticate failed: User not known to the underlying authentication module


    Kann man da was machen ? Ich such mich dumm

  2. #2
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    When a dot does not work in an imap login, that's usually because the imap server is using a dot as hierarchy separator.
    OXpedia.org - the answer to almost all questions.

  3. #3
    Join Date
    Jun 2009
    Posts
    28

    Default

    In cyrus

    mailbox names separator is set to "/" instead of "."

    Any other idea ?

  4. #4
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    No. You need to check with tcpdump what happens on imap protocol level.
    OXpedia.org - the answer to almost all questions.

  5. #5
    Join Date
    Jun 2009
    Posts
    28

    Default

    Problem found.

    for a reason I don't understand and would best describe as Bug, the issue is based on OX User names with capital letters.

    Login of User "Test.Dummy" at OX fails if user is created within cyrus as "Test.Dummy".
    When I create the user as "test.dummy" at cyrus , all works fine.
    It seems that IMAP Auth only and always asks Linux for authentication of "test.dummy" even if User enters "Test.Dummy" in the OX login screen.
    I also have the problem with capital letters in Funabmol Outlook sync. The only workaround is to create all users within OX in non capital letters - then OX login with IMAP Auth and Funambol client work.


    So the problem are the capital letters not the "dots", can you please confirm if this is a Bug with IMAP auth ?

    (during my tests with OX I had only simply names like "test" or "123" as usernames. Now switched over to working environment with real users containing capital letters and dots in user names)
    Last edited by mybulk; 02-15-2010 at 06:46 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •