Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 3 123 LastLast
Results 1 to 10 of 21
  1. #1
    altariq Guest

    Default OX Database (IV.3.)

    Hello there,

    root@schmidt-mg:~# /opt/open-xchange/sbin/oxinstaller --oxdb-pass=mypass --admin-pass=mypass --maildomain mydomain.com
    initializing databaseERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
    done

    I followed all points in the Installhow to and had no errors before

  2. #2
    Ben Pahne Guest

    Default

    Quote Originally Posted by altariq View Post
    Hello there,

    root@schmidt-mg:~# /opt/open-xchange/sbin/oxinstaller --oxdb-pass=mypass --admin-pass=mypass --maildomain mydomain.com
    initializing databaseERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
    done

    I followed all points in the Installhow to and had no errors before
    followed this step? ->
    http://typo3.open-xchange.com/wiki/i...MySQL_database

  3. #3
    altariq Guest

    Default

    yes
    tried it 2 times

  4. #4
    Ben Pahne Guest

    Default

    Quote Originally Posted by altariq View Post
    yes
    tried it 2 times
    what happens when you just try to open mysql?

    Code:
    & mysql
    no host, no password and no username. just a ablank mysql.

  5. #5
    altariq Guest

    Default

    Another problem in the wiki is:

    IV.5.3
    hange /etc/pam.d/imap that it looks like:

    passwd=<pass>

    Password in "<>" or not? Sometimes there is <YOURPASSFROMINSTALL> somtimes YOURPASSFROMINSTALL

  6. #6
    altariq Guest

    Default

    Before i follow the steps in III.5 it works.
    Than i follow the steps with mysqladmin und grant all on ..
    Now & mysql brings the same output

    initializing databaseERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)

  7. #7
    Ben Pahne Guest

    Default

    then try to give root the access to mysql:

    http://dev.mysql.com/doc/refman/5.0/...rmissions.html

    btw: what system do you use?

  8. #8
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Quote Originally Posted by altariq View Post
    Before i follow the steps in III.5 it works.
    Than i follow the steps with mysqladmin und grant all on ..
    Now & mysql brings the same output

    initializing databaseERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
    What mysql Version are you using and what OS and Version?

    What does

    echo "select host,user from mysql.user;" |mysql

    and
    echo "select host,user from mysql.user;" |mysql -u openexchange -pyoursecret

    and

    mysql -V

    say?

  9. #9
    altariq Guest

    Default

    Its ubuntu 6.10 Server

    ill try it now

    openexchange@schmidt-mg:~$ mysql -V
    mysql Ver 14.12 Distrib 5.0.24a, for pc-linux-gnu (i486) using readline 5.1



    echo "select host,user from mysql.user;" |mysql
    ERROR 1045 (28000): Access denied for user 'openexchange'@'localhost' (using password: NO)


    @Ben

    i tried this:

    Alternatively, on any platform, you can set the new password using the mysql client(but this approach is less secure):

    1.

    Stop mysqld and restart it with the --skip-grant-tables --user=root options (Windows users omit the --user=root portion).
    2.

    Connect to the mysqld server with this command:

    shell> mysql -u root

    3.

    Issue the following statements in the mysql client:

    mysql> UPDATE mysql.user SET Password=PASSWORD('newpwd')
    -> WHERE User='root';
    mysql> FLUSH PRIVILEGES;

    Replace “newpwd” with the actual root password that you want to use.
    4.

    You should be able to connect using the new password.
    and got this:

    root@schmidt-mg:/home/openexchange# /etc/init.d/mysql stop
    * Stopping MySQL database server mysqld [ ok ]
    root@schmidt-mg:/home/openexchange# /etc/init.d/mysql start --skip-grant-tables --user=root
    * Starting MySQL database server mysqld [ ok ]
    * Checking for corrupt, not cleanly closed and upgrade needing tables.
    root@schmidt-mg:/home/openexchange# mysql -u root
    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
    root@schmidt-mg:/home/openexchange# mysql -u root -p
    Enter password:
    Welcome to the MySQL monitor. Commands end with ; or \g.
    Your MySQL connection id is 7 to server version: 5.0.24a-Debian_9ubuntu1-log

    Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

    mysql> UPDATE mysql.user SET Password=PASSWORD('mypass')
    -> WHERE User='root';
    Query OK, 1 row affected (0.00 sec)
    Rows matched: 2 Changed: 1 Warnings: 0

    mysql> FLUSH PRIVILEGES;
    Query OK, 0 rows affected (0.00 sec)

    mysql> Aborted
    root@schmidt-mg:/home/openexchange# mysql
    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)

    Last edited by altariq; 03-05-2007 at 05:54 PM.

  10. #10
    Join Date
    Feb 2007
    Location
    Olpe
    Posts
    199

    Default

    This is a bug in our documentation in wiki. I changed the documentation to correct this issue.

    The oxinstaller only works if mysql rootpassword is not set!

    So please first do an "mysqladmin password "" -p" Enter the password you set for mysql root to have the mysql root password unset.

    Then start oxinstaller again.

    Daniel
    Last edited by Daniel Halbe; 03-05-2007 at 06:41 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •