Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    Join Date
    Mar 2010
    Posts
    16

    Unhappy Fehler seit Update auf 6.16.0 Rev4

    Ich habe heute unter openSuse 11.2 die neuen Pakete 6.16.0 Rev4 eingespielt und bekomme jetzt bei allen Accounts folgende Fehlermeldung nachdem man sich einloggt:

    "Kein passender Ordner-Speicher für Baum-ID "0" und Ordner-ID "default0.INBOX". (FLD-0004, 2136811928-575)"

    oder Englisch

    No appropriate folder storage for tree identifier "0" and folder identifier "default2.INBOX". (FLD-0004, 2136811928-593)

    als Folge dessen ist der gesamte Benutzerbaum links nicht mehr zu sehen (nur noch der Name). Bis auf die Mails kann man aber auf alle Module wie Kalender, Infostore, etc. zugreifen wenn mann die Buttons links oben benutzt. Die Popups für neue Einträge funktionieren ebenfalls nicht aber ich nehme an, dass das eine das andere bedingt.

    Kann jemand etwas mit dieser Fehlermeldung anfangen oder kennt gar die Lösung?

    Vielen Dank im Vorraus für alle Antworten.

    Gruß Marco

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hallo Marco,

    sind tatsächlich alle Pakete auf dem Stand 6.16 und der Browsercache wurde geleert?

    Gruß

  3. #3
    Join Date
    Mar 2010
    Posts
    16

    Default

    Hallo Martin,

    ich habe alle installierten Pakete aktualisiert und der Fehler erscheint in jedem Browser. Allerdings gibt es ein paar neue Pakete die ich noch nicht installiert habe da es sie in der Version 6.14 noch nicht gab. So sind da diverse open-xchange-meta-xx Pakete dessen Funktion ich nicht kenne.
    Für mich sieht es wie ein Rechte-Problem aus, als sollte es irgendwo einen Ordner geben der nicht angelegt werden kann oder die falschen Rechte hat. In den Log-Dateien konnte ich allerdings nichts entdecken was darauf hinweist.

    Gruß Marco

  4. #4
    Join Date
    Mar 2010
    Posts
    16

    Default

    Ich habe jetzt folgende Einträge im Apache-Error-Log gefunden:

    [Tue Mar 16 14:58:16 2010] [error] [client 192.168.xxx.xxx] File does not exist: /srv/www/htdocs/ox6/plugins/folderstorage, referer: http://ox/ox6/ox.html
    [Tue Mar 16 14:58:17 2010] [error] [client 192.168.xxx.xxx] File does not exist: /srv/www/htdocs/ox6/plugins/com.openexchange.extras/lang, referer: http://ox/ox6/ox.html
    [Tue Mar 16 14:58:17 2010] [error] [client 192.168.xxx.xxx] File does not exist: /srv/www/htdocs/ox6/plugins/com.openexchange.upsell.generic/lang, referer: http://ox/ox6/ox.html
    [Tue Mar 16 14:58:18 2010] [error] [client 192.168.xxx.xxx] File does not exist: /srv/www/htdocs/ox6/plugins/com.openexchange.upsell.generic/lang, referer: http://ox/ox6/ox.html
    [Tue Mar 16 14:58:18 2010] [error] [client 192.168.xxx.xxx] File does not exist: /srv/www/htdocs/ox6/plugins/com.openexchange.extras/lang, referer: http://ox/ox6/ox.html

    Allerdings weis ich auch nicht woher "plugins/folderstorage" kommen sollte. Kann es sein das mir irgendwelche Pakete fehlen?

    Gruß Marco

  5. #5
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hallo Marco,

    die Fehler im Apache haben nichts mit dem Fehlverhalten zu tun. Kannst du vielleicht eine komplette Liste der installierten OX Pakete posten (rpm -qa | grep open-x)

    Hast du vielleicht open-xchange-folder-json installiert? Dann entferne es mal.

    Gruß
    Last edited by Martin Heiland; 03-16-2010 at 04:52 PM.

  6. #6
    Join Date
    Mar 2010
    Posts
    16

    Default

    Hallo Martin

    Quote Originally Posted by Martin Braun View Post
    Hast du vielleicht open-xchange-folder-json installiert? Dann entferne es mal.
    Ja hatte ich, habs deinstalliert aber kein Erfolg.

    Hier sind meine OX-Pakete:
    Code:
    ox:/opt/open-xchange/sbin # rpm -qa | grep open-x         
    open-xchange-admin-plugin-hosting-doc-6.16.0.0-4_6.2.noarch
    open-xchange-publish-6.16.0.0-4_4.1.noarch
    open-xchange-server-6.16.0.0-5_5.1.noarch         
    open-xchange-pop3-6.16.0.0-4_4.1.noarch
    open-xchange-admin-plugin-hosting-lib-6.16.0.0-4_4.1.noarch
    open-xchange-admin-plugin-hosting-6.16.0.0-4_4.1.noarch
    open-xchange-online-help-de-6.16.0.0-5_5.1.noarch
    open-xchange-gui-themes-default-6.16.0.0-4_6.1.noarch
    open-xchange-charset-6.16.0.0-4_4.1.noarch
    open-xchange-crypto-6.16.0.0-4_4.1.noarch
    open-xchange-management-6.16.0.0-4_4.1.noarch
    open-xchange-cache-6.16.0.0-4_4.1.noarch
    open-xchange-imap-6.16.0.0-4_4.1.noarch
    open-xchange-contactcollector-6.16.0.0-4_4.1.noarch
    open-xchange-spamhandler-default-6.16.0.0-4_4.1.noarch
    open-xchange-push-mailnotify-6.16.0.0-2_3.2.noarch
    open-xchange-publish-json-6.16.0.0-4_4.1.noarch
    open-xchange-admin-client-6.16.0.0-4_4.1.noarch
    open-xchange-admin-plugin-autocontextid-6.16.0.0-4_6.2.noarch
    open-xchange-online-help-fr-6.16.0.0-5_7.1.noarch
    open-xchange-upsell-generic-6.16.0.0-4_4.1.noarch
    open-xchange-gui-wizard-plugin-gui-6.16.0.0-4_4.1.noarch
    open-xchange-commons-logging-log4j-6.16.0.0-4_4.1.noarch
    open-xchange-i18n-6.16.0.0-4_4.1.noarch
    open-xchange-conversion-servlet-6.16.0.0-4_4.1.noarch
    open-xchange-resource-managerequest-6.16.0.0-4_4.1.noarch
    open-xchange-passwordchange-servlet-6.16.0.0-4_4.1.noarch
    open-xchange-audit-6.16.0.0-4_4.1.noarch
    open-xchange-themes-default-6.16.0.0-4_6.1.noarch
    open-xchange-contacts-ldap-6.16.0.0-4_4.1.noarch
    open-xchange-admin-plugin-contextrestore-6.16.0.0-4_4.1.noarch
    open-xchange-gui-mobile-1.0.0-25_25.1.noarch
    open-xchange-conversion-6.16.0.0-4_4.1.noarch
    open-xchange-conversion-engine-6.16.0.0-4_4.1.noarch
    open-xchange-push-6.16.0.0-4_4.1.noarch
    open-xchange-smtp-6.16.0.0-4_4.1.noarch
    open-xchange-calendar-6.16.0.0-4_4.1.noarch
    open-xchange-publish-basic-6.16.0.0-4_4.1.noarch
    open-xchange-subscribe-microformats-6.16.0.0-4_4.1.noarch
    open-xchange-admin-soap-6.16.0.0-4_4.1.noarch
    open-xchange-gui-6.16.0.0-4_4.1.noarch
    open-xchange-xml-6.16.0.0-4_4.1.noarch
    open-xchange-admin-doc-6.16.0.0-4_4.1.noarch
    open-xchange-meta-6.16.0.0-4_5.1.noarch
    open-xchange-lang-6.16.0.0-4_4.1.noarch
    open-xchange-voipnow-gui-6.16.0.0-4_6.1.noarch
    open-xchange-messaging-6.16.0.0-4_6.1.noarch
    open-xchange-threadpool-6.16.0.0-4_4.1.noarch
    open-xchange-control-6.16.0.0-4_4.1.noarch
    open-xchange-unifiedinbox-6.16.0.0-4_4.1.noarch
    open-xchange-push-malpoll-6.16.0.0-4_4.1.noarch
    open-xchange-voipnow-json-6.16.0.0-4_6.2.noarch
    open-xchange-publish-infostore-online-6.16.0.0-4_4.1.noarch
    open-xchange-subscribe-crawler-offering-6.16.0.0-4_4.1.noarch
    open-xchange-admin-plugin-autocontextid-client-6.16.0.0-4_6.2.noarch
    open-xchange-gui-ie6-compat-6.8.1-47_47.1.noarch
    open-xchange-xerces-sun-6.16.0.0-4_4.1.noarch
    open-xchange-sql-6.16.0.0-4_4.1.noarch
    open-xchange-configread-6.16.0.0-4_4.1.noarch
    open-xchange-templating-6.16.0.0-4_4.1.noarch
    open-xchange-settings-extensions-6.16.0.0-4_4.1.noarch
    open-xchange-group-managerequest-6.16.0.0-4_4.1.noarch
    open-xchange-passwordchange-database-6.16.0.0-4_4.1.noarch
    open-xchange-authentication-database-6.16.0.0-4_4.1.noarch
    open-xchange-subscribe-6.16.0.0-4_4.1.noarch
    open-xchange-admin-6.16.0.0-4_4.1.noarch
    open-xchange-report-client-6.16.0.0-4_4.1.noarch
    open-xchange-jcharset-1.3.0-23_52.1.noarch
    open-xchange-common-6.16.0.0-4_4.1.noarch
    open-xchange-configjump-generic-gui-6.16.0.0-4_4.1.noarch
    open-xchange-dataretention-6.16.0.0-4_4.1.noarch
    open-xchange-dataretention-csv-6.16.0.0-4_4.1.noarch
    open-xchange-sessiond-6.16.0.0-4_4.1.noarch
    open-xchange-data-conversion-ical4j-6.16.0.0-4_4.1.noarch
    open-xchange-calendar-printing-6.16.0.0-4_4.1.noarch
    open-xchange-push-udp-6.16.0.0-4_4.1.noarch
    open-xchange-easylogin-6.16.0.0-4_6.2.noarch
    open-xchange-publish-microformats-6.16.0.0-4_4.1.noarch
    open-xchange-admin-plugin-hosting-client-6.16.0.0-4_4.1.noarch
    open-xchange-online-help-en-6.16.0.0-5_7.1.noarch
    open-xchange-global-6.16.0.0-4_4.1.noarch
    open-xchange-log4j-6.16.0.0-4_4.1.noarch
    open-xchange-meta-gui-6.16.0.0-4_5.1.noarch
    open-xchange-monitoring-6.16.0.0-4_4.1.noarch
    open-xchange-user-json-6.16.0.0-4_4.1.noarch
    open-xchange-admin-lib-6.16.0.0-4_4.1.noarch
    open-xchange-genconf-mysql-6.16.0.0-4_4.1.noarch
    open-xchange-gui-wizard-plugin-6.16.0.0-4_4.1.noarch
    open-xchange-6.16.0.0-5_5.1.noarch
    open-xchange-subscribe-crawler-6.16.0.0-4_4.1.noarch
    open-xchange-meta-admin-6.16.0.0-4_5.1.noarch
    open-xchange-activation-1.1.1-23_23.1.noarch
    open-xchange-genconf-6.16.0.0-4_4.1.noarch
    open-xchange-configjump-generic-6.16.0.0-4_4.1.noarch
    open-xchange-passwordchange-script-6.16.0.0-4_5.1.noarch
    open-xchange-axis2-6.16.0.0-4_4.1.noarch
    open-xchange-subscribe-json-6.16.0.0-4_4.1.noarch
    Gruß Marco
    Last edited by marcove; 03-17-2010 at 02:19 AM.

  7. #7
    Join Date
    Mar 2010
    Posts
    16

    Default

    Kann es sich um einen Datenbankfehler handeln? Wie wird eingentlich das DB-update bei einer neuen Version angeschubst? Beim ersten login kam nämlich die Fehlermeldung "Datenbank wird aktualisiert". Vielleicht ist sie nicht ganz fertig geworden?

    Mutmaßungen über Mutmaßungen, aber ich kann in den logs keine Fehler entdecken
    Last edited by marcove; 03-17-2010 at 09:42 AM.

  8. #8
    Thorben Betten Guest

    Default

    Bitte das Paket "com.openexchange.folder.json" komplett entfernen uind neu starten. Vielleicht hat das was mit der Servlet-Ersetzung nicht funktioniert.

  9. #9
    Join Date
    Mar 2010
    Posts
    16

    Thumbs up

    Quote Originally Posted by Thorben Betten View Post
    Bitte das Paket "com.openexchange.folder.json" komplett entfernen uind neu starten. Vielleicht hat das was mit der Servlet-Ersetzung nicht funktioniert.
    Das war's

    Deinstallation von "com.openexchange.folder.json" und Neustart des Rechners. Ich hatte es vorher nur deinstalliert und dann die open-xchange-admin- und -groupware-Server neu gestartet.

    Vielen Dank, jetzt läuft wieder alles

    Gruß Marco

  10. #10
    Join Date
    Mar 2010
    Posts
    16

    Default Fehler seit Update auf 6.20.0 REV 3

    Und da war er wieder -> Mein Fehler:

    Code:
     Kein passender Ordner-Speicher für Baum-ID "0" und Ordner-ID "default0.INBOX". (FLD-1004, -1044123647-2059)
    Beim Update auf 6.18 war es ausreichend das ich folders-json deinstalliere. Diesmal funktioniert das aber nicht, da diverse Abhängigkeiten durch die Deinstallation verletzt werden und selbst wenn ich diese ignoriere bekomme ich neue Fehlermeldungen (503 apache). Bin ich etwa der einzigste der JSON bisher nicht verwendet hat? So wie es für mich aussieht scheint folders json ja auch nur daran zu scheitern das es nicht weiß wo es den Verzeichnisbaum erstellen soll. Aber ich weiß auch nicht an welcher Einstellungsdatei ich drehen muß damit es funktioniert.

    Freue mich über jede Hilfe

    Gruß Marco

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •