Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 5 of 5
  1. #1
    tcrass Guest

    Question Debian (lenny) Install Problem - Database Access Error

    I can't seem to get it to set up the database connections right. The database and open-xchange are on the same computer and the database being used is an existing database with production information already in it. It's throwing the error at the end and I can't seem to get rid of it. Here's what I hope is the relevant information:

    Debian 5.0.3 Lenny
    Existing MySQL install
    Existing Apache2 install

    java -version
    java version "1.5.0_17"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_17-b04)
    Java HotSpot(TM) Server VM (build 1.5.0_17-b04, mixed mode)

    Installed open-xchange by apt-get install open-xchange-meta-singleserver

    Command Run for initconfigdb:
    ./initconfigdb --configdb-user=dbuser --configdb-pass=password --configdb-host=localhost --configdb-dbname=domain_oxchange
    Output for Command:
    initializing configdb from scratch... done
    Verified that it "did" create the tables in the database specified.
    I also verified connectivity to the database via command line using the user/pass combination specified in these commands.

    Command Run for oxinstaller
    ./oxinstaller --servername=oxchange --imapserver=mail.domain.com --smtpserver=localhost --configdb-user=dbuser --configdb-pass=password --configdb-dbname=domain_oxchange --master-pass=password --no-license
    Output for Command:
    setting up groupware configuration /opt/open-xchange/etc/groupware
    ....
    skipping configuration of URL in /opt/open-xchange/etc/groupware/configjump.properties
    .............................................
    groupware daemon must now be restarted if already running
    setting up admin daemon configuration /opt/open-xchange/etc/admindaemon
    ......................
    *** RMI authentication is enabled
    using oxadminmaster as master account
    admin daemon must now be restarted if already running
    I started the admin daemon service for it with /etc/init.d/open-xchange-admin start

    Command to registerserver:
    ./registerserver -n oxchange -A oxadminmaster -P password
    Output for Command:
    server could not be registered:
    Server response:
    com.openexchange.admin.rmi.exceptions.PoolExceptio n: DBP-0001 Category=5 Message=Cannot get connection to config DB. exceptionID=45963687-12
    Var Message Log (a link since it's long):
    http://www.thinkingimpared.com/oxlog.txt


    I guess the question is... why am I getting db connection errors when I've specified the information, verified java versioning, verified the db that I specified is active and accessible and even has tables populated from the first part of the step. However, at no point in this does the db_pool table contain any information. I don't know if that's important or not at this point, it might be too early in the install process for that to matter.

    Any assistance will be greatly appreciated.
    Last edited by tcrass; 03-19-2010 at 07:31 AM. Reason: Added info.

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Sorry i cannot access the log file, HTTP403.

  3. #3
    tcrass Guest

    Default

    Quote Originally Posted by Martin Braun View Post
    Sorry i cannot access the log file, HTTP403.
    Sorry about that, silly permissions issue on my part. Access has been resolved and the log file should be viewable now. Thanks!

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    the issue seems to be network related "Caused by: java.net.ConnectException: Connection refused". Please check if mysql listens on localhost and localhost is reachable. This topic popped up in the past already, mostly because /etc/hosts was broken.

    Greetings

  5. #5
    tcrass Guest

    Default

    Quote Originally Posted by Martin Braun View Post
    Hi,

    the issue seems to be network related "Caused by: java.net.ConnectException: Connection refused". Please check if mysql listens on localhost and localhost is reachable. This topic popped up in the past already, mostly because /etc/hosts was broken.

    Greetings
    Thanks for the pointer. I thought I had already verified this, apparently I didn't. The cause was that my mysql system was "only" listening on an external address. I had to change my bind-address line to be 0.0.0.0 for it to listen on both internal and external addresses.

    bind-address = 0.0.0.0

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •