Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 4 of 4
  1. #1
    Join Date
    Feb 2010
    Location
    Vienna
    Posts
    44

    Unhappy IMAP troubles after upgrade to 6.16rev4

    Hello,

    I upgraded a working 6.14rev6 to 6.16rev4 from recent OpenSuse repository.
    While everything went very smoothly, there are some strange glitches with the IMAP functionality:

    1.) Authentification works, I can even view the folders & messages but clicking on Email icon (next to home icon) will results in this message box:

    The E-Mail module is not available
    Unable to establish a connection to the E-Mail server. Possible reasons: the mail server is (temporarily) down or there are network connection problems. To prevent further errors the module has been disabled. Please contact your administrator.

    But afterwards I can still browse/read emails. Interesting is that there is no relevant log message and I cannot see any IMAP trafic using tcpdump while error message appears.

    2.) Selecting "Subscribe folder" seems to hang up the webmail (whole window remains dark/busy)

    3.) The IMAP folders are not properly ordered anymore as they were before: now Inbox,Trash,. & other special folders are not on the top but sorted alphabetically among all other folders.


    Thanks in advance for your any help or hints where to look further, you did a great job with OX6 !

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    please uninstall the open-xchange-folder-json package, if installed. Then restart Open-Xchange Server. This package is not intended for productive usage (yet).

    Greetings

  3. #3
    Join Date
    Feb 2010
    Location
    Vienna
    Posts
    44

    Thumbs up All Issues Solved !

    Hi Martin,

    Thanks a lot ! Removing that package solves all 3 imap issues listed above.

    Unfortunately, I misinterpreted the postings in other recent threads and first tried to deinstall and reinstall this package - which did not help. Did not expect this package is not needed at all.

    Is there some place where to look for a short description of each package including some info whether optional/nonoptional production/beta etc. ? I mean there are pretty much small packages at the moment and I could tell (aus dem Bauch her...) just for about 50% of these what they are really used for.

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    you can find an overview at the wiki:
    http://oxpedia.org/wiki/index.php?ti...lugin_Overview

    and the admin guide:
    http://software.open-xchange.com/OX6...nistration.pdf

    All packages have a short description
    dpkg --info <package>.deb

    open-xchange-folder-json is an optional and experimental package. It's not part of our installation guides nor needed by any other package or installed as a dependency. With 6.14 it did nothing at all, with 6.16 it replaces some functionality which lead to this issue.

    Greetings

    Greetings

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •