Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 6 of 6
  1. #1
    Join Date
    Oct 2007
    Location
    Germany, Essen
    Posts
    171

    Question Context Admin <> Mailbox

    Hi,

    ich kann für den Context Admin keine Mailbox verbinden obwohl diese existiert?

    Wenn dieses nicht gwollt ist würde ich gerne wissen warum, bzw. wie es geht oder was ich machen muss damit auch hier eine Mailbox verwendet werden kann.

    ################
    Hi,

    i couldn´t connect a mailbox to Context Admin, but this exist why?

    If this is not wanted, I would like to know why, or how to do it or what I must do so a mail box can be used.

    thx

    outlow

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hallo,

    das funktioniert, jedoch muss es in der Konfiguration aktiviert werden:

    /opt/open-xchange/etc/groupware/mail.properties
    Code:
    # Define whether a context admin is allowed to login to mail system or not.
    # Note that a mail account is supposed to exist if set to true; if not an
    # authentication error will occur.
    com.openexchange.mail.adminMailLoginEnabled=true
    Gruß

  3. #3
    Join Date
    Oct 2007
    Location
    Germany, Essen
    Posts
    171

    Default

    Hi Martin,

    muss ich ebenfalls noch etwas in der Config ändern damit Sieve für den Admin Account richtig funktioniert?

    Aktuell wird versucht auf den Sieve Baum so zuzugreifen

    WARNING: sieve script /var/spool/sieve/domain/a/xxxx.de/a/administrator/defaultbc doesn't exist: No such file or directory

    für den Administrator Account wird dieser aber nur so erstellt:

    /var/spool/sieve/domain/a/xxxx.de/global/defaultbc

    was natürlich sichtlich nicht wirklich zusammen passt.

    Für jede Hilfe wie immer dankbar,

    MfG

    outlow

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hallo,

    das scheint eine Sache vom IMAP Server zu sein, die OX nutzt managesieve um die Skripte per Netzwerk hochzuladen oder anzusehen. An der SIEVE Struktur auf dem Speichermedium selbst, ändern wir nichts.

    Gruß

  5. #5
    Join Date
    Oct 2007
    Location
    Germany, Essen
    Posts
    171

    Default

    Hi Martin,

    warum dies eine Sache des IMAP Server sein soll ist mir nicht ganz klar.

    Bei allen durch OX angelegten Benutzern, wurde unter cyrus eine Mailbox erstellt. Nach dem ersten Login wurde jeweils eine erste Spam Regel (Sieve) eingetragen.

    Der Baum bei Sieve sieht dann wie folgt aus:

    /var/spool/sieve/domain/a/xxxx.de/a/username/defaultbc

    einzig die jeweiligen ersten Benutzer(OX Admins) greifen bei der erstellung von Regeln auf eine andre Struktur zu

    /var/spool/sieve/domain/a/xxxx.de/global/defaultbc

    Wenn jetzt allerdings eine E-Mail zugestellt wird und per Sieve sortiert werden soll kommt es eben zu dem Fehler da jetzt unter diesem Baum

    /var/spool/sieve/domain/a/xxxx.de/a/username/defaultbc

    versucht wird das Script zu finden.

    Da sich Sieve hier ja verhält wie bei allen anderen usern gehe ich nicht von einer Fehlerhaften Config des IMAP aus.

    Bislang finde ich sieht es eher danach aus das beim anlegen eines User der Gleichzeitig OXAdmin ist andre Einstellungen benutzt werden als bei einem normalen User.

    Ich würde mich freuen wenn wir der Ursache vielleicht zusammen auf die Schliche kommen.

    Sollten hierfür weiter Infos notwendig sein so liefere ich diese gerne,

    MfG

    outlow

  6. #6
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hallo,

    vielleicht ist es besser, wenn du die entsprechenden Informationen in einen Bugreport schreibst - dann können wir zusammen mit den entsprechenden Entwicklern dabei schauen.

    Gruß

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •