Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 9 of 9
  1. #1
    jonny12 Guest

    Default Mobile Gui Community Edition

    Hi,
    I have installed OX on OpenSues 11.2 via the repositoiry. There you can select the mobile gui. But if I try to connect I get :

    * @author Stefan Preuss * */ session_start(); global $username, $passwd, $device, $available_modules, $module, $view, $webkit_powered_devices; include_once("config.php"); include_once("api/oxapi.php"); include_once("api/misc.php"); include_once("localization.php"); // for i18n // checking device // @todo: this should go into a temp config file which can be modified by users without the need // to modify this file!! $device = "default"; foreach ($webkit_powered_devices as $dev) { if (eregi($dev,$_SERVER['HTTP_USER_AGENT'])){ $device = "iphone"; break; } } //if (eregi('iphone',$_SERVER['HTTP_USER_AGENT']) || eregi('ipod',$_SERVER['HTTP_USER_AGENT'])) { // seems like an iphone or ipod // $device = "iphone"; //} // check login and try to authentificate user if ($_POST['cmd'] == "do_login" || $_GET['cmd'] == "do_login") { checkLogin($ox_server, $use_ssl); } include "device/".$device."/index.tmpl.php"; ?>


    I also don't find anything about how to configure it.

    Is it possible to use it with the community edition?
    If yes, how?

    Thank You

    Thomas Schneider

  2. #2
    jonny12 Guest

    Default

    Hallo nochmal,
    hat noch niemand die Mobile Gui in Betrieb?
    Gruß
    Thomas Schneider

  3. #3
    Join Date
    Mar 2010
    Posts
    22

    Default

    Hi Jonny12,

    I think you must set the following Setting in the php.ini to "On".

    short_open_tag = On (The standard of this setting is "Off").

    Best wishes
    moah

  4. #4
    jonny12 Guest

    Default It worked

    Thank you, that was the right tip

  5. #5
    jonny12 Guest

    Default but now I get this

    Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2,0/DST' instead in /srv/www/htdocs/ox6-mobile/api/oxapi.php on line 175

    Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2,0/DST' instead in /srv/www/htdocs/ox6-mobile/api/oxapi.php on line 175

    Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2,0/DST' instead in /srv/www/htdocs/ox6-mobile/api/oxapi.php on line 175

    Warning: mktime() [function.mktime]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2,0/DST' instead in /srv/www/htdocs/ox6-mobile/api/oxapi.php on line 175

    Fatal error: Uncaught exception 'Exception' with message 'DateTime::__construct() [<a href='datetime.--construct'>datetime.--construct</a>]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2,0/DST' instead' in /srv/www/htdocs/ox6-mobile/api/oxapi.php:589 Stack trace: #0 /srv/www/htdocs/ox6-mobile/api/oxapi.php(589): DateTime->__construct() #1 /srv/www/htdocs/ox6-mobile/device/default/calendar/list.php(49): oXGetDisplayDate(Array, 1273687200000, 'D d.m.Y') #2 /srv/www/htdocs/ox6-mobile/device/default/index.tmpl.php(42): include('/srv/www/htdocs...') #3 /srv/www/htdocs/ox6-mobile/index.php(49): include('/srv/www/htdocs...') #4 {main} thrown in /srv/www/htdocs/ox6-mobile/api/oxapi.php on line 589

  6. #6
    Join Date
    Mar 2010
    Posts
    22

    Default

    Hi jonny12,

    set the following variable in your php.ini to your timezone:

    date.timezone = "America/Anchorage"

    A list of supported timezones is here:
    http://nl3.php.net/manual/en/timezones.php


    Best wishes
    moah

  7. #7
    jonny12 Guest

    Default

    I changed the date.timezone to Europe/Berlin but no change

    ???

  8. #8
    Join Date
    Mar 2010
    Posts
    22

    Default

    Hi,

    you have restarted apache ?

    Best wishes
    moah

  9. #9
    jonny12 Guest

    Default

    Yes, several times and the whole computer.
    Regards
    Thomas

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •