Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 5 of 5
  1. #1
    Join Date
    Apr 2010
    Posts
    13

    Default Open-Xchange stürzt alle 2 Stunden ab

    Hallo,

    wir haben das Problem, dass Open-XChange sich alle 2 Stunden aufhängt.
    Der Benutzer bekommt den Fehler 503. Irgendwie scheint die Kommunikation zwischen dem Apache und Open-XChange gestört zu sein. Nach einem Neustart des Groupware-Daemons funktioniert die Sache wieder für ca. 2 Stunden. Im Open-Xchange-Log ist kein Fehler feststellbar. Lediglich in der 'error_log' vom Apache ist zu sehen, dass der AJP-Proxy angeblich ein Problem mit dem Connect hat (siehe Auszug). Per Telnet funktioniert der Connect auf den Port 8009 auch nach dem Absturz von Open-Xchange.

    Hier ein Auszug aus der error_log vom Apache:
    [Wed May 12 11:38:41 2010] [error] (111)Connection refused: proxy: AJP: attempt to connect to 127.0.0.1:8009 (127.0.0.1) failed
    [Wed May 12 11:38:41 2010] [error] ap_proxy_connect_backend disabling worker for (127.0.0.1)
    [Wed May 12 11:38:41 2010] [error] proxy: AJP: failed to make connection to backend: 127.0.0.1
    [Wed May 12 11:38:43 2010] [error] proxy: AJP: disabled connection for (127.0.0.1)
    [Wed May 12 11:38:45 2010] [error] (111)Connection refused: proxy: AJP: attempt to connect to 127.0.0.1:8009 (127.0.0.1) failed
    [Wed May 12 11:38:45 2010] [error] ap_proxy_connect_backend disabling worker for (127.0.0.1)
    [Wed May 12 11:38:45 2010] [error] proxy: AJP: failed to make connection to backend: 127.0.0.1
    [Wed May 12 11:38:46 2010] [error] proxy: AJP: disabled connection for (127.0.0.1)
    [Wed May 12 11:38:46 2010] [error] proxy: AJP: disabled connection for (127.0.0.1)
    [Wed May 12 11:38:46 2010] [error] proxy: AJP: disabled connection for (127.0.0.1)
    [Wed May 12 11:38:46 2010] [error] proxy: AJP: disabled connection for (127.0.0.1)
    [Wed May 12 11:38:46 2010] [error] proxy: AJP: disabled connection for (127.0.0.1)
    [Wed May 12 11:38:46 2010] [error] proxy: AJP: disabled connection for (127.0.0.1)
    [Wed May 12 11:38:47 2010] [error] proxy: AJP: disabled connection for (127.0.0.1)
    [Wed May 12 11:38:49 2010] [error] proxy: AJP: disabled connection for (127.0.0.1)
    [Wed May 12 11:38:56 2010] [error] (111)Connection refused: proxy: AJP: attempt to connect to 127.0.0.1:8009 (127.0.0.1) failed
    [Wed May 12 11:38:56 2010] [error] ap_proxy_connect_backend disabling worker for (127.0.0.1)
    [Wed May 12 11:38:56 2010] [error] proxy: AJP: failed to make connection to backend: 127.0.0.1
    [Wed May 12 11:39:01 2010] [error] proxy: AJP: disabled connection for (127.0.0.1)


    Folgende Konfiguration ist bei uns im Einsatz:
    - openSUSE 11.2
    - Apache 2.2.15-13.1
    - java-1_6_0-openjdk (Version 1.6.0.0_b17-2.1.1)
    - open-Xchange 6.16.1 Rev. 3

    Hat jemand einen Lösungsansatz? Bin für jede Hilfe dankbar.

    Gruß
    Last edited by VG-Kirchberg; 05-12-2010 at 09:37 PM.

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hallo,

    OpenJDK wird nicht unterstützt, bitte nutzen Sie SUN oder IBM Java 1.5 oder 1.6. Die Apache logfiles sagen lediglich, dass keine Kommunikation mit der OX mehr möglich ist, vermutlich weil sie nicht mehr antwortet. Nähere Informationen sollten sich im OX logfile finden lassen.

    Gruß

  3. #3
    Join Date
    Apr 2010
    Posts
    13

    Default

    Hallo Martin,

    Danke für die schnelle Antwort.

    Habe jetzt SUN Java 1.6.0_20 installiert und openJDK (wurde wohl automatisch mitinstalliert) deinstalliert.

    Hoffe, dass es jetzt funktioniert.

    Im Log von Open-Xchange ist definitiv nicht zu sehen warum er aussteigt.

    Gruß

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hallo,

    bitte schau auch, dass Sun Java die Standard-VM ist, ein "java -version" sollte nun Sun Java zeigen statt OpenJDK. Viel Glück!

  5. #5
    Join Date
    Apr 2010
    Posts
    13

    Default

    Hallo,

    das hatte ich bereits gleich nach der Installation geprüft. Standard-VM ist SUN.
    Bis jetzt läuft der OX-Server durch.

    Gruß

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •