Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1
    MisterM74 Guest

    Question error 404 /ajax/login

    Hello, I have a problem when I log myself out there always this error:

    error 404 /ajax/login
    Does someone already had this error?

    Thank you for your help


  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    it seems your apache is not configured correctly. Servlet entries for proxy_ajp are missing. Please check with the installation guide again.

    Greetings

  3. #3
    MisterM74 Guest

    Unhappy The config is active

    Hi, the config is active vis--vis the howto presented here:

    http://oxpedia.org/index.php?title=O...for_Debian_5.0

    is through this too :

    a2enmod proxy proxy_ajp expires deflate headers
    vim /etc/apache2/conf.d/proxy_ajp.conf

    <Proxy *>
    Order deny,allow
    allow from all
    </Proxy>

    ProxyPass /axis2 ajp://127.0.0.1:8009/axis2 smax=0 ttl=60 retry=5
    ProxyPass /ajax ajp://127.0.0.1:8009/ajax smax=0 ttl=60 retry=5
    ProxyPass /servlet ajp://127.0.0.1:8009/servlet smax=0 ttl=60 retry=5
    ProxyPass /infostore ajp://127.0.0.1:8009/infostore smax=0 ttl=60 retry=5
    ProxyPass /publications ajp://127.0.0.1:8009/publications smax=0 ttl=60 retry=5
    $ vim /etc/apache2/sites-enabled/000-default

    <VirtualHost *:80>
    ServerAdmin webmaster@localhost

    DocumentRoot /var/www/

    <Directory /var/www/>
    AllowOverride None
    Order allow,deny
    allow from all
    RedirectMatch ^/$ /ox6/
    </Directory>

    ExpiresActive On
    ExpiresByType image/gif "access plus 23 hours"
    ExpiresByType image/png "access plus 23 hours"
    ExpiresByType image/jpg "access plus 23 hours"
    ExpiresByType image/jpeg "access plus 23 hours"
    ExpiresByType text/javascript "access plus 23 hours"
    ExpiresByType text/css "access plus 23 hours"
    ExpiresByType text/html "access plus 23 hours"
    ExpiresByType application/x-javascript "access plus 23 hours"
    <Files ~ "\.(js|css|gif|jpe?g|png)$">
    Header append Cache-Control "public"
    </Files>

    DeflateFilterNote ratio
    AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/x-js application/x-javascript application/javascript
    BrowserMatch ^Mozilla/4 gzip-only-text/html
    BrowserMatch ^Mozilla/4\.0[678] no-gzip
    BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html
    Header append Vary User-Agent env=!dont-vary
    </VirtualHost>
    There is nothing else to add, except this config?

    Thank you for your help

    MM

    PS :

    a2enmod proxy proxy_ajp expires deflate headers
    Module proxy already enabled
    Considering dependency proxy for proxy_ajp:
    Module proxy already enabled
    Module proxy_ajp already enabled
    Module expires already enabled
    Module deflate already enabled
    Module headers already enabled
    Last edited by MisterM74; 07-07-2010 at 10:40 AM.

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Mhh, please post the apache error/access log when trying to login. I guess the webserver has already been restarted after applying the config?

    Greetings

  5. #5
    MisterM74 Guest

    Question Error Access log

    Hello, sorry for the delayed response, here is what I see in the logs, you answer this:

    xx.xxxxx.xx||||392||||XX.XXX.XXX.X - - [19/Jul/2010:12:09:26 +0200] "POST /ajax/login?action=login&client=com.openexchange.ox6.gui .dhtml&version=6.16.1%20Rev3&authId=447a6405-6e51-469c-a1b2-d76afccb6bdb HTTP/1.1" 404 392 "http://xx.xxxxx.xx/ox.html" "Mozilla/5.0 (Windows; U; Windows NT 6.1; fr; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6"
    ox.axiome.be||||396||||81.245.120.6 - - [19/Jul/2010:12:09:26 +0200] "POST /newInfoItemHidden.html HTTP/1.1" 200 396 "http://xx.xxxxx.xx/ox.html" "Mozilla/5.0 (Windows; U; Windows NT 6.1; fr; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6"
    Thank you for help ...

    MM

  6. #6
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Well, the path /ajax does not seem to exist, can you manually check to access that? It should return something like:

    Code:
    http://192.168.32.154/ajax/
    
    No servlet bound to path/alias: /ajax/
    If it returns something like:
    Code:
    Not Found
    The requested URL /ajax/ was not found on this server.
    your apache configuration is incorrect or not applied correctly. Try to add the stuff from proxy_ajp.conf to the sites-enabled where you've configured all the other things. Perhaps your apache2 does not include configuration from conf.d?

    Greetings
    Last edited by Martin Heiland; 07-19-2010 at 12:08 PM.

  7. #7
    MisterM74 Guest

    Question So I have the same error

    When I do the same steps as you, I have a 404, when I add the IP address of the directory server is ajax.

    HTTP Status 404 - /ajax

    type Status report

    message /ajax

    description The requested resource (/ajax) is not available.
    Apache Tomcat/6.0.16
    If you talk proxy_ajp.conf file, it is this well in:

    etc/apache2/conf.d/proxy_ajp.conf
    For this, do you, I did what, because I do not understand your line:

    Try to add the stuff from proxy_ajp.conf to the sites-enabled WHERE you've configured all the Other Things
    Add the domain instead of 127.0.0.1 or something?

    Thank you for help ...

    MM

  8. #8
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    It seems you're running Tomcat on the same machine. Is there any good use for this? OX and Tomcat use the same TCP Ports so you either have to shutdown one of them or configure different ports. OX6 does not require Tomcat to work.

    Greetings

  9. #9
    MisterM74 Guest

    Question It is possible that this is what the port?

    Hello again Martin, is that Funambol, the mesa will all this mess?

    When I make this:

    ps aux | grep tomcat
    I have this as an answer

    ps aux | grep tomcat
    root 9110 0.0 0.0 3672 692 pts/0 R+ 13:27 0:00 grep tomcat
    root 25994 0.1 1.7 765720 52984 ? Sl Jul01 39:29 /opt/Funambol/tools/jre-1.5.0/jre/bin/java -Xmx512M -Dfunambol.debug=false -Dfunambol.home=/opt/Funambol -Dfile.encoding=UTF-8 -Djava.library.path=/opt/Funambol/ds-server/lib/linux -Djavax.net.ssl.trustStore=/opt/Funambol/ds-server/lib/security/cacerts -Dcom.sun.management.jmxremote -Dcom.sun.management.jmxremote.port=8101 -Dcom.sun.management.jmxremote.ssl=false -Dcom.sun.management.jmxremote.authenticate=false -Djava.net.preferIPv4Stack=true -Djava.awt.headless=true -Djava.util.logging.manager=org.apache.juli.ClassLo aderLogManager -Djava.util.logging.config.file=/opt/Funambol/tools/tomcat/conf/logging.properties -Djava.endorsed.dirs=/opt/Funambol/tools/tomcat/endorsed -classpath :/opt/Funambol/tools/tomcat/bin/bootstrap.jar -Dcatalina.base=/opt/Funambol/tools/tomcat -Dcatalina.home=/opt/Funambol/tools/tomcat -Djava.io.tmpdir=/opt/Funambol/tools/tomcat/temp org.apache.catalina.startup.Bootstrap start
    Is this possible?

    Thank you Martin, I would be in error

    It is possible that this is what the port?

    MM

    MM

  10. #10
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Well, if you need to run funambol, you can change the port of the OX servlet container.
    Code:
    /opt/open-xchange/etc/groupware/ajp.properties
    [...]
    AJP_PORT=8010
    
    /etc/apache2/conf.d/proxy_ajp.conf
    [...]
    ProxyPass /axis2 ajp://127.0.0.1:8010/axis2 smax=0 ttl=60 retry=5
    ProxyPass /ajax ajp://127.0.0.1:8010/ajax smax=0 ttl=60 retry=5
    ProxyPass /servlet ajp://127.0.0.1:8010/servlet smax=0 ttl=60 retry=5
    ProxyPass /infostore ajp://127.0.0.1:8010/infostore smax=0 ttl=60 retry=5
    ProxyPass /publications ajp://127.0.0.1:8010/publications smax=0 ttl=60 retry=5
    Restart OX and Apache after that. OX will then run on Port 8010 and Apache should correctly redirect requests to OX servlets to that port.

    Greetings

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •