Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    mauro Guest

    Default FC6 installation problem ox gui

    Hi all.
    I try install Hyperion on a FC6 box.
    I follow step by step the installation instruction. All go well (only little bit hard find all the necessary product), but when i arrive at the gui installation i have an error in compile with ant. This is what i read:


    [root@salamx open-xchange-gui]# ant -Dlib.dir=/opt/open-xchange/lib/ -lib /opt/open-xchange/lib deploy
    Buildfile: build.xml

    all_with_clean:

    clean:
    [delete] Deleting directory /oxhyp_fc6_inst/open-xchange-gui/build
    [delete] Deleting 3 files from /oxhyp_fc6_inst/open-xchange-gui

    css:
    [xslt] Processing /oxhyp_fc6_inst/open-xchange-gui/style.xml to /oxhyp_fc6_inst/open-xchange-gui/build/border.css
    [xslt] Loading stylesheet /oxhyp_fc6_inst/open-xchange-gui/css.xsl
    [xslt] oxhyp_fc6_inst/open-xchange-gui/css.xsl:20: Warning! Running an XSLT 1.0 stylesheet with an XSLT 2.0 processor

    html:

    build page:
    [xslt] Processing /oxhyp_fc6_inst/open-xchange-gui/html/index.xml to /oxhyp_fc6_inst/open-xchange-gui/index.html
    [xslt] Loading stylesheet /oxhyp_fc6_inst/open-xchange-gui/build.xsl

    BUILD FAILED
    /oxhyp_fc6_inst/open-xchange-gui/build.xml:514: The following error occurred while executing this line:
    /oxhyp_fc6_inst/open-xchange-gui/build.xml:269: The following error occurred while executing this line:
    /oxhyp_fc6_inst/open-xchange-gui/build.xml:56: Could not create task or type of type: replaceregexp.

    Ant could not find the task or a class this task relies upon.

    This is common and has a number of causes; the usual
    solutions are to read the manual pages then download and
    install needed JAR files, or fix the build file:
    - You have misspelt 'replaceregexp'.
    Fix: check your spelling.
    - The task needs an external JAR file to execute
    and this is not found at the right place in the classpath.
    Fix: check the documentation for dependencies.
    Fix: declare the task.
    - The task is an Ant optional task and the JAR file and/or libraries
    implementing the functionality were not found at the time you
    yourself built your installation of Ant from the Ant sources.
    Fix: Look in the ANT_HOME/lib for the 'ant-' JAR corresponding to the
    task and make sure it contains more than merely a META-INF/MANIFEST.MF.
    If all it contains is the manifest, then rebuild Ant with the needed
    libraries present in ${ant.home}/lib/optional/ , or alternatively,
    download a pre-built release version from apache.org
    - The build file was written for a later version of Ant
    Fix: upgrade to at least the latest release version of Ant
    - The task is not an Ant core or optional task
    and needs to be declared using <taskdef>.
    - You are attempting to use a task defined using
    <presetdef> or <macrodef> but have spelt wrong or not
    defined it at the point of use

    Remember that for JAR files to be visible to Ant tasks implemented
    in ANT_HOME/lib, the files must be in the same directory or on the
    classpath

    Please neither file bug reports on this problem, nor email the
    Ant mailing lists, until all of these causes have been explored,
    as this is not an Ant bug.

    Total time: 1 second
    [root@salamx open-xchange-gui]#

    if i can say, in accord with the installation instruction, i check if i've the ant-optional package:

    [root@salamx open-xchange-gui]# rpm -q ant
    ant-1.6.5-2jpp.2

    [root@salamx open-xchange-gui]# ant -diagnostics
    ------- Ant diagnostics report -------
    Apache Ant version 1.6.5 compiled on August 30 2006

    -------------------------------------------
    Implementation Version (JDK1.2+ only)
    -------------------------------------------
    core tasks : 1.6.5
    optional tasks : not available

    -------------------------------------------
    ANT_HOME/lib jar listing
    -------------------------------------------
    ant.home: /usr/share/ant


    Like you can see, in "optional tasks" there is write not available.
    Is this the problem?
    If yes, where i can find ant-optional for Fedora Core 6? I can't find with yum, and i can't find any RPM in the network.
    Thank you all,
    regards,
    Mauro.
    Last edited by mauro; 07-28-2007 at 11:23 AM.

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi Mauro, did you exported the suggested class information? Please be aware: These information are taken from a debian based system, they may differ on a FC6.

    export CLASSPATH=/opt/open-xchange/lib/saxon8.jar
    export ANT_OPTS="-Djavax.xml.transform.TransformerFactory=net.sf.sax on.TransformerFactoryImpl"

    Ant optional is required for the build process, if the Fedora Project does not offer this tool in its repositories, you may download it seperate:

    http://rpmseek.com/rpm/ant-optional-...:2221704:0:0:0

    (don't know if this is the correct package, if not - just search )
    Last edited by Martin Heiland; 07-28-2007 at 01:23 PM.

  3. #3
    mauro Guest

    Default

    Thank you Martin for your reply.
    I try compile with ant, without export the class. But i not win.
    I install ant-optional from an RPM (the one that you give me only pubblic ftp that contain ant 1.7.0, but thank you for the help). After install ant-optional, my "ant -diagnostics" show me the same (i don't know at this point if is correct):

    [root@salamx open-xchange-gui]# ant -diagnostics
    ------- Ant diagnostics report -------
    Apache Ant version 1.6.5 compiled on August 30 2006

    -------------------------------------------
    Implementation Version (JDK1.2+ only)
    -------------------------------------------
    core tasks : 1.6.5
    optional tasks : not available

    -------------------------------------------
    ANT_HOME/lib jar listing
    -------------------------------------------
    ant.home: /usr/share/ant

    -------------------------------------------
    Tasks availability


    and compile all with ant, fail another time.
    Here the output:

    [root@salamx open-xchange-gui]# ant -Dlib.dir=/opt/open-xchange/lib/ -lib /opt/open-xchange/lib deploy
    Buildfile: build.xml

    all_with_clean:

    clean:
    [delete] Deleting directory /oxhyp_fc6_inst/open-xchange-gui/build
    [delete] Deleting 1 files from /oxhyp_fc6_inst/open-xchange-gui

    css:
    [xslt] Processing /oxhyp_fc6_inst/open-xchange-gui/style.xml to /oxhyp_fc6_inst/open-xchange-gui/build/border.css
    [xslt] Loading stylesheet /oxhyp_fc6_inst/open-xchange-gui/css.xsl

    html:

    build page:
    [xslt] Processing /oxhyp_fc6_inst/open-xchange-gui/html/index.xml to /oxhyp_fc6_inst/open-xchange-gui/index.html
    [xslt] Loading stylesheet /oxhyp_fc6_inst/open-xchange-gui/build.xsl
    [xslt] oxhyp_fc6_inst/open-xchange-gui/build.xsl:50: Error! Mode name is not a valid QName
    [xslt] oxhyp_fc6_inst/open-xchange-gui/build.xsl:112: Error! Mode name is not a valid QName
    [xslt] oxhyp_fc6_inst/open-xchange-gui/build.xsl:113: Error! Mode name is not a valid QName
    [xslt] oxhyp_fc6_inst/open-xchange-gui/build.xsl:116: Error! Mode name is not a valid QName
    [xslt] oxhyp_fc6_inst/open-xchange-gui/build.xsl:120: Error! Mode name is not a valid QName
    [xslt] oxhyp_fc6_inst/open-xchange-gui/build.xsl:154: Error! Error in expression element(): The only functions allowed in a pattern are id() and key()
    [xslt] oxhyp_fc6_inst/open-xchange-gui/build.xsl:162: Error! Error in expression attribute(): The only functions allowed in a pattern are id() and key()
    [xslt] oxhyp_fc6_inst/open-xchange-gui/build.xsl:169: Error! Mode name is not a valid QName
    [xslt] oxhyp_fc6_inst/open-xchange-gui/build.xsl:175: Error! Mode name is not a valid QName
    [xslt] oxhyp_fc6_inst/open-xchange-gui/build.xsl:182: Error! Mode name is not a valid QName
    [xslt] oxhyp_fc6_inst/open-xchange-gui/build.xsl:209: Error! Mode name is not a valid QName
    [xslt] oxhyp_fc6_inst/open-xchange-gui/build.xsl:214: Error! Mode name is not a valid QName
    [xslt] oxhyp_fc6_inst/open-xchange-gui/build.xsl:232: Error! Mode name is not a valid QName
    [xslt] oxhyp_fc6_inst/open-xchange-gui/build.xsl:240: Error! Mode name is not a valid QName
    [xslt] oxhyp_fc6_inst/open-xchange-gui/build.xsl:253: Error! Mode name is not a valid QName
    [xslt] oxhyp_fc6_inst/open-xchange-gui/build.xsl:279: Error! Mode name is not a valid QName
    [xslt] oxhyp_fc6_inst/open-xchange-gui/build.xsl:295: Error! Mode name is not a valid QName
    [xslt] oxhyp_fc6_inst/open-xchange-gui/build.xsl:442: Error! Mode name is not a valid QName
    [xslt] oxhyp_fc6_inst/open-xchange-gui/build.xsl:454: Error! Mode name is not a valid QName
    [xslt] oxhyp_fc6_inst/open-xchange-gui/build.xsl:36: Error! Namespace prefix #all has not been declared
    [xslt] Failed to process /oxhyp_fc6_inst/open-xchange-gui/html/index.xml

    BUILD FAILED
    /oxhyp_fc6_inst/open-xchange-gui/build.xml:514: The following error occurred while executing this line:
    /oxhyp_fc6_inst/open-xchange-gui/build.xml:269: The following error occurred while executing this line:
    /oxhyp_fc6_inst/open-xchange-gui/build.xml:46: javax.xml.transform.TransformerConfigurationExcept ion: Failed to compile stylesheet. 20 errors detected.

    Total time: 1 second


    Any other suggestion?
    I really desire see Hyperion works on my box. I'm intresting in help in the Italian Translation too, after all works in English.
    Thank you,
    Mauro.

  4. #4
    mauro Guest

    Default No other idea?

    I really desire see Hyperion works on my box. But seems that is little bit hard.

  5. #5
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    did you export the saxon stuff to the system envvar? These may differ on you FC6 system:

    export CLASSPATH=/opt/open-xchange/lib/saxon8.jar
    export ANT_OPTS="-Djavax.xml.transform.TransformerFactory=net.sf.sax on.TransformerFactoryImpl"


    ant -Dlib.dir=/opt/open-xchange/lib/ deploy

  6. #6
    mauro Guest

    Default

    Thanks Martin, and sorry if i not understand nothing about Java and ant.
    Yes, i export now the saxon path like you say me, and this is the new results:

    [root@salamx open-xchange-gui]# export CLASSPATH=/opt/open-xchange/lib/saxon8.jar
    [root@salamx open-xchange-gui]# export ANT_OPTS="-Djavax.xml.transform.TransformerFactory=net.sf.sax on.TransformerFactoryImpl"
    [root@salamx open-xchange-gui]# ant -Dlib.dir=/opt/open-xchange/lib/ deploy
    Exception in thread "main" java.lang.NoClassDefFoundError: on/TransformerFactoryImpl
    [root@salamx open-xchange-gui]#


    But .. say me .. is so hard install OX on Fedora? I must change the distribution? I not like this, all my experience is on Fedora distribution.
    Thanks.
    Mauro.

  7. #7
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi Mauro,

    no need to be sorry, a forum is for asking questions

    The installation is that "hard" on any distribution and you should have some knowledge about basic java and linux usage. But for that we provide a wiki which shows a working way to build the whole system from source. As there are no installation packages from your distribution it's the only way to get it running.

    The error message looks like that there is no saxon8.jar file at the /opt/open-xchange/lib directory. The saxon8.jar is one of many dependencies that are required to compile the software. To avoid overhead and redundancy Open-Xchange used already existing libraries for its code, thats why the dependencies are so important.


    /edit
    Or wait... is there a whitespace between "TransformerFactory=net.sf.sax" and "on.TransformerFactoryImpl"? This string must be without a whitespace.

    Please post what the folder /opt/open-xchange/lib contains. It should contain all 3rd party libraries mentioned at the wiki.

    Greetings.
    Last edited by Martin Heiland; 08-03-2007 at 08:59 PM.

  8. #8
    mauro Guest

    Default

    Thanks.
    So, yes, without the space, something change (i not pay atention at this, i say you i not have experience in Java, only know the operating system, and i'm not an expert). Here the new situation:

    [root@salamx open-xchange-gui]# export CLASSPATH=/opt/open-xchange/lib/saxon8.jar
    [root@salamx open-xchange-gui]# export ANT_OPTS="-Djavax.xml.transform.TransformerFactory=net.sf.sax on.TransformerFactoryImpl"
    [root@salamx open-xchange-gui]# ant -Dlib.dir=/opt/open-xchange/lib/ deploy
    Buildfile: build.xml

    all_with_clean:

    clean:
    [delete] Deleting directory /oxhyp_fc6_inst/open-xchange-gui/build
    [delete] Deleting 1 files from /oxhyp_fc6_inst/open-xchange-gui

    css:
    [xslt] Processing /oxhyp_fc6_inst/open-xchange-gui/style.xml to /oxhyp_fc6_inst/open-xchange-gui/build/border.css
    [xslt] Loading stylesheet /oxhyp_fc6_inst/open-xchange-gui/css.xsl
    [xslt] oxhyp_fc6_inst/open-xchange-gui/css.xsl:20: Warning! Running an XSLT 1.0 stylesheet with an XSLT 2.0 processor

    html:

    build page:
    [xslt] Processing /oxhyp_fc6_inst/open-xchange-gui/html/index.xml to /oxhyp_fc6_inst/open-xchange-gui/index.html
    [xslt] Loading stylesheet /oxhyp_fc6_inst/open-xchange-gui/build.xsl

    BUILD FAILED
    /oxhyp_fc6_inst/open-xchange-gui/build.xml:514: The following error occurred while executing this line:
    /oxhyp_fc6_inst/open-xchange-gui/build.xml:269: The following error occurred while executing this line:
    /oxhyp_fc6_inst/open-xchange-gui/build.xml:56: Could not create task or type of type: replaceregexp.

    Ant could not find the task or a class this task relies upon.

    This is common and has a number of causes; the usual
    solutions are to read the manual pages then download and
    install needed JAR files, or fix the build file:
    - You have misspelt 'replaceregexp'.
    Fix: check your spelling.
    - The task needs an external JAR file to execute
    and this is not found at the right place in the classpath.
    Fix: check the documentation for dependencies.
    Fix: declare the task.
    - The task is an Ant optional task and the JAR file and/or libraries
    implementing the functionality were not found at the time you
    yourself built your installation of Ant from the Ant sources.
    Fix: Look in the ANT_HOME/lib for the 'ant-' JAR corresponding to the
    task and make sure it contains more than merely a META-INF/MANIFEST.MF.
    If all it contains is the manifest, then rebuild Ant with the needed
    libraries present in ${ant.home}/lib/optional/ , or alternatively,
    download a pre-built release version from apache.org
    - The build file was written for a later version of Ant
    Fix: upgrade to at least the latest release version of Ant
    - The task is not an Ant core or optional task
    and needs to be declared using <taskdef>.
    - You are attempting to use a task defined using
    <presetdef> or <macrodef> but have spelt wrong or not
    defined it at the point of use

    Remember that for JAR files to be visible to Ant tasks implemented
    in ANT_HOME/lib, the files must be in the same directory or on the
    classpath

    Please neither file bug reports on this problem, nor email the
    Ant mailing lists, until all of these causes have been explored,
    as this is not an Ant bug.

    Total time: 1 second


    and, like you ask, this is the ls of my /opt/open-xchange/lib:

    [root@salamx open-xchange-gui]# cd /opt/open-xchange/lib
    [root@salamx lib]# ls -l
    totale 11248
    -rw-r--r-- 1 root root 55932 19 apr 2006 activation.jar
    -rw-r--r-- 1 root root 36174 5 lug 04:48 commons-cli-1.0.jar
    -rw-r--r-- 1 root root 53082 14 feb 05:34 commons-fileupload.jar
    -rw-r--r-- 1 root root 307550 16 mar 21:34 commons-httpclient-2.0.2.jar
    -rw-r--r-- 1 root root 87776 27 giu 03:51 commons-io.jar
    -rw-r--r-- 1 root root 31605 10 giu 2005 commons-logging.jar
    -rw-r--r-- 1 root root 140837 10 giu 2005 concurrent.jar
    -rw-r--r-- 1 root root 172713 23 dic 2004 jakarta-slide-webdavlib-2.1.jar
    -rw-r--r-- 1 root root 435347 30 mag 20:23 jcs-1.2.7.9.2.jar
    -rw-r--r-- 1 501 root 153253 10 set 2004 jdom.jar
    -rw-r--r-- 1 root root 40247 23 lug 12:52 json.jar
    -rw-r--r-- 1 root root 161477 19 lug 23:13 junit-4.1.jar
    -rw-r--r-- 1 root root 388826 19 ago 2006 mail.jar
    -rw-r--r-- 1 root root 459094 18 ott 2006 mysql-connector-java-3.1.13-bin.jar
    -rw-r--r-- 1 root root 849471 23 lug 12:37 org.eclipse.osgi_3.2.2.ox.jar
    drwxr-xr-x 3 root root 4096 23 lug 13:43 originali
    -rw-r--r-- 1 root root 27241 23 lug 15:01 ox_admin_console_ee.jar
    -rw-r--r-- 1 root root 324099 23 lug 15:01 ox_admindaemon.jar
    -rw-r--r-- 1 root root 13675 23 lug 15:01 ox_admin_plugin_ca_mgmt_simple.jar
    -rw-r--r-- 1 root root 32338 23 lug 15:01 ox_admin_plugin_context_light.jar
    -rw-r--r-- 1 root root 15208 23 lug 15:01 ox_admin_plugin_imap.jar
    -rw-r--r-- 1 root root 74674 23 lug 15:01 ox_admin_plugin_mailfilter.jar
    -rw-r--r-- 1 root root 89586 23 lug 15:01 ox_admin_plugin_mail.jar
    -rw-r--r-- 1 root root 8460 23 lug 14:18 ox_languages.jar
    -rw-r--r-- 1 root root 3177440 23 lug 14:18 ox_server.jar
    -rw-r--r-- 1 root root 3733422 26 giu 23:11 saxon8.jar
    -rw-r--r-- 1 root root 97693 1 ago 2005 servlet-api-2.4.jar
    -rw-r--r-- 1 root root 230640 27 feb 2006 spring-beans_1.2.7.jar
    -rw-r--r-- 1 root root 121409 27 feb 2006 spring-core_1.2.7.jar
    -rw-r--r-- 1 root root 51286 4 mag 21:49 tnef.jar
    [root@salamx lib]#


    /edit
    in particoular, the saxon8.jar file, arrive from saxonb8-9-0-4j.zip that contain saxon8.jar.
    Last edited by mauro; 08-04-2007 at 08:52 AM.

  9. #9
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi, did you installed the package ant-optional like mentioned in the wiki?

  10. #10
    mauro Guest

    Default

    Like i write in the 3rd topic:

    I install ant-optional from an RPM (the one that you give me only pubblic ftp that contain ant 1.7.0, but thank you for the help). After install ant-optional, my "ant -diagnostics" show me the same (i don't know at this point if is correct):

    [root@salamx open-xchange-gui]# ant -diagnostics
    ------- Ant diagnostics report -------
    Apache Ant version 1.6.5 compiled on August 30 2006

    -------------------------------------------
    Implementation Version (JDK1.2+ only)
    -------------------------------------------
    core tasks : 1.6.5
    optional tasks : not available

    -------------------------------------------
    ANT_HOME/lib jar listing
    -------------------------------------------
    ant.home: /usr/share/ant

    -------------------------------------------
    Tasks availability

    Is this way correct for know if i've ant-optional installed correctly?
    You can say me other test that i can perform for know this?
    Thanks.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •