Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 5 of 5
  1. #1
    dawilk Guest

    Default HTTP-API GUI empty response

    Hi!

    I'm working with http://oxpedia.org/wiki/index.php?title=HTTP_API , I can login, logout, but when I make any other request, I recieve empty response and I can see in logs:
    Sep 3 15:37:04 ox2 2010-09-03: 15:37:04,952 open-xchange-groupware ERROR [com.openexchange.ajp13.najp.AJPv13Task][AJPListener-0000001]: com.openexchange.ajp13.najp.AJPv13Task,call AJP-0001 Category=7 Message=[Not available] exceptionID=-550205246-88

    Is that problem with installation?

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    please post the requests you're performing and the OX log file which should contain a corresponding stacktrace to this error.

    Greetings

  3. #3
    dawilk Guest

    Default

    Hi Martin,

    my first request:
    Code:
    POST /ajax/login?action=login
    I recieve a session key (that's ok), next request is for example:
    Code:
    GET /ajax/quota?action=mail&session=e88323426555474db30864d3623808d8 HTTP/1.1
    and now I get an empty response from server (other commands behave in the same way).

    OX log file:
    Code:
    Sep  6 11:14:56 ox-app-2 2010-09-06: 11:14:56,231 open-xchange-groupware DEBUG [com.openexchange.sessiond.impl.SessionHandler][AJPListener-0000758]: com.openexchange.sessiond.impl.SessionHandler,getSession getSession <13976bdbbdb34cc58c5f04dd8b9a9c92>
    Sep  6 11:14:56 ox-app-2 2010-09-06: 11:14:56,231 open-xchange-groupware ERROR [com.openexchange.ajp13.najp.AJPv13Task][AJPListener-0000758]: com.openexchange.ajp13.najp.AJPv13Task,call AJP-0001 Category=7 Message=[Not available] exceptionID=-550205246-831
    Sep  6 11:14:56 ox-app-2 AJP-0001: Category=7 Message=[Not available] exceptionID=-550205246-831
    Sep  6 11:14:56 ox-app-2 at: com.openexchange.ajp13.najp.AJPv13Task.call(AJPv13Task.java:393)
    Sep  6 11:14:56 ox-app-2 at: java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
    Sep  6 11:14:56 ox-app-2 at: java.util.concurrent.FutureTask.run(FutureTask.java:123)
    Sep  6 11:14:56 ox-app-2 at: com.openexchange.threadpool.internal.CustomThreadPoolExecutor$Worker.runTask(CustomThreadPoolExecutor.java:738)
    Sep  6 11:14:56 ox-app-2 at: com.openexchange.threadpool.internal.CustomThreadPoolExecutor$Worker.run(CustomThreadPoolExecutor.java:764)
    Sep  6 11:14:56 ox-app-2 at: java.lang.Thread.run(Thread.java:595)
    Sep  6 11:14:56 ox-app-2 aused: by: java.lang.NullPointerException

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Do you send the cookie that you got when logging in?

    i get this when executing the GET request through a http client (firefox):
    {"data":{"countquota":-1,"use":-1024,"countuse":-1,"quota":-1024}}

  5. #5
    dawilk Guest

    Default

    Hi,

    yes, I send the cookie, but there was a hidden error in my code:/ Now it works correct, thank you for a hint.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •