Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25
  1. #21

    Default

    Hallo!

    Ich habe versucht auf einem OX-Stable CE (Version : 6.20.0 Rev8 (2011-04-21 12:43:06)) den neuestem Funambol zum Laufe zum bekommen.
    Funambol: funambol-10.0.3.bin
    + funambol-ox-module-7.0.8.zip (+ ox-core.zip Patch)
    und alternativ mit Funambol-ox-connector-7.1.1-patched-for-ox-6.18.tgz (http://blog.peter-b.org/2010/12/11/f...rver-error-511)

    Aber mit beiden Varianten renne ich das 511 Problem wenn ich synce (neueste Version von Funambil Win Sync Client)#

    Funambol Client:
    12:00:07 GMT +1:00 [ERROR] - Server Failure: server returned error code 511
    12:00:07 GMT +1:00 [DEBUG] - end (mode "none")
    12:00:07 GMT +1:00 [ERROR] - Error in syncing: Server Failure: server returned error code 511

    ds-Server Log

    011-12-11 11:39:29,323] [funambol.auth] [ERROR] [978A42C9906E51D4FCE61B5C9D4C369C] [192.168.123.214] [fol-QU5EWURWRDpwZXpp] [] [] $
    com.funambol.ox.exception.OXAccessException: Wrong response while attempting to retrieve config data.
    at com.funambol.ox.items.dao.OXEntityDAO.getUserConfi g(OXEntityDAO.java:532)
    at com.funambol.ox.security.OXOfficer.setUserInfo(OXO fficer.java:404)
    at com.funambol.ox.security.OXOfficer.authenticateBas icCredential(OXOfficer.java:234)
    at com.funambol.ox.security.OXOfficer.authenticateUse r(OXOfficer.java:150)
    at com.funambol.ox.security.OXOfficer.authenticateUse r(OXOfficer.java:73)

    Ich dacht dieser Fehler sei gefixt - siehe auch:
    http://comments.gmane.org/gmane.comp...bol.devel/5901


    Gruß
    Peter
    Last edited by pezi; 12-11-2011 at 05:38 PM.

  2. #22
    Join Date
    Dec 2011
    Location
    318 Montgomery Ave, Sarasota, FL 34243
    Posts
    1

    Default

    Das ist sehr hilfreich Idee. Dass es einfach sein, für mich zu verwenden. Vielen Dank für die Beratung und Unterstützung.
    yes thing

  3. #23

    Default

    Hi!

    I get the newest Funambol version 10.0.3 working with OX Funambol 9.0.7 and OX 6.20.0-Rev8 and Funambol Sync Client
    http://sourceforge.net/projects/funa...nc-client/v10/

    In this thread, there are some fixes for Funambol and OX 6.18, but the didn't work for OX 6.20.0.

    I made a maven rebuild of the OX connector according this link
    http://blog.peter-b.org/2010/12/11/f...ver-error-511/
    The fixes are inside the SVN code, but the are disabled by remarks. Someone wrote an other code, which works for OX 6.20.
    The ox-connector has actual the version 9.0.7

    The build is availabe - see the updated version of my installation guide.
    http://geizhalsforum.666kb.at/files/2305/funambol.pdf

    Please report any problems and errors.

    with regards
    Peter

    This is the actual code of ox-core/src/main/java/com/funambol/ox/util/Utility.java

    // if (h[i].getName().equals("Set-Cookie")){
    // // < 6.10
    // // if (h[i].getValue().startsWith("open-xchange-session")){
    // // 6.18 / 6.20
    // if (h[i].getValue().startsWith("open-xchange-secret")){
    // tmp = h[i].getValue();
    // // test "; path=/"
    // int postfixlength = "; path=/".length();
    // sessionIDs[1] = tmp.substring(0,tmp.length()-postfixlength);
    // }
    // if (h[i].getValue().startsWith("JSESSIONID")){
    // tmp = h[i].getValue();
    // // test "; path=/"
    // int postfixlength = "; path=/".length();
    // sessionIDs[2] = tmp.substring(0,tmp.length()-postfixlength);
    // }
    // }

    //
    if (h[i].getName().equals("Set-Cookie")){
    tmp = h[i].getValue();
    // remove "; ..."
    // in the request during the sync process the Cookie should
    // have just the first part
    int firstSemiColon = tmp.indexOf("; ");
    tmp = tmp.substring(0, firstSemiColon);
    oxHeaderKeys.getCookies().add(tmp);
    }


    }
    Last edited by pezi; 12-13-2011 at 11:20 AM.

  4. #24
    Join Date
    Dec 2011
    Posts
    1

    Default oxconnector not syncing to OX database

    Hello Peter,

    I read your manual http://geizhalsforum.666kb.at/files/2305/funambol.pdf, downloaded and installed everthing as you described. From my android phone the contacts are synced to Funambol DS ServerVersion 10.0.0 (i can see the contacts in the webdemo), but they are not appearing in OX contacts.

    Please help! what am i missing here?

    Tim



    Quote Originally Posted by pezi View Post
    Hi!

    I get the newest Funambol version 10.0.3 working with OX Funambol 9.0.7 and OX 6.20.0-Rev8 and Funambol Sync Client
    http://sourceforge.net/projects/funa...nc-client/v10/

    In this thread, there are some fixes for Funambol and OX 6.18, but the didn't work for OX 6.20.0.

    I made a maven rebuild of the OX connector according this link
    http://blog.peter-b.org/2010/12/11/f...ver-error-511/
    The fixes are inside the SVN code, but the are disabled by remarks. Someone wrote an other code, which works for OX 6.20.
    The ox-connector has actual the version 9.0.7

    The build is availabe - see the updated version of my installation guide.
    http://geizhalsforum.666kb.at/files/2305/funambol.pdf

    Please report any problems and errors.

    with regards
    Peter

    This is the actual code of ox-core/src/main/java/com/funambol/ox/util/Utility.java

    // if (h[i].getName().equals("Set-Cookie")){
    // // < 6.10
    // // if (h[i].getValue().startsWith("open-xchange-session")){
    // // 6.18 / 6.20
    // if (h[i].getValue().startsWith("open-xchange-secret")){
    // tmp = h[i].getValue();
    // // test "; path=/"
    // int postfixlength = "; path=/".length();
    // sessionIDs[1] = tmp.substring(0,tmp.length()-postfixlength);
    // }
    // if (h[i].getValue().startsWith("JSESSIONID")){
    // tmp = h[i].getValue();
    // // test "; path=/"
    // int postfixlength = "; path=/".length();
    // sessionIDs[2] = tmp.substring(0,tmp.length()-postfixlength);
    // }
    // }

    //
    if (h[i].getName().equals("Set-Cookie")){
    tmp = h[i].getValue();
    // remove "; ..."
    // in the request during the sync process the Cookie should
    // have just the first part
    int firstSemiColon = tmp.indexOf("; ");
    tmp = tmp.substring(0, firstSemiColon);
    oxHeaderKeys.getCookies().add(tmp);
    }


    }

  5. #25

    Default

    Hello Peter,

    I tried to install the funambol-Connector according to your installationguide on a Host with opensuse 11.4.
    You wrote in your guide:
    To enable and register the Open-Xchange connector at the Funambol server, it has to be
    added to the configuration file at /opt/Funambol/ds-server/install.properties. The last line
    of this file should look like this:
    modules-to-install=content-provider-7.1.2,email-connector-7.1.1,foundation-
    7.1.1,phones-support-7.1.0, funambol-ox-listener-9.0.7-SNAPSHOT
    With this config, the install-module failed. Should it be "ox-connector-9.0.7-SNAPSHOT" instead of "funambol-ox-listener-9.0.7-SNAPSHOT"?

    Ok, Install-Module worked, started funambol, started ox-listener. Status of ox-listener:
    OXLISTENER_HOME: /opt/Funambol/ox-listener
    JAVA_OPTS: -Dfile.encoding=UTF-8 -Dfunambol.home=/opt/Funambol -Dfunambol.pushlistener.config.bean=com/funambol/oxlistener/OXListenerConfiguration.xml -Djava.library.path=/opt/Funambol/ox-listener/lib/x86_64 -Djavax.net.ssl.trustStore=/opt/Funambol/ox-listener/lib/security/cacerts
    Connecting to: localhost:3102
    PushListener status:
    > instance: com.funambol.pushlistener.service.PushListenerHeal thStatus@f79f36b
    > RegistryMonitor status:
    > instance: com.funambol.pushlistener.service.registry.Registr yMonitor@203e1bc8
    > current number of threads in the pool: 1
    > number of running tasks: 0
    > number of scheduled tasks: 12
    > number of completed tasks: 11
    > number of tasks to execute: 1
    > is shut down: false
    > ScheduledTaskExecutor status:
    > instance: com.funambol.pushlistener.service.taskexecutor.Sch eduledTaskExecutor@59e2afb2
    > current number of threads in the pool: 0
    > number of running tasks: 0
    > number of scheduled tasks: 0
    > number of completed tasks: 0
    > number of tasks to execute: 0
    > is shut down: false
    Seems ok.
    Then, I tried to configure Funambol.
    I called "/opt/Funambol/admin/bin/funamboladmin" as root, but there is no process listed. I but a "set -x" in top of the funamboladmin to get further information. The script "/opt/Funambol/admin # cd platform6/lib/nbexec" was not executable. A chmod did the trick. So started the script again....no errors....but also no process in the list.
    Can you tell me whats wrong here? Any Ideas?

    Regards

    Daniel

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •