Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 5 of 5
  1. #1
    OXnewbi Guest

    Default UBUNTU / OX 6.18 installation/ Pb http access (SOLVED)

    Hi there,

    I'm a newbie in the Linux World. My Boss ask me to work on linux to be able to use Open Xchange to manage our mails.

    So I try for now on a test machine with UBUNTU 10

    I follow this installation procedure

    http://oxpedia.org/wiki/index.php?ti...r_Ubuntu_10.04

    Everything is fine until that

    Modify the default website settings to display the Open-Xchange GUI

    For versions of Open-Xchange starting with 6.18:

    $ vim /etc/apache2/sites-available/default

    <VirtualHost *:80>
    ServerAdmin webmaster@localhost

    DocumentRoot /var/www/

    <Directory /var/www/>
    AllowOverride None
    Order allow,deny
    allow from all
    RedirectMatch ^/$ /ox6/
    Options +FollowSymLinks +SymLinksIfOwnerMatch
    </Directory>
    # deflate
    AddOutputFilterByType DEFLATE text/html text/plain text/javascript application/javascript text/css text/xml application/xml text/x-js application/x-javascript

    # pre-compressed files
    AddType text/javascript .jsz
    AddType text/css .cssz
    AddType text/xml .xmlz

    AddEncoding x-gzip .jsz .cssz .xmlz
    SetEnvIf Request_URI "\.(jsz|cssz|xmlz)$" no-gzip

    ExpiresActive On

    <Location /ox6>
    # Expires (via ExpiresByType to override global settings)
    ExpiresByType image/gif "access plus 6 months"
    ExpiresByType image/png "access plus 6 months"
    ExpiresByType image/jpg "access plus 6 months"
    ExpiresByType image/jpeg "access plus 6 months"
    ExpiresByType text/css "access plus 6 months"
    ExpiresByType text/html "access plus 6 months"
    ExpiresByType text/xml "access plus 6 months"
    ExpiresByType text/javascript "access plus 6 months"
    ExpiresByType text/x-js "access plus 6 months"
    ExpiresByType application/x-javascript "access plus 6 months"
    ExpiresDefault "access plus 6 months"
    Header append Cache-Control "private"
    Header unset Last-Modified
    Header unset Vary
    # Strip version
    RewriteEngine On
    RewriteRule v=\w+/(.+) $1 [L]
    # Turn off ETag
    Header unset ETag
    FileETag None
    </Location>

    <Location /ox6/ox.html>
    ExpiresByType text/html "now"
    ExpiresDefault "now"
    Header unset Last-Modified
    Header set Cache-Control "no-store, no-cache, must-revalidate, post-check=0, pre-check=0"
    # Turn off ETag
    Header unset ETag
    FileETag None
    </Location>

    <Location /ox6/index.html>
    ExpiresByType text/html "now"
    ExpiresDefault "now"
    Header unset Last-Modified
    Header set Cache-Control "no-store, no-cache, must-revalidate, post-check=0, pre-check=0"
    # Turn off ETag
    Header unset ETag
    FileETag None
    </Location>
    </VirtualHost>

    When I do that I can't restart APACHE

    Error message : Syntax error on line 43 of /etc/apache2/sites-enabled/000-default:
    Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration
    [fail]

    But I use the 6.18 version

    If I use that :
    For versions of Open-Xchange prior to 6.18:

    $ vim /etc/apache2/sites-available/default

    <VirtualHost *:80>
    ServerAdmin webmaster@localhost

    DocumentRoot /var/www/

    <Directory /var/www/>
    AllowOverride None
    Order allow,deny
    allow from all
    RedirectMatch ^/$ /ox6/
    </Directory>

    ExpiresActive On
    ExpiresByType image/gif "access plus 23 hours"
    ExpiresByType image/png "access plus 23 hours"
    ExpiresByType image/jpg "access plus 23 hours"
    ExpiresByType image/jpeg "access plus 23 hours"
    ExpiresByType text/javascript "access plus 23 hours"
    ExpiresByType text/css "access plus 23 hours"
    ExpiresByType text/html "access plus 23 hours"
    ExpiresByType application/x-javascript "access plus 23 hours"
    <Files ~ "\.(js|css|gif|jpe?g|png)$">
    Header append Cache-Control "public"
    </Files>

    DeflateFilterNote ratio
    AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/x-js application/x-javascript application/javascript
    BrowserMatch ^Mozilla/4 gzip-only-text/html
    BrowserMatch ^Mozilla/4\.0[678] no-gzip
    BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html
    Header append Vary User-Agent env=!dont-vary
    </VirtualHost>


    I can restart APACHE

    But i can't enter in Open Xchange via FIREFOX

    ERROR MESSAGE : You need to enable JavaScript to access the Open-Xchange Server.

    JAVASCRIPT is enabled on my FIREFOX

    Thanks for your help !
    Last edited by OXnewbi; 09-22-2010 at 12:05 PM.

  2. #2
    Join Date
    Jun 2009
    Posts
    28

    Default

    use the config you posted first, then use this :

    Activate rewriteEngine with: (needs root privileges)

    cd /etc/apache2/mods-enabled
    ln -s ../mods-available/rewrite.load rewrite.load
    /etc/init.d/apache2 restart

  3. #3
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Check out the quick install guide, e.g. for Debian, every configuration is posted there. Debian and Ubuntu are more or less the same so you can just interchance the configs.

  4. #4
    OXnewbi Guest

    Default

    THANKS A LOT mybulk !

    Your solution works fine !! PB SOLVED

    Cheers.
    ps: How I close this case ?
    Last edited by OXnewbi; 09-22-2010 at 12:07 PM.

  5. #5
    OXnewbi Guest

    Default

    Ooops, I did something wrong, or something wrong appens...

    I try to change the title of the theard, to ass (SOLVED) and my first message has disappears ...

    So I put here what was my problem before Mysbulk help me...

    I follow those manipulation (link below)

    http://oxpedia.org/wiki/index.php?ti...r_Ubuntu_10.04

    Everything was ok until this :

    Modify the default website settings to display the Open-Xchange GUI

    For versions of Open-Xchange starting with 6.18:
    <VirtualHost *:80>
    ServerAdmin webmaster@localhost

    DocumentRoot /var/www/

    <Directory /var/www/>
    AllowOverride None
    Order allow,deny
    allow from all
    RedirectMatch ^/$ /ox6/
    Options +FollowSymLinks +SymLinksIfOwnerMatch
    </Directory>
    # deflate
    AddOutputFilterByType DEFLATE text/html text/plain text/javascript application/javascript text/css text/xml application/xml text/x-js application/x-javascript

    # pre-compressed files
    AddType text/javascript .jsz
    AddType text/css .cssz
    AddType text/xml .xmlz

    AddEncoding x-gzip .jsz .cssz .xmlz
    SetEnvIf Request_URI "\.(jsz|cssz|xmlz)$" no-gzip

    ExpiresActive On

    <Location /ox6>
    # Expires (via ExpiresByType to override global settings)
    ExpiresByType image/gif "access plus 6 months"
    ExpiresByType image/png "access plus 6 months"
    ExpiresByType image/jpg "access plus 6 months"
    ExpiresByType image/jpeg "access plus 6 months"
    ExpiresByType text/css "access plus 6 months"
    ExpiresByType text/html "access plus 6 months"
    ExpiresByType text/xml "access plus 6 months"
    ExpiresByType text/javascript "access plus 6 months"
    ExpiresByType text/x-js "access plus 6 months"
    ExpiresByType application/x-javascript "access plus 6 months"
    ExpiresDefault "access plus 6 months"
    Header append Cache-Control "private"
    Header unset Last-Modified
    Header unset Vary
    # Strip version
    RewriteEngine On
    RewriteRule v=\w+/(.+) $1 [L]
    # Turn off ETag
    Header unset ETag
    FileETag None
    </Location>

    <Location /ox6/ox.html>
    ExpiresByType text/html "now"
    ExpiresDefault "now"
    Header unset Last-Modified
    Header set Cache-Control "no-store, no-cache, must-revalidate, post-check=0, pre-check=0"
    # Turn off ETag
    Header unset ETag
    FileETag None
    </Location>

    <Location /ox6/index.html>
    ExpiresByType text/html "now"
    ExpiresDefault "now"
    Header unset Last-Modified
    Header set Cache-Control "no-store, no-cache, must-revalidate, post-check=0, pre-check=0"
    # Turn off ETag
    Header unset ETag
    FileETag None
    </Location>
    </VirtualHost>


    AFTER that I cannot restart APACHE.

    ERROR : Syntax error on line 43 of /etc/apache2/conf.d/ox.conf:
    Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration


    Then I solved the problem with the solution gives by Mybulk .

    Cheers

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •