Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 5 of 5
  1. #1
    Aszrael Guest

    Default apache2 not starting

    Hi,
    I followed your excellent howto.
    When starting apache2 it drops out with
    "Syntax error on line 1 of /etc/apache2/conf.d/ox.conf:
    Invalid command 'JkWorkersFile', perhaps misspelled or defined by a module not included in server configuration"

    Somehow mod_jk is not loaded by apache2, but:
    libapache2-mod-jk (v.1.2.18-3etch1) is installed and mod_jk.so is in /usr/lib/apache2/
    JkWorkersFile in ox.conf is pointing to /etc/libapache2-mod-jk/workers.properties.

    Am I missing something? Is the module to be included somewhere in apache-configs?

    [edit] there is no jk.load in /etc/apache2/mods-enabled/
    how do I get it? [/edit]

    Thanks
    Aszrael
    Last edited by Aszrael; 08-10-2007 at 02:15 PM.

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    to use mod_jk the module has to be loaded by apache2, this seems to be distribution specific, maybe there exists a how-to for your distribution?

  3. #3
    sledge0303 Guest

    Default

    a2enmod lists available apache modules, choose your mod_jk, restart Apache2 and then should everything be all right.

  4. #4
    Aszrael Guest

    Default

    thanks for your extremely quick reply.
    I found the answer:
    # a2enmod jk
    did the trick for me on debian/etch
    Maybe this could be added to Open_Xchange_Installation.

    Thanks a lot
    Aszrael

  5. #5
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    i installed a dozen machines with Hyperion on Debian Etch and mod_jk worked on every default install... *confused*

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •