Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 4 of 4
  1. #1
    Join Date
    Apr 2008
    Posts
    20

    Default Settings for OX Client Updater?

    What is the proper way to get different Settings for OX Client Updater on OX AE? For now it creates by default a new Outlook Profile including Email account. But uses wrong port numbers since we use e.g. port 576 for smtp since many Internet providers block traffic to foreign smtp service on 25.

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    this is not meant to be changed on an OXAE machine. However, you could ask your OX partner or the OX support for assistance and additional services for your OXAE installation.

    Greetings

  3. #3
    Join Date
    Apr 2008
    Posts
    20

    Default

    There is no OX partner between OX and us because we have enough Linux / Groupware expertise. Its a topic of missing Documantation. As I understood this kind of question would not be answered with installation support. Do we really need to buy support for questions which could be answered within administrators handbook?
    An Outlook profile with "localhost" entered as Mailserver is simply crap! So this nice "Welcome to Open-Xchange Server" Wizard is then kind of beta I guess beacause with the default settings it does not give a usable Outlook profile, and even worse it kills a working profile by making a new one and setting it as default!
    At least the possibility to disable the autocreation of a new profile should be configurable for OX AE within UCS registry...better having the other setting from there as well.

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Well, that setting might be incorrect on your installation by default. However, this does not affect the maturity of the wizard itself nor does it "kill" any other profile - it just sets a new default where the user can select the previous profile as default again if he likes. I'm gonna check the initial mail server address setting for OXAE, this could be some kind of integration bug.

    Please note that 25/tcp is the default port for SMTP/S and 587 is an alternative but not the default. If the internet provider blocks port 25, this is a non-default behavior of the environment and unfortunately not covered by the OXAE default configuration and parameters.

    The parameters itself are not configurable but read from the users groupware configuration. Thats why there is no documentation about changing them. It seems like the SMTP server is set to "localhost" while the IMAP server is set to the correct hostname when creating users. This works fine via the GUI since the SMTP server runs locally from OX' perspective.

    Possible workaround:
    Check the Settings -> Connection -> URL field at the OXUpdater, it contains an URL to a XML file that contains configuration e.g. for the Outlook OXtender. This XML file might contain invalid configuration data. You could copy&paste and fix the contents to the desired values and put it to an alternative update.xml file which needs to be added to the clients OXUpdater.

    Thanks for you report. I've opened a bug report for this behavior.
    Last edited by Martin Heiland; 10-04-2010 at 03:34 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •