Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1

    Default Performanceprobleme seit 6.18.9

    Hallo,

    wir haben ein update von 6.16 auf 6.18 Rev 9 durchgeführt. Mit dieser Umstellung schein sich ein unschöner Fehler eingeschlichen zu haben.

    Alle Aktion, die über die Groupware-GUI ausgeführt werden, erzeugen ein hohen IO-Wait auf dem Server. Besonders problematisch ist das beim Mailfolder. Das Öffnen und initale Laden der Folder sollte sehr schnell gehen, es dauert aber hier 20-30 Sekunden, natürlich abhängig von der Anzahl der Folder. Das Lesen der Emails geht relativ schnell.
    Zu beobachten ist, das der Zugriff auf die Emailkonten über die GUI IMMER zu einem hohen IO-Wait führt. Während des Zugriffes kommt nur die Sanduhr.
    Zugriff auf die Mailboxen mit einem Email-Client zeigt dagegen keine Auffälligkeiten, es liegt also nicht am Cyrus selber.
    Also, die Menge der Ordner im IMAP ist hier nicht dasProblem, sondern das die Zugriffe darauf den hohen IO erzeugen, was der Zugriff per Mail-Client nicht macht.

    Verwendet wird OX6.18.Rev9, RHES5, Cyrus-Imap, Mysql, Postfix.

    Gibt es irgendwo eine Schraub, an der ich drehen kann, um hier im OX die Performance zu verbessern?
    Oder irgendeine Idee, wo ich suchen kann, um dem Probelm näher zu kommen? Die logfiles sagen natürlich nichts, es kommt ja auch zu keinem Fehler, es ist nur alles grottenlangsam geworden.

    Vg
    Sebastian

  2. #2

    Default

    Hi,

    im maillog ist zu erkennen, dass sich die Groupware, (die ja der Imap-Client ist) mehrfach auf dem cyrus anmeldet und alle Aktionen, die der Nutzer anfordert, mehrfach auf dem Mailserver ausführt.
    Ist das so normal? Es gibt dementsprechend sehr viele imapd-prozesse, die sich natürlich gegenseitig behindern.

    Auf unserem Testsystem kann ich so ein verhalten nicht nachvollziehen.

    Sebbel

  3. #3
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hallo,

    das muss man mal analysieren. Aus Performancegründen laden wir verschiedene Ordner parallel, möglich dass es im Log den Anschein erweckt, dass der gleiche Befehl ausgeführt wird. Du kannst dazu gerne einen Bugreport aufmachen.

    Gruß

  4. #4
    Join Date
    Feb 2007
    Posts
    113

    Default

    hallo,
    wir verwenden die 6.18.0 Rev14 in einer ähnlichen hw/sw konstelation ohne solche probleme. allerdings gab es das problem auch bei uns. hat lange gedauert, bis wir herausgefunden hatten, dass das iowait wegen der zu geringen anzahl an NFS prozessen passierte. Möglicherweise ist es bei euch ja so ähnlich?
    lg

  5. #5

    Default

    Hallo,

    jetzt müsste man nur noch NFS nutzen. Also, es ist ein Verzeichnis eingehängt, aber das wird durch cyrus nicht verwendet. Wo müsste ich bei NFS drehen um die Prozessanzahl zu erhöhen?

    Hmm, aber ne Idee isses natürlich. Ich hab im cyrus das prefork für imap mal auf 10 erhöht, das schein eine klizekleine Besserung gebracht zu haben. Aber nicht entscheident.

    Bugreport: Ok, gerne, wenn ich hier einen Bug hätte. Aber das würde ich gerne erst noch näher herausbekommen. Auf unserer Testkiste scheint das nämlich reibungslos zu funktionieren, die ist allerdings nicht von 6.16 auf 6.18.1 direkt aktualisiert worden sondern über Zwischenschritte. Außerdem hat die zu wenig Last, als das ich das effektiv ermitteln könnte, ob die das Problem auch hat, ich glaub es aber nicht.
    Ergo - auf der Hauptserver muss was nicht stimmen.
    Noch eine Idee, wie ich mich dem Problem nähern könnte? Wir haben das Subsystem schon einem Stresstest unterzogen. Das bringt aktuell genügend performance. Mich irritiert halt stark, dass Zugriffe aus dem OX heraus das System so stressen, während viele Email-Clients direkt überhaupt keine Wirkung zeigen.

    Vg
    Sebbel

  6. #6
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    494

    Default

    Das neueste Update ist 6.18 rev20. Da könnte noch was IMAP performance-relevantes dabei sein wenn ich mich richtig erinnere.

    Gruss,
    Wolfgang

  7. #7

    Default

    Da ich 6.18.1 Rev 12 habe ist das Update nicht für mein System gedacht.

    Wir haben durch kleiner Tuningmaßnahmen am Cyrus das ein wenig verbessern könne, aber ist noch nicht wirklich viel.
    Weitere Ideen, wie ich dem OX da auf die Sprünge helfen kann oder das Problem eingrenzen kann?

  8. #8
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    heute ist 6.18.2 rausgekommen, dort wurde weiter an der Performance geschraubt. Vielleicht hilft das - ansonsten: Ticket beim Support oder einen Bug mit den bisherigen Erkenntnissen aufmachen.

    Gruß

  9. #9

    Default

    Ahhhh! Sehr schön, gleich mal auf die Testumgebung werfen.

    Schönes Weihnachtsfest!

  10. #10

    Default

    Hallo,

    das Problem besteht leider immer noch. Letzte interne Diskussion erbrachte, dass wir das Feature der parallelen Abfragen auf die Emailkonten gerne mal abschalten würden.
    Ist das möglich über die Konfig?

    Wenn das nicht geht werd ich den Support bemühen müssen, da bei vielen Nutzern die GUI sehr sehr zäh wird :-(

    Grüße
    Sebbel

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •