Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 16 12311 ... LastLast
Results 1 to 10 of 152
  1. #1
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default Open-Xchange Community Edition Installer released

    Hello Everybody,

    i just want to point your attention to a little contribution i've been working on in the last weeks: http://www.open-xchange.com/wiki/ind...tion_Installer

    This little script automatically installs a full functional build of the Open-Xchange Community Edition on a Debian Etch system. Currently it works quite simple, but i hope you like it anyway and maybe drop some feedback

    Greetings.
    Last edited by Martin Heiland; 08-23-2007 at 11:53 PM.

  2. #2
    xiao Guest

    Default

    Quote Originally Posted by Martin Braun View Post
    Hello Everybody,

    i just want to point your attention to a little contribution i've been working on in the last weeks: http://www.open-xchange.com/wiki/ind...tion_Installer

    This little script automatically installs a full functional build of the Open-Xchange Community Edition on a Debian Etch system. Currently it works quite simple, but i hope you like it anyway and maybe drop some feedback

    Greetings.

    thank you very much Martin, as always helping and making great contributions, thank you very much.

  3. #3
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Installers updated, i also added a script for openSuSE 10.2 and Ubuntu Feisty.
    Last edited by Martin Heiland; 08-25-2007 at 10:40 PM.

  4. #4
    jonathanussf Guest

    Default Fantansitc Script

    Many thanks to Martin and his great effort. The script does the work of two days for you in 5 minutes.

    Remember to set your JDK enviroments ie: JAVA_HOME etc...

    John (very happy now with OX)

  5. #5
    xiao Guest

    Default

    Quote Originally Posted by Martin Braun View Post
    Installers updated, i also added a script for openSuSE 10.2 and Ubuntu Feisty.

    thanks for your work Martin… I have a doubt, that I must change so that the dominion is not example.com and change it by midomain.com

  6. #6
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    // EDIT:
    The workaround below is obsolete now as i added a customizable domain name to the installer. It's included at the debian installer at the moment but will also be available at the ubuntu/opensuse installer soon.

    Hi,

    you'll have to modify the following lines. All line numbers are taken from the debian script as of 19/09/07.

    line 216:
    /opt/open-xchange/sbin/oxinstaller -f --oxdb-pass=secret --admin-pass=secret --maildomain example.com

    line 227:
    /opt/open-xchange/sbin/createuser -A oxadmin -P secret -c 1 -u testuser -d "Test User" -s "User" -g "Test" -p secret -e testuser@example.com

    configs:
    apache/default: ServerName hyperion.example.com
    apache/default: ServerAdmin oxadmin@example.com
    cyrus/imapd.conf:loginrealms: example.com
    postfix/main.cf:myhostname = example.com
    Last edited by Martin Heiland; 09-20-2007 at 09:59 AM.

  7. #7
    Gromit Guest

    Default

    Does your script also work with Ubuntu 6.06 LTS ?

  8. #8
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi Gromit,

    i am not sure about this, but - just try
    If it is a requirement for many community members to provide a 6.06 installer i'll think about it but supporting any and every version of a distribution will end up in a very large support effort, for example when updating the script for 100 platforms. But anybody is invited port the installer to other distributions and operating systems.

    Greetings

  9. #9
    Gromit Guest

    Default

    Well, I think Ubuntu 6.06 LTS ist probably the most important version of ubuntu for server systems right now since it has the long term support.

  10. #10
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi again,

    i just added a installer for Ubuntu 6.06 LTS. Please add the 'universe' and 'multiverse' repository to your sources.list in order to complete installation.

    Greetings

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •