Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 5 of 5
  1. #1
    Join Date
    Jan 2008
    Posts
    140

    Default oxadmin not working on CLI

    Hi,

    we are using successfully oxldapsync. But after running oxldapsync we have
    some problems using the cli interface. So when I try to change user settings
    I get an error
    /opt/open-xchange/sbin/listuser -c 1 -A oxadmin -P PASSWORD
    users in context 1 could not be listed:
    Server response:
    Authentication failed

    The pw *is* working for oxldapsync ....

    What can we do ?

    Bye, Peer

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Perhaps the context id is incorrect? The cli will return any specific error details for security reasons if access to a context fails.

  3. #3
    Join Date
    Jan 2008
    Posts
    140

    Default

    Hi,

    we only have *one* context. The password is the same for oxldapsync and the cli commands.
    Is there a way to create a second admin account to check/change the password of the oxadmin ?
    Using the WEB-Interface will alway work, because the ldap pw is taken, right ?

  4. #4
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    I doubt that oxldapsync is working using the same password for oxadmin and it does not work when running the same command outside. That sounds quite unlikely.
    Fact is, that the admin cli authenticates against the database via admin daemon. That means, you cannot use the password in ldap of the same user oxadmin. oxadmin user still has the same password for the admin daemon, which you specified upon initial context creation (unless you manually changed it using changeuser). oxldapsync cannot sync passwords, btw.
    OXpedia.org - the answer to almost all questions.

  5. #5
    Join Date
    Jan 2008
    Posts
    140

    Default

    Quote Originally Posted by Carsten Hoeger View Post
    Fact is, that the admin cli authenticates against the database via admin daemon.
    Fact is also: the oxldapsync seem's to work. New users added to the ldap can be found in the member list of the open xchange
    when I create a appointment. Also nobody has change/modified the oxadmin user. Only "normal" ldap users. It wasn't clear,
    if the cli commands *only* work against the database, or if the settings of the gui are used (auth. against LDAP).

    I've reseted the password and now everything works normal.

    Thanks.

    Quote Originally Posted by Carsten Hoeger View Post
    ...oxldapsync cannot sync passwords, btw.
    That's clear and not necessary, because the authentication for normal user is done against LDAP.
    We just need the LDAP Account to automatically create the users within open xchange.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •