Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    Leuchtfeuer18 Guest

    Angry Problem Upgrading to 6.18.0 at SUSE 11.1

    Moin!

    I did install openexchange community edition a year ago, did updates and would like to use ist again. When trying to open webinterface I see:

    HTML Code:
    You need to enable JavaScript to access the Open-Xchange Server.
    
    Für den Zugriff auf den Open-Xchange Server müssen Sie JavaScript aktivieren.

    I find follwing line at my /var/log/apache2/error.log:

    Code:
    File does not exist: /srv/www/htdocs/ox6/v=MkGgXRX, referer: http://myIP/ox6/
    I did changes to the apache configuration, here is my /etc/apache2/sites-available/default:
    Code:
    <virtualHost *:80>
      ServerAdmin webmaster@localhost
      DocumentRoot /srv/www/htdocs/
      <Directory /srv/www/htdocs>
        AllowOverride None
        Order allow,deny
        allow from all
        RedirectMatch ^/$ /ox6/
        Options +FollowSymLinks +SymLinksIfOwnerMatch
      </Directory>
      # deflate
      AddOutputFilterByType DEFLATE text/html text/plain text/javascript application/javascript text/css text/xml application/xml text/x-js application/x-javascript
    
      #pre-compressed files
      AddType text/javascript .jsz
      AddType text/css .cssz
      AddType text/xml .xmlz
      AddEncoding gzip .jsz .cssz .xmlz
      SetEnvIf Request_URI "\.(jsz|cssz|xmlz)$" no-gzip
      ExpiresActive On
      <Location /ox6>
        # Expires (via ExpiresByType to override global settings)
        ExpiresByType image/gif "access plus 6 months"
        ExpiresByType image/png "access plus 6 months"
        ExpiresByType image/jpg "access plus 6 months"
        ExpiresByType image/jpeg "access plus 6 months"
        ExpiresByType text/css "access plus 6 months"
        ExpiresByType text/html "access plus 6 months"
        ExpiresByType text/xml "access plus 6 months"
        ExpiresByType text/javascript "access plus 6 months"
        ExpiresByType text/x-js "access plus 6 months"
        ExpiresByType application/x-javascript "access plus 6 months"
        ExpiresDefault "access plus 6 months"
        Header append Cache-Control "private"
        Header unset Last-Modified
        Header unset Vary
        # Strip version
        RewriteEngine On
        RewriteRule v=\w+/(.+) $1 [L]
        # Turn off ETag
        Header unset ETag
        FileETag None
      </Location>
      <Location /ox6/ox.html>
        ExpiresByType text/html "now"
        ExpiresDefault "now"
        Header unset Last-Modified
        Header set Cache-Control "no-store, no-cache, must-revalidate, post-check=0, pre-check=0"
        # Turn off ETag
        Header unset ETag
        FileETag None
      </Location>
      <Location /ox6/index.html>
        ExpiresByType text/html "now"
        ExpiresDefault "now"
        Header unset Last-Modified
        Header set Cache-Control "no-store, no-cache, must-revalidate, post-check=0, pre-check=0"
        # Turn off ETag
        Header unset ETag
        FileETag None
       </Location>
    </VirtualHost>
    Could anybody help me? Please

    Thanks, Sandra

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    it seems like the rewrite engine is not working, can you verify that the module is running and all site configurations have been updated? Perhaps some ssl vhost entry has not yet been updated. Check the sites-enabled directory for other configuration files.

    Greetings

  3. #3
    Leuchtfeuer18 Guest

    Default

    phpinfo() says that the rewrite module is installed and active. Is there anyway to proof if it is working correct? I did reinstall this module from a different repository.
    the default configurations is the only one.

    thanks, Sandra

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Well, its very strange that apache loggs such stuff as errors:
    Code:
    srv/www/htdocs/ox6/v=MkGgXRX, referer: http://myIP/ox6/
    mod_rewrite should rewrite the "v=cRyPtiC" stuff to / like defined here:
    Code:
    # Strip version
        RewriteEngine On
        RewriteRule v=\w+/(.+) $1 [L]
    Maybe some old and some new apache settings collide?

    Greetings

  5. #5
    Leuchtfeuer18 Guest

    Default

    Thanks for your help,
    I added the location part of the config to default-server.conf and got the following page:

    Code:
     Loading
    10%
    Loading Scripts and Content ... Please Wait ...
     
     
     Please wait while you are being redirected to the start page ...
     
     Version : 6.18.0 Rev20 ( 2010-12-10 15:10:59 )
    The server hangs at this page. Nothing in apache/error.log.

    Firebug says:
    Code:
    initAll is not defined
    [Bei diesem Fehler anhalten] Das Laden des Quelltexts ist fehlgesch.../myIP/ox6/ox.html/event/seq/1
    Thanks for ypur help

  6. #6
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Yes, i think the source cannot be loaded because the location of the JS file is not valid due to some mod_rewrite issue. The JS code is using auto-versioning since 6.18 and comes with that v=something URL part which allows to override the browsers cache. For whatever reason, apache does not rewrite the URL :/

  7. #7
    Leuchtfeuer18 Guest

    Default

    Firebug say now:

    illegal character
    � concat_init.jsz (Zeile 1) and concat_ox.jsz (Zeile 1)

    thx

  8. #8
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    It looks like the browser does not detect the file type. The apache config sets "AddEncoding gzip" for those jsz files. Again, this seems to be caused by a faulty apache configuration.

    Greetings

  9. #9
    Leuchtfeuer18 Guest

    Default

    I am now able to see the login-mask but not able to login. Is there any way to reset the password? /opt/open-xchange/sbin/createuser says
    Code:
    user in context 1 could not be created: 
    Server response:
     Authentication failed

  10. #10
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    you can reset the password for user oxadmin this way:
    1. /opt/open-xchange/etc/admindaemon/AdminDaemon.properties
    Code:
    CONTEXT_AUTHENTICATION_DISABLED=true
    2. Restart the admindaemon
    3. Change the password of oxadmin
    Code:
    changeuser -c 1 -u oxadmin -p newpass
    4. /opt/open-xchange/etc/admindaemon/AdminDaemon.properties
    Code:
    CONTEXT_AUTHENTICATION_DISABLED=false
    5. Restart the admindaemon

    Greetings

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •