Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 4 of 4
  1. #1
    hamed Guest

    Default Error while Sending mail

    hi all,
    when i want to send mail from open-xchange, when i click send button, a red line appear on the screen :
    Internal error: Could not connect to SMTP host: localhost, port: 25, response: -1 (MSG-0020,619657516-12)

    and in /var/log/mail.log i have :

    Aug 26 10:30:03 localhost postfix/smtpd[16713]: connect from localhost.localdomain.com[127.0.0.1]
    Aug 26 10:30:03 localhost postfix/smtpd[16713]: fatal: non-null host address bits in "127.0.0.1/25", perhaps you should use "127.0.0.0/25" instead
    Aug 26 10:30:04 localhost postfix/master[16654]: warning: process /usr/lib/postfix/smtpd pid 16713 exit status 1
    Aug 26 10:30:04 localhost postfix/master[16654]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
    "/var/log/mail.log" 8639L, 993549C

    and this is my main.cf file :

    # See /usr/share/postfix/main.cf.dist for a commented, more complete version


    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname

    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    # TLS parameters
    smtpd_tls_cert_file = /etc/ssl/certs/eecert.pem
    smtpd_tls_key_file = /etc/ssl/private/eekey.pem
    smtpd_use_tls=yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.

    mydomain = example.com
    myhostname = mail.example.com
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    #mydestination = $myhostname, localhost.$mydomain
    relayhost =
    mynetworks = 127.0.0.1/25
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    mailbox_transport = lmtp:unix:/var/run/cyrus/socket/lmtp
    virtual_alias_domains = mysql:/etc/postfix/ox_domains.cf
    virtual_alias_maps = mysql:/etc/postfix/ox_user_aliases.cf, mysql:/etc/postfix/ox_aliases.cf, mysql:/etc/postfix/ox_resource$smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/ox_externaldomaincheck.cf
    smtpd_restriction_classes = local_only
    local_only = check_recipient_access mysql:/etc/postfix/ox_domains.cf, reject
    smtpd_recipient_restrictions = check_sender_access mysql:/etc/postfix/ox_senderrestrictions.cf, permit_sasl_authenticated, p$
    procmail_destination_concurrency_limit = 1
    procmail_destination_recipient_limit = 1
    maximal_queue_lifetime = 1d


    ... Any idea??
    Thanks in advance

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    tried to change

    mynetworks = 127.0.0.1/25
    to
    mynetworks = 127.0.0.0/25 ?

    i'm not sure you need this parameter at all if you want to send E-Mail from external computers also... this is my main.cf:

    Code:
    smtpd_banner = $myhostname - ESMTP Service
    mailbox_transport = lmtp:unix:/var/run/cyrus/socket/lmtp
    
    virtual_alias_domains = mysql:/etc/postfix/ox_domains.cf
    virtual_alias_maps = mysql:/etc/postfix/ox_user_aliases.cf, mysql:/etc/postfix/ox_aliases.cf, mysql:/etc/postfix/ox_resource_aliases.cf, mysql:/etc/postfix/ox_group_aliases.cf
    
    smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/ox_externaldomaincheck.cf
    smtpd_restriction_classes = local_only
    local_only = check_recipient_access mysql:/etc/postfix/ox_domains.cf, reject
    
    smtpd_recipient_restrictions = check_sender_access mysql:/etc/postfix/ox_senderrestrictions.cf, permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination
    smtpd_tls_cert_file = /etc/ssl/certs/eecert.pem
    smtpd_tls_key_file = /etc/ssl/private/eekey.pem
    procmail_destination_concurrency_limit = 1
    procmail_destination_recipient_limit = 1
    maximal_queue_lifetime = 1d
    alias_maps = $alias_database
    bounce_queue_lifetime = 1d
    Last edited by Martin Heiland; 08-26-2007 at 12:55 PM.

  3. #3
    hamed Guest

    Default

    Hi Martin,
    I have changed 'my_network' parameter to 127.0.0.0/25 & now it's working, thanks
    i have a question here! what does 127.0.0.0 exactly mean?!

    Thanks in advance

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    127.0.0.0 is a network address which specifies where E-Mail is accepted from. Please consult the postfix documentation for more information about that parameter.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •