New packages:

com.openexchange.config.cascade
The basic framework

com.openexchange.config.cascade.context
The context level configuration provider

com.openexchange.config.cascade.user
The user level configuration provider

These bundles should be installed in every installation. The first bundle is necessary for both admin and server installations, the other two need only be installed in the groupware osgi system.