Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 3 of 3
  1. #1
    Join Date
    Feb 2011
    Posts
    16

    Default Error: Missing Dependency: java-sun is needed by package open-xchange-server

    Hello again

    I am trying to install OX on CEntos 5.5 and I am following the installation guide step-by-step.
    When I try to install the meta-packages described in the guide. (page 16)

    Code:
    yum install mysql-server open-xchange-meta-singleserver \
    open-xchange-authentication-database open-xchange-spamhandler-default
    I get

    Code:
    open-xchange-server-6.18.0.0-20_22.1.noarch from ox has depsolving problems
      --> Missing Dependency: java-sun is needed by package open-xchange-server-6.18.0.0-20_22.1.noarch (ox)
    Error: Missing Dependency: java-sun is needed by package open-xchange-server-6.18.0.0-20_22.1.noarch (ox)
     You could try using --skip-broken to work around the problem
     You could try running: package-cleanup --problems
                            package-cleanup --dupes
                            rpm -Va --nofiles --nodigest
    I have installed Java on the server.

    If I run: rpm -qa | grep java I get

    Code:
    tzdata-java-2010l-1.el5
    java-1.6.0-openjdk-1.6.0.0-1.16.b17.el5
    java-1.4.2-gcj-compat-1.4.2.0-40jpp.115
    Also rpm -qa | grep jre gives out

    Code:
    jre-1.6.0_24-fcs
    Clearly, it complains about java-sun but I can't find what package provides java-sun.

    The whatprovides command does not find any matches. Does anyone have any suggestions, please?

    Many thanks

  2. #2
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Which guide did you follow?

    This guide http://oxpedia.org/wiki/index.php?ti...e_for_CentOS_5 requires to specify the centos meta package, which you did not specify.
    OXpedia.org - the answer to almost all questions.

  3. #3
    Join Date
    Feb 2011
    Posts
    16

    Thumbs up

    Hi Carsten

    I was following the Open-Xchange Community Edition guide for RedHat, didn't see the link for Centos.

    Meta-packages are successfully installed now.

    Thanks a lot for the help.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •