Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 7 of 7
  1. #1
    Join Date
    Feb 2011
    Location
    Canada
    Posts
    3

    Unhappy You need to enable JavaScript to access the Open-Xchange Server with Centos 5 x64

    Hi to all !

    After several hours, I managed to install open xchange Cento 5.5 x64
    I followed this guide step by step, note that installing Java runtime p is not detailed, but now I'm stuck to this message :

    You need to enable JavaScript to access the Open-Xchange Server ,

    I noticed this information, but German is not my first language, English either I'm french .

    two questions: Centos is really compatible with Open-Xchange? In this case the guide is to change.

    I understand, the new version 6.18 requires special settings to make to Apache so what should we change?

    Thank's a lot and sorry for the bad english

  2. #2
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    You just need the described apache configuration:

    http://oxpedia.org/wiki/index.php?ti...igure_services
    OXpedia.org - the answer to almost all questions.

  3. #3
    Join Date
    Feb 2011
    Location
    Canada
    Posts
    3

    Default

    Quote Originally Posted by Carsten Hoeger View Post
    You just need the described apache configuration:

    http://oxpedia.org/wiki/index.php?ti...igure_services

    thank's for the quick reply

    I copy past exactly same config
    Code:
    LoadModule proxy_ajp_module modules/mod_proxy_ajp.so
    
    <Proxy *>
    Order deny,allow
    allow from all
    </Proxy>
    
    ProxyPass /axis2 ajp://127.0.0.1:8009/axis2 smax=0 ttl=60 retry=5
    ProxyPass /ajax ajp://127.0.0.1:8009/ajax smax=0 ttl=60 retry=5
    ProxyPass /servlet ajp://127.0.0.1:8009/servlet smax=0 ttl=60 retry=5
    ProxyPass /infostore ajp://127.0.0.1:8009/infostore smax=0 ttl=60 retry=5
    ProxyPass /publications ajp://127.0.0.1:8009/publications smax=0 ttl=60 retry=5
    # next line is required for OXtender for Business Mobility only
    ProxyPass /Microsoft-Server-ActiveSync ajp://127.0.0.1:8009/Microsoft-Server-ActiveSync smax=0 ttl=60 retry=5
    # next line is required for for Microsoft Outlook 2
    ProxyPass /usm-json ajp://127.0.0.1:8009/usm-json smax=0 ttl=60 retry=5
    Firewall and selinux are Off

    I try on the server also via gnome and under root to be sure do you need I post some file ?

  4. #4
    Join Date
    Feb 2011
    Location
    Canada
    Posts
    3

    Default

    Hi !

    Thank's for the reply .
    I failed with Centos but it worked perfectly with Fedora 14.

  5. #5
    Join Date
    Jan 2013
    Posts
    1

    Default

    Hi all im experiencing the same problem on debian 6 squeeze

    ive been trawling for a while now i have done everything that the install tutorial says here

    http://oxpedia.org/wiki/index.php?ti...for_Debian_6.0

    a2enmod proxy_ajp is enabled still i get

    You need to enable JavaScript to access the Open-Xchange Server.

    Für den Zugriff auf den Open-Xchange Server müssen Sie JavaScript aktivieren.



    when i browse to "IPADDRESS"\ox6

    Could anyone help im pulling my hair out! tried litterly every peice of information i could find

    if anyone has any experiance here please let me know!

  6. #6
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    please doublecheck that *all* Apache related configuration is correct and active. This issue typically occurs if mod_rewrite is not enabled and OX specific rules are not loaded by the active site.

    Cheers
    Martin

  7. #7
    Join Date
    Feb 2013
    Posts
    3

    Default

    I am having the same problem as described. Running OpenSuse12.1 and following installation instruction for 11.0, installation is fine including the step registerdatabase.Then, I have followed the complete apache2 configuration instruction, but as said before, when trying to use the browser I get the message:

    You need to enable JavaScript to access the Open-Xchange Server.
    Für den Zugriff auf den Open-Xchange Server müssen Sie JavaScript aktivieren.


    Now, I am wondering whether there is additional logging information to trace down the problem. I also tried to continue create the default context, but it fails:

    /opt/open-xchange/sbin/createcontext -A oxadminmaster -P secret -c 1 -u oxadmin -d "Context Admin" -g Admin -s User -p secret2 -L defaultcontext -e mail@mail.org -q 1024 --access-combination-name=all
    context 1 could not be created:
    Error: Connection refused to host: localhost; nested exception is:
    java.net.ConnectException: Connection refused
    Last edited by paladin1974; 02-21-2013 at 04:28 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •