Open-Xchange Server Edition
Version : 6.20.0 Rev5 (2011-03-30 09:27:52)
Running on Debian 5.0.8, 64bit


Login from internal IP-Address is possible (OX itself works so far), but not from outside (Portforwarding). This occoured today, after changing our firewall-system from IPCop to IPfire (same settings, VPNs, and so on) last night.

I am getting strange errors here in OX-log:
Code:
SEVERE: Could not create sender to [1.70.178.9:57462] -- Socket is null, cannot connect to 1.70.178.9:57462
Apr 6, 2011 11:03:36 AM org.apache.jcs.auxiliary.lateral.socket.tcp.LateralTCPCacheManager fixService
SEVERE: Can't fix Socket is null, cannot connect to 1.70.178.9:57462
Apr 6, 2011 11:03:36 AM org.apache.jcs.auxiliary.lateral.LateralCacheRestore canFix
SEVERE: Can't fix Can't fix Socket is null, cannot connect to 1.70.178.9:57462
Strange thing is, that the IP is from a customerīs OX system, which is available through a VPN tunnel (that has to stay up 24/7).

All logs have this IP listed, so itīs not directly a problem that came with the change of the firewall, but one that now shows up after the change.

An "lsof" shows a lot of ports that forward from our subdomain for OX to the customerīs OX:

Code:
lsof -i | grep java
....
java      3086 open-xchange   32u  IPv6  12268       TCP vm-ox.domain.de:35161->vm-customergroupware.local:57461 (SYN_SENT)
java      3086 open-xchange   33u  IPv6  12473       TCP vm-ox.domain.de:46373->vm-customergroupware.local:57462 (SYN_SENT)
....
When I start/stop Apache2 I get this warnings, maybe it has something to do with the problem:
Code:
vm-ox:/etc/apache2# /etc/init.d/apache2 restart
Restarting web server: apache2[Wed Apr 06 11:06:05 2011] [warn] worker ajp://127.0.0.1:8009/axis2 already used by another worker
[Wed Apr 06 11:06:05 2011] [warn] worker ajp://127.0.0.1:8009/ajax already used by another worker
[Wed Apr 06 11:06:05 2011] [warn] worker ajp://127.0.0.1:8009/servlet already used by another worker
[Wed Apr 06 11:06:05 2011] [warn] worker ajp://127.0.0.1:8009/infostore already used by another worker
[Wed Apr 06 11:06:05 2011] [warn] worker ajp://127.0.0.1:8009/publications already used by another worker
[Wed Apr 06 11:06:05 2011] [warn] worker ajp://127.0.0.1:8009/axis2 already used by another worker
[Wed Apr 06 11:06:05 2011] [warn] worker ajp://127.0.0.1:8009/ajax already used by another worker
[Wed Apr 06 11:06:05 2011] [warn] worker ajp://127.0.0.1:8009/servlet already used by another worker
[Wed Apr 06 11:06:05 2011] [warn] worker ajp://127.0.0.1:8009/infostore already used by another worker
[Wed Apr 06 11:06:05 2011] [warn] worker ajp://127.0.0.1:8009/publications already used by another worker
How can I change the settings, that the Apache/OX (whatever) ignores other OX ports from external systems?

Thanks in advance for your help!

Sebastian