Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 5 of 5
  1. #1
    Join Date
    Mar 2011
    Posts
    13

    Default How do I reset a users open-xchange-gui-mobile-v2 settings

    Hello,

    While trying out the new open-xchange-gui-mobile-v2 (looks very good btw!) I accidentally requested a import of the global address book (43987 users...!). Now as you might imagine, this is a bit to much for my poor Iphone-4. Thus I'd like to reset this behavior but this can only be done (as it seems?) from within the mobile-gui. Is there an other way to do this? e.g. set field X or Y to NULL in the database?

    To be more clear: When I try to login into the mobile-gui (v2) it tries to load the contacts but these are far to much thus safari on the Iphone-4 crashes. I'd like to undo this behavior.

    Many thanks in advance,

    Robert.
    Last edited by masikh; 04-18-2011 at 03:28 PM.

  2. #2
    Join Date
    Apr 2011
    Location
    Olpe, Germany
    Posts
    3

    Default

    Hi Robert!

    It' right, to unsubscribe this folder you must use the Mobile Web App. Your settings will be saved on the backend and restored on any client you will use.

    To unsubscribe this folder please login to the Mobile Web App via a desktop browser like Chrome, Safari or Firefox. A desktop system should be capable of loading this amount of contacts.

    After all contacts are loaded, just unsubscribe the folder under settings->contact folders. After this, your iPhone won't load this folder on the next login.

    Btw: The next preview version of the Mobile Web App will only load a fixed maximum of contacts on the device to prevent browser crashes. For real big folders there will be a online search function. So stay tuned for further releases.

    Regards,
    Alexander

  3. #3
    Join Date
    Mar 2011
    Posts
    13

    Default

    Hello Alexander,

    Well it seems that even firefox (the desktop version, thus not mobile!) can not handle a g.a.b. with ~44K users. Most unfortunately I am stuck. I have 'spitted' (is that English?) through the database looking for a clue to reset it but...

    Any ideas (except waiting for the next release?) as how to solve this? Since this post is frequently viewed in the last week, I assume I am not the only one!

    Anyway, as usual,

    Kind regards,

    Robert Nagtegaal.

  4. #4
    Join Date
    Mar 2011
    Posts
    13

    Default

    Hello,

    Does anyone know how to fix above issue?

    Kind regards,

    Robert Nagtegaal.

  5. #5
    Join Date
    Apr 2011
    Location
    Olpe, Germany
    Posts
    3

    Default

    Hi everybody!

    The only way to reset this setting without using Mobile Web App is to remove this large folder from your Mobile Web App config in the database.

    Follow these steps to reset your settings:

    1. Open your user database, i.e. "oxdatabase_X"
    2. The table "user_attribute" holds the settings for each user using the Mobile Web App
    3. locate the table row with your user id and the name "config/mox/subscribedFolders/contacts"
    4. the value in this rows will be something like this ["6,"123","456"]
    5. delete this table row or set value to "[]"
    6. restart OX server (in case you set it to "[]" the restart should not be necessary)

    Regards,

    Alexander

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •