Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 5 of 5
  1. #1
    Join Date
    May 2011
    Posts
    13

    Default Passwort-Skript: HTTP method PUT is not supported by this URL

    Hallo

    Ich habe "open-xchange-passwordchange-script" installiert und wie in der Anleitung unter http://oxpedia.org/wiki/index.php?ti...sswordExternal beschrieben, ein Perl Skript erstellt (in der Anleitung das Example Script 1).

    Wenn ich jetzt mit einem User einlogge und das Passwort ändern will, erscheint ein PopUp (ohne dass die Seite neu geladen wird) mit der Fehlermeldung:

    Code:
    Fehlermeldung: 405 - HTTP method PUT is not supported by this URL
    In die beiden Log-Dateien "open-xchange-admin.log.0" und "open-xchange.log.0" wird nichts geschrieben.

    Hat das irgendwas mit den Java Einstellungen zu tun? Oder mit denjenigen von Apache?

    Besten Dank und Gruss
    Marco

  2. #2
    Join Date
    Feb 2007
    Location
    Dortmund, Germany
    Posts
    168

    Default

    Hast du auch das Paket open-xchange-passwordchange-servlet installiert?
    Markus Wagner
    Open-Xchange Quality Assurance

  3. #3
    Join Date
    May 2011
    Posts
    13

    Default

    Quote Originally Posted by Markus Wagner View Post
    Hast du auch das Paket open-xchange-passwordchange-servlet installiert?
    Nein. Werde ich versuchen. Besten Dank für Deine Hilfe!

    EDIT: habe gerade noch ein andere Paket bezgl. Passwort gefunden: "open-xchange-passwordchange-database". Brauche ich das?

    Gruss
    Marco
    Last edited by 46AND2; 05-23-2011 at 08:34 PM.

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    das -database Paket brauchst du, wenn das Passwort des Benutzers in der MySQL DB geändert werden soll, wenn du ein externes Script aufrufen willst, ist das -script Paket schon sinnvoll.

    Gruß

  5. #5
    Join Date
    May 2011
    Posts
    13

    Default

    Quote Originally Posted by Martin Braun View Post
    das -database Paket brauchst du, wenn das Passwort des Benutzers in der MySQL DB geändert werden soll, wenn du ein externes Script aufrufen willst, ist das -script Paket schon sinnvoll.
    Ok, vielen lieben Dank für die Hilfe. Ich brauche - so scheint es nun - das andere Skript gar nicht, sondern das -database und das -servlet.

    Besten Dank und Gruss
    Marco

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •