Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Join Date
    Dec 2009
    Location
    Finland
    Posts
    13

    Default Oxtender2 fails to create new mail profile

    I have installed Oxtender2 already for many computers and on this one I can't finish the Oxtender2 installation.
    User is logged as administrator and there's no any antivir/firewall/application control software blocking.
    Here is the error log:
    Code:
    2011-07-01 08:46:20.860 Verbose [1] TextWriterTraceListener attached to Logger.
    2011-07-01 08:46:21.047 Verbose [1] ConsoleTraceListener attached to Logger.
    2011-07-01 08:46:21.047 Info    [1] OXProfileHelper starting.
    2011-07-01 08:46:21.047 Info    [1] Current directory is C:\WINDOWS\system32
    2011-07-01 08:46:21.047 Info    [1] Executing assembly: OXProfileHelper, Version=7.0.19.1412, Culture=neutral, PublicKeyToken=72e3368c86d08802
    2011-07-01 08:46:21.047 Info    [1] Assembly location: C:\Program Files\Open-Xchange\OXtender 2 for Microsoft Outlook\Profile\OXProfileHelper.exe
    2011-07-01 08:46:21.047 Info    [1] Processing commandline arguments.
    2011-07-01 08:46:21.047 Verbose [1] About to set 'profilename' to 'OXtender 2'...
    2011-07-01 08:46:21.076 Info    [1] Successfully set 'profilename' to 'OXtender 2'.
    2011-07-01 08:46:21.076 Verbose [1] About to set 'serverurl' to 'http://server.fi'...
    2011-07-01 08:46:21.076 Info    [1] Successfully set 'serverurl' to 'http://server.fi'.
    2011-07-01 08:46:21.076 Verbose [1] About to set 'username' to 'firstname.lastname'...
    2011-07-01 08:46:21.090 Info    [1] Successfully set 'username' to 'firstname.lastname'.
    2011-07-01 08:46:21.090 Verbose [1] About to set 'password' to '***'...
    2011-07-01 08:46:21.090 Info    [1] Successfully set 'password' to '***'.
    2011-07-01 08:46:21.090 Verbose [1] About to set 'overwriteprofile' to 'false'...
    2011-07-01 08:46:21.090 Info    [1] Successfully set 'overwriteprofile' to 'false'.
    2011-07-01 08:46:21.090 Verbose [1] About to set 'defaultprofile' to 'false'...
    2011-07-01 08:46:21.090 Info    [1] Successfully set 'defaultprofile' to 'false'.
    2011-07-01 08:46:21.090 Verbose [1] About to set 'showui' to '1'...
    2011-07-01 08:46:21.090 Info    [1] Successfully set 'showui' to '1'.
    2011-07-01 08:46:21.090 Verbose [1] About to set 'picklogonprofile' to '1'...
    2011-07-01 08:46:21.090 Info    [1] Successfully set 'picklogonprofile' to '1'.
    2011-07-01 08:46:21.090 Info    [1] Commandline arguments processed successfully.
    2011-07-01 08:46:21.090 Info    [1] Commandline was "C:\Program Files\Open-Xchange\OXtender 2 for Microsoft Outlook\Profile\OXProfileHelper.exe" -profilename "OXtender 2" -serverurl "http://server.fi" -username "firstname.lastname" -password "***" -overwriteprofile false -defaultprofile false -showui 1 -picklogonprofile 1
    2011-07-01 08:46:21.119 Info    [1] About to create mail profile...
    2011-07-01 08:46:21.448 Verbose [1] Searching for an existing profile with name 'OXtender 2'...
    2011-07-01 08:46:21.491 Info    [1] No existing profile with name 'OXtender 2' found.
    2011-07-01 08:46:21.491 Verbose [1] Adding profile 'OXtender 2' to profiles collection...
    2011-07-01 08:46:21.506 Info    [1] Profile 'OXtender 2' added successfully.
    2011-07-01 08:46:21.506 Verbose [1] About to add "OXSTOR_SVC" service to new profile...
    2011-07-01 08:46:21.606 Error   [1] Error adding "OXSTOR_SVC" service: Could not add a service
    2011-07-01 08:46:21.692 Verbose [1] Exception details: System.Runtime.InteropServices.COMException (0x8004010F): Could not add a service
       at ProfMan.ServicesClass.Add(String ServiceName, String DisplayName, Boolean ShowUI, Int32 ParentHandle)
       at OpenXchange.OXProfileHelper.Program.CreateProfile(Config config)
    Server and usernames has been changed to protect the innocent

  2. #2
    Join Date
    Apr 2011
    Posts
    72

    Default

    Hi Wilis,

    it's a known issue but did you try first to deinstall the OXtender2 and then try again to install, maybe this helps...

  3. #3
    Join Date
    Dec 2009
    Location
    Finland
    Posts
    13

    Default

    Yes I have tried to uninstall Oxtender2 and removed all references that I could find from disk and registry.
    Also I have killed all unnecessary processes and disabled bluetooth etc. Nothing helps.
    Do you have any idea what may be causing this?

  4. #4
    Join Date
    Apr 2011
    Posts
    72

    Default

    For further investigation we need the msi-logfile. Please activate the msi-logging and then try once again to install the OXtender2.

    1. First activate msi-logging -> http://go.microsoft.com/?linkid=97230302
    - If you already enabled the msi-logging skip the first step.
    2. Install the OXtender2
    3. Open Windows Explorer -> go to %TEMP%
    4. Provide msi-logfile -> MSI*.LOG

  5. #5
    Join Date
    Dec 2009
    Location
    Finland
    Posts
    13

    Default

    Here's the log file. Names, passwords etc have been changed.
    Attached Files Attached Files

  6. #6
    Join Date
    Apr 2011
    Posts
    72

    Default

    Is it maybe possible to have a look (teamviewer-session) at this system?! Because we're not able to reproduce this issue on our test environment. Please send me a private message...

  7. #7
    Join Date
    Dec 2009
    Location
    Finland
    Posts
    13

    Default

    Now I have two computers where I can't install Oxtender2. WinXP and Win7 (does UAC block this?) machines.
    Could these installation problems have something to do with these errors in open-xchange.log.0:
    Code:
    Jul 6, 2011 1:41:52 PM com.openexchange.tools.exceptions.DefaultLoggingLogic codeError
    SEVERE: Coding Error: SVL-0002 Category=8 Message=Missing the following request parameter: [folder] exceptionID=1553100194-528985
    SVL-0002 Category=8 Message=Missing the following request parameter: [folder] exceptionID=1553100194-528985
            at com.openexchange.file.storage.json.actions.files.AJAXInfostoreRequest.require(AJAXInfostoreRequest.java:129)
            at com.openexchange.file.storage.json.actions.files.UpdatesAction.handle(UpdatesAction.java:68)
            at com.openexchange.file.storage.json.actions.files.AbstractFileAction.perform(AbstractFileAction.java:187)
            at com.openexchange.multiple.AJAXActionServiceAdapterHandler.performRequest(AJAXActionServiceAdapterHandler.java:121)
            at com.openexchange.ajax.Multiple.doAction(Multiple.java:214)
            at com.openexchange.ajax.Multiple.parseActionElement(Multiple.java:173)
            at com.openexchange.ajax.Multiple.doPut(Multiple.java:125)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:619)
            at com.openexchange.ajax.AJAXServlet.service(AJAXServlet.java:413)
            at com.openexchange.ajax.SessionServlet.service(SessionServlet.java:219)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
            at com.openexchange.ajp13.najp.AJPv13RequestHandlerImpl.doServletService(AJPv13RequestHandlerImpl.java:523)
            at com.openexchange.ajp13.AJPv13Request.response(AJPv13Request.java:134)
            at com.openexchange.ajp13.najp.AJPv13RequestHandlerImpl.createResponse(AJPv13RequestHandlerImpl.java:335)
            at com.openexchange.ajp13.najp.AJPv13ConnectionImpl.createResponse(AJPv13ConnectionImpl.java:227)
            at com.openexchange.ajp13.najp.AJPv13Task.call(AJPv13Task.java:352)
            at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
            at java.util.concurrent.FutureTask.run(FutureTask.java:123)
            at com.openexchange.threadpool.internal.CustomThreadPoolExecutor$Worker.runTask(CustomThreadPoolExecutor.java:750)
            at com.openexchange.threadpool.internal.CustomThreadPoolExecutor$Worker.run(CustomThreadPoolExecutor.java:776)
            at java.lang.Thread.run(Thread.java:595)
    That has something to do with Infostore?

    And
    Code:
    Jul 6, 2011 1:56:56 PM com.openexchange.database.internal.ConnectionLifecycle validate
    WARNING: DBP-0012 Category=5 Message=Connection used for 3280 milliseconds. exceptionID=1553100194-529660
    DBP-0012 Category=5 Message=Connection used for 3280 milliseconds. exceptionID=1553100194-529660
            at com.openexchange.database.internal.DBPoolingExceptionFactory.createException(DBPoolingExceptionFactory.java:76)
            at com.openexchange.database.internal.DBPoolingExceptionFactory.createException(DBPoolingExceptionFactory.java:62)
            at com.openexchange.exceptions.Exceptions.create(Exceptions.java:141)
            at com.openexchange.exceptions.Exceptions.create(Exceptions.java:145)
            at com.openexchange.exceptions.Exceptions.create(Exceptions.java:149)
            at com.openexchange.database.DBPoolingExceptionCodes.create(DBPoolingExceptionCodes.java:211)
            at com.openexchange.database.internal.ConnectionLifecycle.validate(ConnectionLifecycle.java:186)
            at com.openexchange.pooling.ReentrantLockPool.back(ReentrantLockPool.java:179)
            at com.openexchange.pooling.ReentrantLockPool.back(ReentrantLockPool.java:147)
            at com.openexchange.database.internal.ReplicationMonitor.backAndIncrementTransaction(ReplicationMonitor.java:216)
            at com.openexchange.database.internal.wrapping.JDBC3ConnectionReturner.close(JDBC3ConnectionReturner.java:102)
            at com.openexchange.database.internal.DatabaseServiceImpl.back(DatabaseServiceImpl.java:99)
            at com.openexchange.database.internal.DatabaseServiceImpl.backWritable(DatabaseServiceImpl.java:190)
            at com.openexchange.usm.database.ox.OXDBService.backWritable(OXDBService.java:106)
            at com.openexchange.usm.api.database.EncapsulatedConnection.close(EncapsulatedConnection.java:92)
            at com.openexchange.usm.util.Toolkit.close(Toolkit.java:79)
            at com.openexchange.usm.session.impl.DataObjectStorage.put(DataObjectStorage.java:185)
            at com.openexchange.usm.session.impl.SessionImpl.internalStoreCachedDataObjects(SessionImpl.java:540)
            at com.openexchange.usm.session.impl.SessionImpl.storeCachedDataObjects(SessionImpl.java:528)
            at com.openexchange.usm.session.sync.FolderElementsStorage.storeServerData(FolderElementsStorage.java:95)
            at com.openexchange.usm.session.sync.ContentSyncerSupport.storeDataObjectsAndBuildClientResult(ContentSyncerSupport.java:76)
            at com.openexchange.usm.session.sync.IncrementalContentSyncer.syncChangesWithServer(IncrementalContentSyncer.java:262)
            at com.openexchange.usm.session.impl.SessionImpl.syncChangesWithServer(SessionImpl.java:284)
            at com.openexchange.usm.connector.commands.SyncUpdateHandler.computeSyncUpdate(SyncUpdateHandler.java:242)
            at com.openexchange.usm.connector.commands.SyncUpdateHandler.handleRequest(SyncUpdateHandler.java:119)
            at com.openexchange.usm.json.USMJSONServlet.doPut(USMJSONServlet.java:228)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:619)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
            at com.openexchange.ajp13.najp.AJPv13RequestHandlerImpl.doServletService(AJPv13RequestHandlerImpl.java:523)
            at com.openexchange.ajp13.AJPv13Request.response(AJPv13Request.java:134)
            at com.openexchange.ajp13.najp.AJPv13RequestHandlerImpl.createResponse(AJPv13RequestHandlerImpl.java:335)
            at com.openexchange.ajp13.najp.AJPv13ConnectionImpl.createResponse(AJPv13ConnectionImpl.java:227)
            at com.openexchange.ajp13.najp.AJPv13Task.call(AJPv13Task.java:352)
            at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
            at java.util.concurrent.FutureTask.run(FutureTask.java:123)
            at com.openexchange.threadpool.internal.CustomThreadPoolExecutor$Worker.runTask(CustomThreadPoolExecutor.java:750)
            at com.openexchange.threadpool.internal.CustomThreadPoolExecutor$Worker.run(CustomThreadPoolExecutor.java:776)
            at java.lang.Thread.run(Thread.java:595)
    Do I have some db timeout set too low?

    These errors repeat all day long, but everything SEEMS to work fine. Except the installation problems of course.

    I will setup the Teamviewer on WinXP computer tomorrow and I'll pm you then.

    I'm also updating the server to the latest version during next weekend. Server is running v.6.20 rev8 at the moment.

  8. #8
    Join Date
    Apr 2011
    Posts
    72

    Default

    Wilis, how about a teamviewer session ;-)

  9. #9
    Join Date
    Apr 2011
    Posts
    72

    Default

    Hi,
    the next version will fix the problem using multiple accounts in the OXtender 2 profile.

    However, we're still keen to know why profile creation fails at your setup with the 0x8004010F exception. Sadly, we're unable to reproduce the issue here, so it would be very nice if we could establish a Teamviewer session on the system where the error occurs as soon as possible. Maybe we can investigate and fix this issue for the next release, too.

  10. #10
    Join Date
    Dec 2009
    Location
    Finland
    Posts
    13

    Default

    I don't have permissions to send you a private message. But if it's okay to you we could have a teamviewer session after 13:30 GMT+3 (Finland) tomorrow.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •