Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 7 of 7
  1. #1
    Join Date
    Jul 2011
    Posts
    7

    Default Mailserver configuration

    Hello,

    I've installed an Open-Xchange Server 6 on Debian GNU / Linux 6.0 as described in the tutorial from oxpedia.org. After the second successful installation I am now so far that I would also like to install a mail server with use of ox6.

    Unfortunately, I doesn`t find any actual instructions. Further, I know from the Open-Xchange™ Server 6
    Installation and Administration Guide that an OX server needs to be fulfilled by an IMAP server.
    But nothing more...

    Now I want to know if I only need an imap-server (like dovecot) or do I need an mail-mta like postfix, too?

    And does anyone have any howtos for the configuration of a mail server with ox6?

    I would be very grateful to you for any help.

  2. #2
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    501

    Default

    Hi,

    Open-Xchange Server just acts as a IMAP (and if configured SIEVE) client. So the mailservices (IMAP and SMTP) need to be configured independent. So for example using Dovecot and Postfix as you mentioned. This is not documented in our Wiki or manual specifically because there are no special configurations needed for use with Open-Xchange Server.
    Just find a HOWTO for configuring an imap server of your choice together with Postfix on your Debian system and set it up.

    Wolfgang

  3. #3
    Join Date
    Jul 2011
    Posts
    7

    Default

    Thank you once.

    Now I've set up postfix and dovecot, which also works. But now, when I try to add an email-account to my first contextadmin-user, I get the same error message than before when I log in from browser:

    It couldn`t be established a connection to the mailserver.
    The module is disabled.

    open-xchange.log.0:
    Aug 8, 2011 10:01:16 PM com.openexchange.tools.exceptions.DefaultLoggingLo gic setupError
    SEVERE: Setup Error: MSG-0014 Category=10 Message=No mail account exists for admin user in context 1 exceptionID=-276762451-190
    MSG-0014 Category=10 Message=No mail account exists for admin user in context 1 exceptionID=-276762451-190
    II tried with the following cmd:
    /opt/open-xchange/sbin/changeuser -c 1 -A oxadmin_1 -P pass -u oxadmin_1 --smtpserver my_serverip --imapserver my_serverip --imaplogin user@mydomain.com

    After that, nothing changed. It looks as it wouldn`t even try to log on imap-server.

    Thanks for help.

  4. #4
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    501

    Default

    Please check the property
    com.openexchange.mail.adminMailLoginEnabled
    in /opt/open-xchange/etc/groupware/mail.properties

  5. #5
    Join Date
    Jul 2011
    Posts
    7

    Default

    Thank you Wolfgang. Now it `s working.

    I have further questions ...

    Is it possible to define a return adress on each Mail-Account (as in ms-outlook for example)?
    The background is that I have a domain with an "ö" within and if I'm not mistaken, a configuration with an "ö" isn`t currently possible.
    However, the recipient should have the reply address with the "ö", if he gets an email from me.

    Thanks for help.

  6. #6
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    501

    Default

    IDN domain names should be supported. Where do you encounter issues? You should be able to use umlauts everywhere.

  7. #7
    Join Date
    Jul 2011
    Posts
    7

    Default

    I had several problems with the installation of the mail server!
    I'm temporarily working to make the base installation with a different domain.

    The idn-domain then I'll set up an additional domain, and then report it.

    Thank you first!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •