Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 3 of 3
  1. #1
    Join Date
    Sep 2011
    Posts
    1

    Default OXtender for Business Mobility - Login issue

    Cannot login using SonyEricsson Xperia X10i, Android 2.3.3.
    Open Xchange Server Version: 6.20.0-Rev24

    On the phone, creating EAS account with native app and receiving error "Username or password incorrect"
    (Web browser access works fine using login john@example.com & PWD)
    using following fields on phone:

    - Domain: example.com
    - Username: john
    - Password: PWD
    - Server: ox1.host.com
    - use SSL (NO)

    email log file shows:
    AbstractSyncService Testing EAS: ox1.host.com, example.com\john, ssl=0
    AbstractSyncService Validation (OPTIONS) response:403
    AbstractSyncService Authentification failed

    If I put all the login info into the Username field, the email log looks better, except in every case a "\" is added.
    - Domain:
    - Username: john@example.com
    - Password: PWD
    - Server: ox1.host.com
    - use SSL (NO)

    email log file shows:
    AbstractSyncService Testing EAS: ox1.host.com, \john@example.com, ssl=0
    AbstractSyncService Validation (OPTIONS) response:403
    AbstractSyncService Authentification failed

    I suspect this backslash is causing the failed authentification.
    Any tips on how to correct this on client or server side would be greatly appreciated.

  2. #2
    Martin Lasarsch is offline Open-Xchange Professional Services
    Join Date
    Aug 2011
    Posts
    3

    Default

    look in your apache logs:
    10.10.0.5 - - [07/Sep/2011:16:27:47 +0200] "POST /Microsoft-Server-ActiveSync?Cmd=Sync&User=testuser&DeviceId=HTCxxxx xxxxxxxx&DeviceType=htcpyramid HTTP/1.1" 200 63 "-" "Android-EAS/4.0.xxxxxxxxxxxxx"

    try:
    http://myserver.org/Microsoft-Server-ActiveSync

    If configured right you should get back a 405 message.

  3. #3
    Martin Lasarsch is offline Open-Xchange Professional Services
    Join Date
    Aug 2011
    Posts
    3

    Default

    from the mobile documentation (chapter 2.5): if you have a @ in your username, you have to use it like this (for john@example.com):

    Username: example.com\john

    If the user is in the defaultcontext, without @:
    Username: defaultcontext\john

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •